summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-05-21 09:49:07 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2023-05-21 09:56:45 +0200
commitf3dd1c0fd0113fe0af9b0b16227e746facb17384 (patch)
treeb71719ee2d1052affc729acffe71e0ce34e6c3ec /dev-java/ant-eclipse-ecj
parentmedia-sound/ardour: add media-libs/suil[X] usedep (diff)
downloadgentoo-f3dd1c0fd0113fe0af9b0b16227e746facb17384.tar.gz
gentoo-f3dd1c0fd0113fe0af9b0b16227e746facb17384.tar.bz2
gentoo-f3dd1c0fd0113fe0af9b0b16227e746facb17384.zip
dev-java/ant-eclipse-ecj: drop 4.22-r2, 4.25
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/ant-eclipse-ecj')
-rw-r--r--dev-java/ant-eclipse-ecj/Manifest2
-rw-r--r--dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.22-r2.ebuild53
-rw-r--r--dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.25.ebuild53
-rw-r--r--dev-java/ant-eclipse-ecj/files/ecj-4.227
-rw-r--r--dev-java/ant-eclipse-ecj/files/ecj-4.257
5 files changed, 0 insertions, 122 deletions
diff --git a/dev-java/ant-eclipse-ecj/Manifest b/dev-java/ant-eclipse-ecj/Manifest
index ca4978dfd113..aa67f4731d80 100644
--- a/dev-java/ant-eclipse-ecj/Manifest
+++ b/dev-java/ant-eclipse-ecj/Manifest
@@ -1,4 +1,2 @@
DIST ecjsrc-4.15.jar 2166228 BLAKE2B 794e0ba1a19b325e2dd8ad0b288ccbe04866627670b50d39dd327c13fe1fac56200eb3a6c1c3d1af043cad795508b9b714a5243049671414b5a62a97725d3297 SHA512 ada55b2522cf26570f0cd43f415eb5cf20e6840f83dadc72e1ae474ebf10eadca73f9fa3d1db51e13fd2762c38cd3e3567db3c7840d43ae3d8665ebe35e1889d
-DIST ecjsrc-4.22.jar 2358194 BLAKE2B e091050297b4556c38adfb01fb1e43e13644af1b3c2b30a93cfe3fdbb55050a0f7709081c7406d384d7141de67a954253aa26cdbb45f56327b16ee5ddd5e82a7 SHA512 cd52a72aecded032625ee83581ac565e1e96f8d26ecfc76e982274fd3d6238f1e7f22576855589b021e9a5ef67686b9b75e010c4e2033a8b7f6e7c9b1ff7eb4c
-DIST ecjsrc-4.25.jar 2340770 BLAKE2B e1e82356984a72e7ebbd5ace2ccbaf885c7acfdaf410b2386fa0a143f85e4431cfa2f5d254197eb56203c48505bc7dbe264664815b572c725ac5814645254776 SHA512 b475d58ef6a03e4bbf7e0f440edcbdd61e0548f68e48c7762973f60850a14fc1c234bb9a41be404ed06db14a273646f1dc5ad7effd4c7146b46f40a52850f236
DIST ecjsrc-4.26.jar 2347137 BLAKE2B 22e627178fe35f34cee7ba63e740ef2699bca691d460c81e97c2f18c197042cc0d901eea988331b3fa2ac7daa87daef9ee90bc1e62901935a6f2f3fe5f1e8534 SHA512 e53534160e6a2cdc8c5db7caec617d5671eb59954a86b9dcb36a514024c3205167c8416560796ce61d1aa188f551660f3bfd8eab46fefe9111c8f0b7a977342f
diff --git a/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.22-r2.ebuild b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.22-r2.ebuild
deleted file mode 100644
index a2d55cda8ca1..000000000000
--- a/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.22-r2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-pkg-simple prefix
-
-DMF="R-${PV}-202111241800"
-
-DESCRIPTION="Ant Compiler Adapter for Eclipse Java Compiler"
-HOMEPAGE="https://www.eclipse.org/"
-SRC_URI="https://download.eclipse.org/eclipse/downloads/drops4/${DMF}/ecjsrc-${PV}.jar"
-
-LICENSE="EPL-1.0"
-KEYWORDS="amd64 ~ppc64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
-SLOT="4.22"
-IUSE=""
-
-CDEPEND="~dev-java/eclipse-ecj-${PV}:${SLOT}
- dev-java/ant-core:0"
-# though technically both could be set to 1.8 and it would
-# compile using jdk 11+, it would not compile using jdk 1.8
-# because eclipse ecj has min jdk 11
-RDEPEND="${CDEPEND}
- >=virtual/jre-11:*"
-DEPEND="${CDEPEND}
- >=virtual/jdk-17:*"
-BDEPEND="app-arch/unzip"
-
-JAVA_GENTOO_CLASSPATH="ant-core,eclipse-ecj-${SLOT}"
-
-src_prepare() {
- default
-
- # Remove everything but the Ant component.
- find org -type f ! -path "org/eclipse/jdt/internal/antadapter/*" ! -name "JDTCompilerAdapter.java" -delete || die
-
- rm build.xml || die
-}
-
-src_compile() {
- java-pkg-simple_src_compile
- find org -type f ! -name "*.java" | xargs jar uvf "${PN}.jar" || die "jar update failed"
-}
-
-src_install() {
- java-pkg-simple_src_install
- insinto /usr/share/java-config-2/compiler
- doins "${FILESDIR}/ecj-${SLOT}"
- eprefixify "${ED}"/usr/share/java-config-2/compiler/ecj-${SLOT}
-}
diff --git a/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.25.ebuild b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.25.ebuild
deleted file mode 100644
index 22c9edfdafa4..000000000000
--- a/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.25.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-pkg-simple prefix
-
-DMF="R-${PV}-202208311800"
-
-DESCRIPTION="Ant Compiler Adapter for Eclipse Java Compiler"
-HOMEPAGE="https://www.eclipse.org/"
-SRC_URI="https://download.eclipse.org/eclipse/downloads/drops4/${DMF}/ecjsrc-${PV}.jar"
-
-LICENSE="EPL-1.0"
-KEYWORDS="amd64 ~ppc64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
-SLOT="4.25"
-IUSE=""
-
-CDEPEND="~dev-java/eclipse-ecj-${PV}:${SLOT}
- dev-java/ant-core:0"
-# though technically both could be set to 1.8 and it would
-# compile using jdk 11+, it would not compile using jdk 1.8
-# because eclipse ecj has min jdk 11
-RDEPEND="${CDEPEND}
- >=virtual/jre-11:*"
-DEPEND="${CDEPEND}
- >=virtual/jdk-17:*"
-BDEPEND="app-arch/unzip"
-
-JAVA_GENTOO_CLASSPATH="ant-core,eclipse-ecj-${SLOT}"
-
-src_prepare() {
- default
-
- # Remove everything but the Ant component.
- find org -type f ! -path "org/eclipse/jdt/internal/antadapter/*" ! -name "JDTCompilerAdapter.java" -delete || die
-
- rm build.xml || die
-}
-
-src_compile() {
- java-pkg-simple_src_compile
- find org -type f ! -name "*.java" | xargs jar uvf "${PN}.jar" || die "jar update failed"
-}
-
-src_install() {
- java-pkg-simple_src_install
- insinto /usr/share/java-config-2/compiler
- doins "${FILESDIR}/ecj-${SLOT}"
- eprefixify "${ED}"/usr/share/java-config-2/compiler/ecj-${SLOT}
-}
diff --git a/dev-java/ant-eclipse-ecj/files/ecj-4.22 b/dev-java/ant-eclipse-ecj/files/ecj-4.22
deleted file mode 100644
index 57e76b76c539..000000000000
--- a/dev-java/ant-eclipse-ecj/files/ecj-4.22
+++ /dev/null
@@ -1,7 +0,0 @@
-JAVAC="@GENTOO_PORTAGE_EPREFIX@/usr/bin/ecj-4.22"
-PACKAGE="=dev-java/ant-eclipse-ecj-4.22*"
-SUPPORTED_TARGET="1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 9 10 11 12 13 14 15 16 17"
-SUPPORTED_SOURCE="1.3 1.4 1.5 1.6 1.7 1.8 9 10 11 12 13 14 15 16 17"
-ANT_BUILD_COMPILER="org.eclipse.jdt.core.JDTCompilerAdapter"
-ANT_BUILD_COMPILER_DEPS="eclipse-ecj-4.22,ant-eclipse-ecj-4.22"
-GENERATION="2"
diff --git a/dev-java/ant-eclipse-ecj/files/ecj-4.25 b/dev-java/ant-eclipse-ecj/files/ecj-4.25
deleted file mode 100644
index b1f3ece05dd7..000000000000
--- a/dev-java/ant-eclipse-ecj/files/ecj-4.25
+++ /dev/null
@@ -1,7 +0,0 @@
-JAVAC="@GENTOO_PORTAGE_EPREFIX@/usr/bin/ecj-4.25"
-PACKAGE="=dev-java/ant-eclipse-ecj-4.25*"
-SUPPORTED_TARGET="1.1 1.2 1.3 1.4 1.5 1.6 1.7 1.8 9 10 11 12 13 14 15 16 17 18"
-SUPPORTED_SOURCE="1.3 1.4 1.5 1.6 1.7 1.8 9 10 11 12 13 14 15 16 17 18"
-ANT_BUILD_COMPILER="org.eclipse.jdt.core.JDTCompilerAdapter"
-ANT_BUILD_COMPILER_DEPS="eclipse-ecj-4.25,ant-eclipse-ecj-4.25"
-GENERATION="2"