summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/hawtjni-runtime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/hawtjni-runtime')
-rw-r--r--dev-java/hawtjni-runtime/Manifest1
-rw-r--r--dev-java/hawtjni-runtime/hawtjni-runtime-1.10.ebuild30
-rw-r--r--dev-java/hawtjni-runtime/metadata.xml8
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-java/hawtjni-runtime/Manifest b/dev-java/hawtjni-runtime/Manifest
new file mode 100644
index 000000000000..39048ac0e279
--- /dev/null
+++ b/dev-java/hawtjni-runtime/Manifest
@@ -0,0 +1 @@
+DIST hawtjni-project-1.10.tar.gz 1602839 SHA256 364c271819b7907e404dee939fc2a3f0f5ea860f2e81810d631f59467f006115 SHA512 3bd94d20bf2d8953c60753aa404077c96c93704c2bd5bebfb5fe790fc29e15d97f6172706f06cea13c4806b652405ccfef824cccf76ff018dafb7262ff845490 WHIRLPOOL 9d6a0fa421d5609d74c13ba39afc2bfd94174474557a0189a530a5c8e5bb9ab0fdf30199a2b3fd4b99c8a068a713357dc1223250182ab0b16fed61c4ee289d1e
diff --git a/dev-java/hawtjni-runtime/hawtjni-runtime-1.10.ebuild b/dev-java/hawtjni-runtime/hawtjni-runtime-1.10.ebuild
new file mode 100644
index 000000000000..8c12be844710
--- /dev/null
+++ b/dev-java/hawtjni-runtime/hawtjni-runtime-1.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="hawtjni-project-${PV}"
+
+DESCRIPTION="A JNI code generator based on the generator used by the Eclipse SWT project"
+HOMEPAGE="https://github.com/fusesource/hawtjni"
+SRC_URI="https://github.com/fusesource/hawtjni/archive/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/hawtjni-${MY_P}/${PN}/src"
+JAVA_SRC_DIR="main/java"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc ../../{changelog,notice,readme}.md
+}
diff --git a/dev-java/hawtjni-runtime/metadata.xml b/dev-java/hawtjni-runtime/metadata.xml
new file mode 100644
index 000000000000..4d45ef179a0f
--- /dev/null
+++ b/dev-java/hawtjni-runtime/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="github">fusesource/hawtjni</remote-id>
+ </upstream>
+</pkgmetadata>