summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/stax-ex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/stax-ex')
-rw-r--r--dev-java/stax-ex/Manifest2
-rw-r--r--dev-java/stax-ex/files/build.xml-1.017
-rw-r--r--dev-java/stax-ex/metadata.xml5
-rw-r--r--dev-java/stax-ex/stax-ex-1.0-r1.ebuild48
-rw-r--r--dev-java/stax-ex/stax-ex-1.0-r3.ebuild34
-rw-r--r--dev-java/stax-ex/stax-ex-1.0.ebuild48
-rw-r--r--dev-java/stax-ex/stax-ex-1.7.6.ebuild25
7 files changed, 179 insertions, 0 deletions
diff --git a/dev-java/stax-ex/Manifest b/dev-java/stax-ex/Manifest
new file mode 100644
index 000000000000..1271d5a7b131
--- /dev/null
+++ b/dev-java/stax-ex/Manifest
@@ -0,0 +1,2 @@
+DIST stax-ex-1.0-src.tar.gz 15446 SHA256 c737665a8ead77f440ad439319a6c6bc6bfdaaa6a15022721731d2b8268889f9 SHA512 acb58c7b182c7aced70099027af8e29b03e42e11f97104a75dfcbe8fad6f989733d67d31c203a95072f04d7e008240fdba59b5abfb6c5362268e12c138204938 WHIRLPOOL bc49fcde63ed63f46069032bd9a5502be3d2298ae0d350222793fd5e7dbc6f1832f05434b788ad6ccdc13fe212cba20b14fed360420011e2cac1a11941cccb00
+DIST stax-ex-1.7.6-sources.jar 49384 SHA256 cbb9af50961e22b4f3227b96adcc130c9c4581b65cbfa7d89628643189e76e71 SHA512 74bff2e094d29f63fb718c249b7e0fc004ca00e7f374af6634484d0c96ee8f1dbfd793706906e375b473b86b34e7a2c55c1d6b65a1d1b10b0125498b9365efe0 WHIRLPOOL eb86b23ce0a0c9eb088c642fa9f4e0a41e9b624239dd0ea67eb5cba6fe3432f9edc9d1321ecbbe84678d781b82790d3b958a4e794b03b365247b4b6d3d0a1602
diff --git a/dev-java/stax-ex/files/build.xml-1.0 b/dev-java/stax-ex/files/build.xml-1.0
new file mode 100644
index 000000000000..d69c84d82636
--- /dev/null
+++ b/dev-java/stax-ex/files/build.xml-1.0
@@ -0,0 +1,17 @@
+<?xml version="1.0"?>
+<project name="stax-ex" default="jar" basedir=".">
+ <target name="compile">
+ <mkdir dir="build"/>
+ <javac debug="false" srcdir="src" destdir="build" encoding="UTF-8">
+ <classpath>
+ <pathelement path="${classpath}"/>
+ <fileset dir="lib/" includes="**/*.jar"/>
+ </classpath>
+ </javac>
+ </target>
+ <target name="jar" depends="compile">
+ <jar destfile="stax-ex.jar">
+ <fileset dir="build" includes="**/*.class"/>
+ </jar>
+ </target>
+</project>
diff --git a/dev-java/stax-ex/metadata.xml b/dev-java/stax-ex/metadata.xml
new file mode 100644
index 000000000000..250f2d1940ea
--- /dev/null
+++ b/dev-java/stax-ex/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/stax-ex/stax-ex-1.0-r1.ebuild b/dev-java/stax-ex/stax-ex-1.0-r1.ebuild
new file mode 100644
index 000000000000..ac96577d2276
--- /dev/null
+++ b/dev-java/stax-ex/stax-ex-1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="Extensions to complement JSR-173 StAX API"
+HOMEPAGE="http://stax-ex.dev.java.net/"
+SRC_URI="https://stax-ex.dev.java.net/files/documents/4480/44372/${P}-src.tar.gz"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+
+IUSE=""
+
+COMMON_DEPEND="java-virtuals/jaf
+ java-virtuals/stax-api"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEPEND}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd "${S}"
+ # build.xml is from maven-1 and tries to download jars to /root/.maven/
+ rm -f build.xml || die
+ cp "${FILESDIR}/build.xml-${PV}" build.xml || die
+
+ mkdir "${S}/lib" || die
+ cd "${S}/lib"
+ java-pkg_jar-from --virtual jaf
+ java-pkg_jar-from --virtual stax-api
+
+}
+
+src_install() {
+
+ java-pkg_dojar "stax-ex.jar"
+
+ use source && java-pkg_dosrc src/java/*
+
+}
diff --git a/dev-java/stax-ex/stax-ex-1.0-r3.ebuild b/dev-java/stax-ex/stax-ex-1.0-r3.ebuild
new file mode 100644
index 000000000000..f53b107d3d25
--- /dev/null
+++ b/dev-java/stax-ex/stax-ex-1.0-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Extensions to complement JSR-173 StAX API"
+HOMEPAGE="http://stax-ex.java.net/"
+SRC_URI="https://stax-ex.java.net/files/documents/4480/44372/${P}-src.tar.gz"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+IUSE=""
+
+COMMON_DEPEND="java-virtuals/jaf:0
+ java-virtuals/stax-api:0"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEPEND}"
+
+JAVA_GENTOO_CLASSPATH="jaf,stax-api"
+
+S="${WORKDIR}/${P}"
+
+src_prepare() {
+ rm "${S}"/build.xml || die
+}
diff --git a/dev-java/stax-ex/stax-ex-1.0.ebuild b/dev-java/stax-ex/stax-ex-1.0.ebuild
new file mode 100644
index 000000000000..7312f44ea897
--- /dev/null
+++ b/dev-java/stax-ex/stax-ex-1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="Extensions to complement JSR-173 StAX API"
+HOMEPAGE="http://stax-ex.dev.java.net/"
+SRC_URI="https://stax-ex.dev.java.net/files/documents/4480/44372/${P}-src.tar.gz"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+
+IUSE=""
+
+COMMON_DEPEND="dev-java/sun-jaf
+ dev-java/jsr173"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEPEND}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd "${S}"
+ # build.xml is from maven-1 and tries to download jars to /root/.maven/
+ rm -f build.xml || die
+ cp "${FILESDIR}/build.xml-${PV}" build.xml || die
+
+ mkdir "${S}/lib" || die
+ cd "${S}/lib"
+ java-pkg_jar-from sun-jaf
+ java-pkg_jar-from jsr173
+
+}
+
+src_install() {
+
+ java-pkg_dojar "stax-ex.jar"
+
+ use source && java-pkg_dosrc src/java/*
+
+}
diff --git a/dev-java/stax-ex/stax-ex-1.7.6.ebuild b/dev-java/stax-ex/stax-ex-1.7.6.ebuild
new file mode 100644
index 000000000000..f6aecdf257ae
--- /dev/null
+++ b/dev-java/stax-ex/stax-ex-1.7.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Extensions to complement JSR-173 StAX API"
+HOMEPAGE="http://stax-ex.java.net/"
+SRC_URI="https://maven.java.net/content/groups/public/org/jvnet/${PN/-/}/${PN}/${PV}/${P}-sources.jar"
+
+LICENSE="CDDL GPL-2"
+SLOT="1"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${COMMON_DEPEND}"