summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-03-14 23:30:40 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-03-15 01:25:40 +0100
commit2a032e6e068371622508d3e2617b5841f87e5067 (patch)
tree93718607dd3de60b5e013af40113eeb1ec867245 /dev-lang/elpi
parentnet-vpn/strongswan: version bump to 5.9.10 (diff)
downloadgentoo-2a032e6e068371622508d3e2617b5841f87e5067.tar.gz
gentoo-2a032e6e068371622508d3e2617b5841f87e5067.tar.bz2
gentoo-2a032e6e068371622508d3e2617b5841f87e5067.zip
dev-lang/elpi: new package; add 1.16.9
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/elpi')
-rw-r--r--dev-lang/elpi/Manifest1
-rw-r--r--dev-lang/elpi/elpi-1.16.9.ebuild47
-rw-r--r--dev-lang/elpi/metadata.xml27
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-lang/elpi/Manifest b/dev-lang/elpi/Manifest
new file mode 100644
index 000000000000..3c296b8fd485
--- /dev/null
+++ b/dev-lang/elpi/Manifest
@@ -0,0 +1 @@
+DIST elpi-1.16.9.tar.gz 2601448 BLAKE2B 37dd239cae112e6ec1c913dc9fdba60d829c0bbf61876f9c98b927d5d359ed5376ea1663da7e6c808bd62d61380973de7ae649d4a0dddef172f8d2599cc18c35 SHA512 89896c0f5d2e9a8ec6d7ef666a0d11c12b670e6951e277c2d29095b3fcbb5a977416cd1876c4c2d8c14b826782b095d3a453db03bebe3438f0eeacc08c7c87fc
diff --git a/dev-lang/elpi/elpi-1.16.9.ebuild b/dev-lang/elpi/elpi-1.16.9.ebuild
new file mode 100644
index 000000000000..184849b51e67
--- /dev/null
+++ b/dev-lang/elpi/elpi-1.16.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Embeddable Lambda Prolog Interpreter in OCaml"
+HOMEPAGE="https://github.com/LPCIC/elpi/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LPCIC/${PN}.git"
+else
+ SRC_URI="https://github.com/LPCIC/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0/${PV}"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=
+ >=dev-ml/menhir-20211230:=
+ dev-ml/atd:=
+ dev-ml/ppx_deriving:=
+ dev-ml/ppxlib:=
+ dev-ml/re:=
+ dev-ml/stdlib-shims:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-ml/ANSITerminal
+ dev-ml/cmdliner
+ )
+"
+
+DOCS=( AUTHORS.md CHANGES.md ELPI.md INCOMPATIBILITIES.md README.md )
+
+src_install() {
+ dune_src_install
+ einstalldocs
+}
diff --git a/dev-lang/elpi/metadata.xml b/dev-lang/elpi/metadata.xml
new file mode 100644
index 000000000000..30a70f111a2f
--- /dev/null
+++ b/dev-lang/elpi/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ ELPI implements a variant of λProlog enriched with Constraint Handling
+ Rules, a programming language well suited to manipulate syntax trees with
+ binders. ELPI is designed to be embedded into larger applications written
+ in OCaml as an extension language. It comes with an API to drive the
+ interpreter and with an FFI for defining built-in predicates and data
+ types, as well as quotations and similar goodies that are handy to adapt
+ the language to the host application.
+ </longdescription>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/LPCIC/elpi/master/CHANGES.md</changelog>
+ <bugs-to>https://github.com/LPCIC/elpi/issues/</bugs-to>
+ <remote-id type="github">LPCIC/elpi</remote-id>
+ </upstream>
+</pkgmetadata>