summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-07-10 23:57:12 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-07-11 12:28:29 -0400
commit4200dd6f56df960800718dae10d37ef5c04e972c (patch)
tree932407bcc38ae69954be08941f4cd03c24982d8e /dev-lang/gdl/gdl-1.0.4-r1.ebuild
parentdev-ruby/net-protocol: drop 0.2.1 (diff)
downloadgentoo-4200dd6f56df960800718dae10d37ef5c04e972c.tar.gz
gentoo-4200dd6f56df960800718dae10d37ef5c04e972c.tar.bz2
gentoo-4200dd6f56df960800718dae10d37ef5c04e972c.zip
dev-lang/gdl: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/930966 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-lang/gdl/gdl-1.0.4-r1.ebuild')
-rw-r--r--dev-lang/gdl/gdl-1.0.4-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-lang/gdl/gdl-1.0.4-r1.ebuild b/dev-lang/gdl/gdl-1.0.4-r1.ebuild
index 37797d0e9d71..e0d6af34f1d0 100644
--- a/dev-lang/gdl/gdl-1.0.4-r1.ebuild
+++ b/dev-lang/gdl/gdl-1.0.4-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
WX_GTK_VER="3.2-gtk3"
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake python-single-r1 toolchain-funcs virtualx wxwidgets
+inherit cmake flag-o-matic python-single-r1 toolchain-funcs virtualx wxwidgets
DESCRIPTION="GNU Data Language"
HOMEPAGE="https://github.com/gnudatalanguage/gdl"
@@ -96,6 +96,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/930966
+ # https://github.com/gnudatalanguage/gdl/issues/1852
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# MPI is still very buggy
# x11=off does not compile
local mycmakeargs=(