summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-11-24 21:58:29 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-11-24 21:58:29 -0800
commit1659a6ae13a71264327de2beb3d6a3f49071319a (patch)
tree26563e4e3d8763ba5f14a7eae4be44c3f4c810d6 /dev-lang/jsonnet
parentsys-cluster/ceph: Remove old (diff)
downloadgentoo-1659a6ae13a71264327de2beb3d6a3f49071319a.tar.gz
gentoo-1659a6ae13a71264327de2beb3d6a3f49071319a.tar.bz2
gentoo-1659a6ae13a71264327de2beb3d6a3f49071319a.zip
dev-lang/jsonnet-0.17.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-lang/jsonnet')
-rw-r--r--dev-lang/jsonnet/Manifest1
-rw-r--r--dev-lang/jsonnet/jsonnet-0.17.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-lang/jsonnet/Manifest b/dev-lang/jsonnet/Manifest
index 8381d36d1406..125cb3172b14 100644
--- a/dev-lang/jsonnet/Manifest
+++ b/dev-lang/jsonnet/Manifest
@@ -1,2 +1,3 @@
DIST jsonnet-0.15.0.tar.gz 21826038 BLAKE2B 722a844c00ec31b662d932a4481a71197adad680181c6a56a49dfa3e9b63696d29320c5278024d44c0ab3d7d80569514792f815ac7fa3a3cc08c7756fb6f08ad SHA512 b63c1bf82e4fc9ba3f1009ed4e4ba1010e3e7f81bd816a234e48d35607eae3cba95cab57813d35daa9f024e316bae5256340a6f8d6d884f9136cdbf062a2b351
DIST jsonnet-0.16.0.tar.gz 21828911 BLAKE2B d6e9648e259b94513507ba5a6e305f705541904d7755dc5521b7fc2940b761f413bfaba39521af54eb428337be2e75f07d12038edcf7e8a5ba95feccc8dd4a02 SHA512 80e0403ec8008cbacff8d9e8fe0e2b5d3bfa306d92c2c11d472e5721015ce4c11be745df10d25715f22f8d8594df69fabf2fe617bdded462ffc5b21f8923606f
+DIST jsonnet-0.17.0.tar.gz 21854054 BLAKE2B 91561f2cffb5c711d4ba58aceef90bbcd654997872936bcf475d397a7b831b833d349c828271e58795cca10c915ab4ec0a517dc0fc2f563673ba7a6e74cfea3f SHA512 d3ee6947163d8abced504ff37ecf365c0311164cbf243d4c635d34944f0831ca9fce2470acf00eb9a218f82a2e553b3f885db9bd21bb9dcefbd707fa0202925d
diff --git a/dev-lang/jsonnet/jsonnet-0.17.0.ebuild b/dev-lang/jsonnet/jsonnet-0.17.0.ebuild
new file mode 100644
index 000000000000..67a0000cab80
--- /dev/null
+++ b/dev-lang/jsonnet/jsonnet-0.17.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit toolchain-funcs flag-o-matic distutils-r1
+
+DESCRIPTION="A data templating language for app and tool developers "
+HOMEPAGE="https://jsonnet.org/"
+SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="custom-optimization python"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+DEPEND="
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+"
+BDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}/jsonnet-0.14.0-makefile.patch"
+ "${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
+)
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ use custom-optimization || replace-flags '-O*' -O3
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ jsonnet \
+ libjsonnet.so \
+ libjsonnet++.so
+
+ use python && distutils-r1_src_compile
+}
+
+src_test() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" test
+ use python && distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest python._jsonnet_test -v \
+ || die "Tests failed with ${EPYTHON}"
+}
+
+src_install() {
+ dolib.so libjsonnet*.so
+ dobin jsonnet
+
+ use python && distutils-r1_src_install
+}