summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-16 11:14:26 +0100
committerSam James <sam@gentoo.org>2021-10-16 11:14:26 +0100
commit04eb86bc87e3a854927784268005115f021188bc (patch)
tree91d1b9a1c35c955813a88a08d0bd93d932fd3544 /dev-lang/ocaml
parentprofiles/arch/hppa: mask gtk+3[cloudprint] (diff)
downloadgentoo-04eb86bc87e3a854927784268005115f021188bc.tar.gz
gentoo-04eb86bc87e3a854927784268005115f021188bc.tar.bz2
gentoo-04eb86bc87e3a854927784268005115f021188bc.zip
dev-lang/ocaml: filter LTO, no strict aliasing in <4.12
Bug: https://bugs.gentoo.org/818445 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ocaml-4.05.0-r7.ebuild5
-rw-r--r--dev-lang/ocaml/ocaml-4.05.0-r8.ebuild5
-rw-r--r--dev-lang/ocaml/ocaml-4.09.0-r2.ebuild5
-rw-r--r--dev-lang/ocaml/ocaml-4.10.2-r2.ebuild5
-rw-r--r--dev-lang/ocaml/ocaml-4.11.2-r2.ebuild5
5 files changed, 25 insertions, 0 deletions
diff --git a/dev-lang/ocaml/ocaml-4.05.0-r7.ebuild b/dev-lang/ocaml/ocaml-4.05.0-r7.ebuild
index 7604e5ba353b..9ef969d018ba 100644
--- a/dev-lang/ocaml/ocaml-4.05.0-r7.ebuild
+++ b/dev-lang/ocaml/ocaml-4.05.0-r7.ebuild
@@ -66,6 +66,11 @@ src_configure() {
# Bug #285993
filter-mfpmath sse
+ # Broken until 4.12
+ # bug #818445
+ filter-flags -flto
+ append-flags -fno-strict-aliasing
+
# -ggdb3 & co makes it behave weirdly, breaks sexplib
replace-flags -ggdb* -ggdb
diff --git a/dev-lang/ocaml/ocaml-4.05.0-r8.ebuild b/dev-lang/ocaml/ocaml-4.05.0-r8.ebuild
index aab387a10427..707f584fb231 100644
--- a/dev-lang/ocaml/ocaml-4.05.0-r8.ebuild
+++ b/dev-lang/ocaml/ocaml-4.05.0-r8.ebuild
@@ -67,6 +67,11 @@ src_configure() {
# Bug #285993
filter-mfpmath sse
+ # Broken until 4.12
+ # bug #818445
+ filter-flags -flto
+ append-flags -fno-strict-aliasing
+
# -ggdb3 & co makes it behave weirdly, breaks sexplib
replace-flags -ggdb* -ggdb
diff --git a/dev-lang/ocaml/ocaml-4.09.0-r2.ebuild b/dev-lang/ocaml/ocaml-4.09.0-r2.ebuild
index 23d27276013c..b9f00b2cfe03 100644
--- a/dev-lang/ocaml/ocaml-4.09.0-r2.ebuild
+++ b/dev-lang/ocaml/ocaml-4.09.0-r2.ebuild
@@ -28,6 +28,11 @@ src_prepare() {
cp "${FILESDIR}"/ocaml.conf "${T}" || die
+ # Broken until 4.12
+ # bug #818445
+ filter-flags -flto
+ append-flags -fno-strict-aliasing
+
# OCaml generates textrels on 32-bit arches
# We can't do anything about it, but disabling it means that tests
# for OCaml-based packages won't fail on unexpected output
diff --git a/dev-lang/ocaml/ocaml-4.10.2-r2.ebuild b/dev-lang/ocaml/ocaml-4.10.2-r2.ebuild
index 7203dec65d67..69ae1931963a 100644
--- a/dev-lang/ocaml/ocaml-4.10.2-r2.ebuild
+++ b/dev-lang/ocaml/ocaml-4.10.2-r2.ebuild
@@ -26,6 +26,11 @@ src_prepare() {
cp "${FILESDIR}"/ocaml.conf "${T}" || die
+ # Broken until 4.12
+ # bug #818445
+ filter-flags -flto
+ append-flags -fno-strict-aliasing
+
# OCaml generates textrels on 32-bit arches
# We can't do anything about it, but disabling it means that tests
# for OCaml-based packages won't fail on unexpected output
diff --git a/dev-lang/ocaml/ocaml-4.11.2-r2.ebuild b/dev-lang/ocaml/ocaml-4.11.2-r2.ebuild
index 464822a6bd42..001fbf26fdf9 100644
--- a/dev-lang/ocaml/ocaml-4.11.2-r2.ebuild
+++ b/dev-lang/ocaml/ocaml-4.11.2-r2.ebuild
@@ -26,6 +26,11 @@ src_prepare() {
cp "${FILESDIR}"/ocaml.conf "${T}" || die
+ # Broken until 4.12
+ # bug #818445
+ filter-flags -flto
+ append-flags -fno-strict-aliasing
+
# OCaml generates textrels on 32-bit arches
# We can't do anything about it, but disabling it means that tests
# for OCaml-based packages won't fail on unexpected output