summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-22 00:46:37 +0000
committerSam James <sam@gentoo.org>2022-02-22 00:46:37 +0000
commitb25f82e790bbcf0f05f434212958ae2e192df08e (patch)
treeaa91fc72345ca35e8259d4a5de2625e99618ca5c /dev-lang/ocaml
parentdev-lang/ocaml: fix 4.10 with glibc 2.34 (diff)
downloadgentoo-b25f82e790bbcf0f05f434212958ae2e192df08e.tar.gz
gentoo-b25f82e790bbcf0f05f434212958ae2e192df08e.tar.bz2
gentoo-b25f82e790bbcf0f05f434212958ae2e192df08e.zip
dev-lang/ocaml: scrub patches
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/files/ocaml-4.05.0-gcc10.patch20
-rw-r--r--dev-lang/ocaml/files/ocaml-4.05.0-glibc-2.34.patch15
-rw-r--r--dev-lang/ocaml/files/ocaml-4.09.0-cflags.patch24
-rw-r--r--dev-lang/ocaml/files/ocaml-4.09.0-glibc-2.34.patch15
-rw-r--r--dev-lang/ocaml/files/ocaml-4.10.2-cflags.patch16
-rw-r--r--dev-lang/ocaml/files/ocaml-4.10.2-glibc-2.34.patch18
6 files changed, 30 insertions, 78 deletions
diff --git a/dev-lang/ocaml/files/ocaml-4.05.0-gcc10.patch b/dev-lang/ocaml/files/ocaml-4.05.0-gcc10.patch
index a0c67da534a0..8b2e99883167 100644
--- a/dev-lang/ocaml/files/ocaml-4.05.0-gcc10.patch
+++ b/dev-lang/ocaml/files/ocaml-4.05.0-gcc10.patch
@@ -1,5 +1,5 @@
---- a/byterun/caml/intext.h 2021-01-28 22:46:20.400224678 +0100
-+++ b/byterun/caml/intext.h 2021-01-28 22:46:49.312751054 +0100
+--- a/byterun/caml/intext.h
++++ b/byterun/caml/intext.h
@@ -196,7 +196,7 @@
CAMLextern struct code_fragment * caml_extern_find_code(char *addr);
@@ -9,8 +9,8 @@
#endif /* CAML_INTERNALS */
---- a/byterun/caml/major_gc.h 2021-01-28 22:44:12.193323457 +0100
-+++ b/byterun/caml/major_gc.h 2021-01-28 22:45:20.918198701 +0100
+--- a/byterun/caml/major_gc.h
++++ b/byterun/caml/major_gc.h
@@ -64,9 +64,9 @@
extern char *caml_gc_sweep_hp;
@@ -24,8 +24,8 @@
extern double caml_gc_clock;
/* [caml_major_gc_hook] is called just between the end of the mark
---- a/byterun/meta.c 2021-01-28 22:47:34.148016359 +0100
-+++ b/byterun/meta.c 2021-01-28 22:47:56.048657393 +0100
+--- a/byterun/meta.c
++++ b/byterun/meta.c
@@ -32,6 +32,8 @@
#include "caml/prims.h"
#include "caml/stacks.h"
@@ -35,8 +35,8 @@
#ifndef NATIVE_CODE
CAMLprim value caml_get_global_data(value unit)
---- a/byterun/backtrace.c 2021-01-28 22:50:25.275226598 +0100
-+++ b/byterun/backtrace.c 2021-01-28 22:50:37.541027290 +0100
+--- a/byterun/backtrace.c
++++ b/byterun/backtrace.c
@@ -28,7 +28,7 @@
#include "caml/fail.h"
@@ -46,8 +46,8 @@
CAMLexport int32_t caml_backtrace_active = 0;
CAMLexport int32_t caml_backtrace_pos = 0;
---- a/asmrun/startup.c 2021-01-28 23:02:50.526072662 +0100
-+++ b/asmrun/startup.c 2021-01-28 23:03:09.977754311 +0100
+--- a/asmrun/startup.c
++++ b/asmrun/startup.c
@@ -44,7 +44,7 @@
#endif
diff --git a/dev-lang/ocaml/files/ocaml-4.05.0-glibc-2.34.patch b/dev-lang/ocaml/files/ocaml-4.05.0-glibc-2.34.patch
index 28d7f48f5b27..d95d2bb0fa50 100644
--- a/dev-lang/ocaml/files/ocaml-4.05.0-glibc-2.34.patch
+++ b/dev-lang/ocaml/files/ocaml-4.05.0-glibc-2.34.patch
@@ -18,15 +18,6 @@ The alternate signal stack is freed when the main OCaml code / an OCaml thread
stops.
(partial back-port of PR#10266 and PR#10726)
----
- asmrun/fail.c | 7 ++++-
- asmrun/signals_asm.c | 69 ++++++++++++++++++++++++++++++++++++++------
- asmrun/startup.c | 7 ++++-
- byterun/sys.c | 5 ++++
- 4 files changed, 77 insertions(+), 11 deletions(-)
-
-diff --git a/asmrun/fail.c b/asmrun/fail.c
-index d73cb88524c..2f064320185 100644
--- a/asmrun/fail.c
+++ b/asmrun/fail.c
@@ -31,6 +31,8 @@
@@ -50,8 +41,6 @@ index d73cb88524c..2f064320185 100644
#ifndef Stack_grows_upwards
#define PUSHED_AFTER <
-diff --git a/asmrun/signals_asm.c b/asmrun/signals_asm.c
-index f124a076749..b4e2516ae1a 100644
--- a/asmrun/signals_asm.c
+++ b/asmrun/signals_asm.c
@@ -194,7 +194,6 @@ DECLARE_SIGNAL_HANDLER(trap_handler)
@@ -140,8 +129,6 @@ index f124a076749..b4e2516ae1a 100644
+ }
+#endif
+}
-diff --git a/asmrun/startup.c b/asmrun/startup.c
-index 70bbc4369dc..a1cb06a7d1e 100644
--- a/asmrun/startup.c
+++ b/asmrun/startup.c
@@ -92,6 +92,7 @@ void (*caml_termination_hook)(void *) = NULL;
@@ -175,8 +162,6 @@ index 70bbc4369dc..a1cb06a7d1e 100644
}
void caml_startup(char **argv)
-diff --git a/byterun/sys.c b/byterun/sys.c
-index 3706e9002d5..aa152239ebf 100644
--- a/byterun/sys.c
+++ b/byterun/sys.c
@@ -111,6 +111,8 @@ static void caml_sys_check_path(value name)
diff --git a/dev-lang/ocaml/files/ocaml-4.09.0-cflags.patch b/dev-lang/ocaml/files/ocaml-4.09.0-cflags.patch
index 8d2391407a35..d0a947da0ea6 100644
--- a/dev-lang/ocaml/files/ocaml-4.09.0-cflags.patch
+++ b/dev-lang/ocaml/files/ocaml-4.09.0-cflags.patch
@@ -1,5 +1,5 @@
---- a/runtime/Makefile 2022-01-22 19:49:32.914213696 +0100
-+++ b/runtime/Makefile 2022-01-22 19:50:03.765640701 +0100
+--- a/runtime/Makefile
++++ b/runtime/Makefile
@@ -335,7 +335,7 @@
# (without the extension, which is added by the macro)
define COMPILE_C_FILE
@@ -9,24 +9,24 @@
endef
object_types := % %_b %_bd %_bi %_bpic %_n %_nd %_ni %_np %_npic
---- a/yacc/Makefile 2022-01-22 20:02:56.510340885 +0100
-+++ b/yacc/Makefile 2022-01-22 20:03:14.998000508 +0100
+--- a/yacc/Makefile
++++ b/yacc/Makefile
@@ -63,4 +63,4 @@
# also works for .obj files.
%.$(O): %.c
- $(CC) -c $(OC_CFLAGS) $(OC_CPPFLAGS) $(OUTPUTOBJ)$@ $<
+ $(CC) -c $(OC_CFLAGS) $(CFLAGS) $(OC_CPPFLAGS) $(OUTPUTOBJ)$@ $<
---- a/otherlibs/Makefile.otherlibs.common 2022-01-22 20:24:15.316779625 +0100
-+++ b/otherlibs/Makefile.otherlibs.common 2022-01-22 20:24:50.730126701 +0100
+--- a/otherlibs/Makefile.otherlibs.common
++++ b/otherlibs/Makefile.otherlibs.common
@@ -138,4 +138,4 @@
$(CAMLOPT) -c $(COMPFLAGS) $(OPTCOMPFLAGS) $<
.c.$(O):
- $(CC) -c $(OC_CFLAGS) $(OC_CPPFLAGS) $(OUTPUTOBJ)$@ $<
+ $(CC) -c $(OC_CFLAGS) $(CFLAGS) $(OC_CPPFLAGS) $(OUTPUTOBJ)$@ $<
---- a/ocamltest/Makefile 2022-01-22 20:30:22.454009704 +0100
-+++ b/ocamltest/Makefile 2022-01-22 20:30:33.845799603 +0100
+--- a/ocamltest/Makefile
++++ b/ocamltest/Makefile
@@ -221,7 +221,7 @@
$(ocamllex) -q $<
@@ -36,8 +36,8 @@
ocamltest_config.ml: ocamltest_config.ml.in Makefile ../Makefile.config
sed \
---- a/otherlibs/systhreads/Makefile 2022-01-22 20:42:17.647349876 +0100
-+++ b/otherlibs/systhreads/Makefile 2022-01-22 20:43:29.766086103 +0100
+--- a/otherlibs/systhreads/Makefile
++++ b/otherlibs/systhreads/Makefile
@@ -93,11 +93,11 @@
# twice, each time with different options).
@@ -52,8 +52,8 @@
-I$(ROOTDIR)/runtime $(SHAREDLIB_CFLAGS) -DNATIVE_CODE \
-DTARGET_$(ARCH) -DMODEL_$(MODEL) -DSYS_$(SYSTEM) \
$(OUTPUTOBJ)$@ -c $<
---- a/tools/Makefile 2022-01-23 09:57:00.788877931 +0100
-+++ b/tools/Makefile 2022-01-23 09:57:21.735516656 +0100
+--- a/tools/Makefile
++++ b/tools/Makefile
@@ -322,7 +322,7 @@
endif
diff --git a/dev-lang/ocaml/files/ocaml-4.09.0-glibc-2.34.patch b/dev-lang/ocaml/files/ocaml-4.09.0-glibc-2.34.patch
index 6f74d38e80b6..48127343a3f4 100644
--- a/dev-lang/ocaml/files/ocaml-4.09.0-glibc-2.34.patch
+++ b/dev-lang/ocaml/files/ocaml-4.09.0-glibc-2.34.patch
@@ -18,15 +18,6 @@ The alternate signal stack is freed when the main OCaml code / an OCaml thread
stops.
(partial back-port of PR#10266 and PR#10726)
----
- runtime/fail_nat.c | 7 ++++-
- runtime/signals_nat.c | 64 +++++++++++++++++++++++++++++++++++++------
- runtime/startup_nat.c | 7 ++++-
- runtime/sys.c | 5 ++++
- 4 files changed, 72 insertions(+), 11 deletions(-)
-
-diff --git a/runtime/fail_nat.c b/runtime/fail_nat.c
-index e1f687d379e..cbf7633ee9e 100644
--- a/runtime/fail_nat.c
+++ b/runtime/fail_nat.c
@@ -31,6 +31,8 @@
@@ -50,8 +41,6 @@ index e1f687d379e..cbf7633ee9e 100644
while (caml_local_roots != NULL &&
(char *) caml_local_roots < caml_exception_pointer) {
-diff --git a/runtime/signals_nat.c b/runtime/signals_nat.c
-index 29a5f49e625..351b575a08e 100644
--- a/runtime/signals_nat.c
+++ b/runtime/signals_nat.c
@@ -182,7 +182,6 @@ DECLARE_SIGNAL_HANDLER(trap_handler)
@@ -132,8 +121,6 @@ index 29a5f49e625..351b575a08e 100644
}
#endif
}
-diff --git a/runtime/startup_nat.c b/runtime/startup_nat.c
-index 7eca5fa5581..f52bec980b6 100644
--- a/runtime/startup_nat.c
+++ b/runtime/startup_nat.c
@@ -92,6 +92,7 @@ void (*caml_termination_hook)(void *) = NULL;
@@ -167,8 +154,6 @@ index 7eca5fa5581..f52bec980b6 100644
}
value caml_startup_exn(char_os **argv)
-diff --git a/runtime/sys.c b/runtime/sys.c
-index 226d596cdff..9e201354e1e 100644
--- a/runtime/sys.c
+++ b/runtime/sys.c
@@ -112,6 +112,8 @@ static void caml_sys_check_path(value name)
diff --git a/dev-lang/ocaml/files/ocaml-4.10.2-cflags.patch b/dev-lang/ocaml/files/ocaml-4.10.2-cflags.patch
index 01117c39887d..7adb1ea0768d 100644
--- a/dev-lang/ocaml/files/ocaml-4.10.2-cflags.patch
+++ b/dev-lang/ocaml/files/ocaml-4.10.2-cflags.patch
@@ -1,5 +1,5 @@
---- a/runtime/Makefile 2022-01-22 19:49:32.914213696 +0100
-+++ b/runtime/Makefile 2022-01-22 19:50:03.765640701 +0100
+--- a/runtime/Makefile
++++ b/runtime/Makefile
@@ -335,7 +335,7 @@
# (without the extension, which is added by the macro)
define COMPILE_C_FILE
@@ -9,16 +9,16 @@
endef
object_types := % %_b %_bd %_bi %_bpic %_n %_nd %_ni %_np %_npic
---- a/otherlibs/Makefile.otherlibs.common 2022-01-22 20:24:15.316779625 +0100
-+++ b/otherlibs/Makefile.otherlibs.common 2022-01-22 20:24:50.730126701 +0100
+--- a/otherlibs/Makefile.otherlibs.common
++++ b/otherlibs/Makefile.otherlibs.common
@@ -138,4 +138,4 @@
$(CAMLOPT) -c $(COMPFLAGS) $(OPTCOMPFLAGS) $<
.c.$(O):
- $(CC) -c $(OC_CFLAGS) $(OC_CPPFLAGS) $(OUTPUTOBJ)$@ $<
+ $(CC) -c $(OC_CFLAGS) $(CFLAGS) $(OC_CPPFLAGS) $(OUTPUTOBJ)$@ $<
---- a/otherlibs/systhreads/Makefile 2022-01-22 20:42:17.647349876 +0100
-+++ b/otherlibs/systhreads/Makefile 2022-01-22 20:43:29.766086103 +0100
+--- a/otherlibs/systhreads/Makefile
++++ b/otherlibs/systhreads/Makefile
@@ -102,10 +102,10 @@
st_stubs_n.$(O): OC_CPPFLAGS += $(NATIVE_CPPFLAGS)
@@ -32,8 +32,8 @@
partialclean:
rm -f *.cm*
---- a/Makefile.common.in 2022-01-23 18:05:04.192323554 +0100
-+++ b/Makefile.common.in 2022-01-23 18:05:17.211122643 +0100
+--- a/Makefile.common.in
++++ b/Makefile.common.in
@@ -79,4 +79,4 @@
# general (it supports both .o and .obj)
diff --git a/dev-lang/ocaml/files/ocaml-4.10.2-glibc-2.34.patch b/dev-lang/ocaml/files/ocaml-4.10.2-glibc-2.34.patch
index 8ce76701366a..4c157ddd90b8 100644
--- a/dev-lang/ocaml/files/ocaml-4.10.2-glibc-2.34.patch
+++ b/dev-lang/ocaml/files/ocaml-4.10.2-glibc-2.34.patch
@@ -18,16 +18,6 @@ The alternate signal stack is freed when the main OCaml code / an OCaml thread
stops.
(partial back-port of PR#10266 and PR#10726)
----
- otherlibs/systhreads/st_stubs.c | 2 +
- runtime/fail_nat.c | 7 ++-
- runtime/signals_nat.c | 87 ++++++++++++++++++++++++++++-----
- runtime/startup_nat.c | 7 ++-
- runtime/sys.c | 5 ++
- 5 files changed, 95 insertions(+), 13 deletions(-)
-
-diff --git a/otherlibs/systhreads/st_stubs.c b/otherlibs/systhreads/st_stubs.c
-index e46a67be9dc..0b441934ae9 100644
--- a/otherlibs/systhreads/st_stubs.c
+++ b/otherlibs/systhreads/st_stubs.c
@@ -140,6 +140,7 @@ static st_retcode caml_threadstatus_wait (value);
@@ -46,8 +36,6 @@ index e46a67be9dc..0b441934ae9 100644
#endif
/* The thread now stops running */
return 0;
-diff --git a/runtime/fail_nat.c b/runtime/fail_nat.c
-index 380578ac47b..4ea658684b4 100644
--- a/runtime/fail_nat.c
+++ b/runtime/fail_nat.c
@@ -32,6 +32,8 @@
@@ -71,8 +59,6 @@ index 380578ac47b..4ea658684b4 100644
while (Caml_state->local_roots != NULL &&
(char *) Caml_state->local_roots < Caml_state->exception_pointer) {
-diff --git a/runtime/signals_nat.c b/runtime/signals_nat.c
-index 017298394e9..b4c58259fc2 100644
--- a/runtime/signals_nat.c
+++ b/runtime/signals_nat.c
@@ -191,8 +191,6 @@ DECLARE_SIGNAL_HANDLER(trap_handler)
@@ -196,8 +182,6 @@ index 017298394e9..b4c58259fc2 100644
+ return 0;
#endif
}
-diff --git a/runtime/startup_nat.c b/runtime/startup_nat.c
-index 91ff81b3fac..b80d0ffbd5e 100644
--- a/runtime/startup_nat.c
+++ b/runtime/startup_nat.c
@@ -93,6 +93,7 @@ void (*caml_termination_hook)(void *) = NULL;
@@ -231,8 +215,6 @@ index 91ff81b3fac..b80d0ffbd5e 100644
}
value caml_startup_exn(char_os **argv)
-diff --git a/runtime/sys.c b/runtime/sys.c
-index d5636199c9f..45f8c8e8100 100644
--- a/runtime/sys.c
+++ b/runtime/sys.c
@@ -112,6 +112,8 @@ static void caml_sys_check_path(value name)