summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-22 03:20:51 +0100
committerSam James <sam@gentoo.org>2024-05-22 03:20:51 +0100
commit28d6c27f171133bb0f3c2c9330960211630d2840 (patch)
treedb30f927d627f76ecaaa3a8a2fc561730f72ca4e /dev-lang/perl
parentdev-perl/PerlIO-Layers: rely on eclass impls (diff)
downloadgentoo-28d6c27f171133bb0f3c2c9330960211630d2840.tar.gz
gentoo-28d6c27f171133bb0f3c2c9330960211630d2840.tar.bz2
gentoo-28d6c27f171133bb0f3c2c9330960211630d2840.zip
dev-lang/perl: pass -D_GNU_SOURCE for the cross build for CHOST too
We need it there as well. Bug: https://bugs.gentoo.org/913171 Closes: https://bugs.gentoo.org/932385 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/perl')
-rw-r--r--dev-lang/perl/perl-5.38.2-r5.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-lang/perl/perl-5.38.2-r5.ebuild b/dev-lang/perl/perl-5.38.2-r5.ebuild
index 7d4eea184691..37a04465b8e2 100644
--- a/dev-lang/perl/perl-5.38.2-r5.ebuild
+++ b/dev-lang/perl/perl-5.38.2-r5.ebuild
@@ -627,6 +627,9 @@ src_configure() {
if tc-is-cross-compiler; then
append-cflags "-fwrapv"
+ # Needed for the CHOST build too (bug #932385)
+ export CFLAGS="${CFLAGS} -D_GNU_SOURCE"
+
# bug #913171
export HOSTCFLAGS="${CFLAGS_FOR_BUILD} -D_GNU_SOURCE"
fi