summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAliaksei Urbanski <aliaksei.urbanski@gmail.com>2024-06-28 03:33:32 +0300
committerSam James <sam@gentoo.org>2024-08-07 04:15:20 +0100
commit2cd85ecfc76344ae70181a0e2aabd5534098202e (patch)
tree732921d114a04ea4221609cc227a106e7f50a270 /dev-lang/zig
parentrust-toolchain.eclass: add powerpc*musl support (diff)
downloadgentoo-2cd85ecfc76344ae70181a0e2aabd5534098202e.tar.gz
gentoo-2cd85ecfc76344ae70181a0e2aabd5534098202e.tar.bz2
gentoo-2cd85ecfc76344ae70181a0e2aabd5534098202e.zip
dev-lang/zig: add 0.13.0
Release: - https://ziglang.org/download/0.13.0/release-notes.html - https://github.com/ziglang/zig/releases/tag/0.13.0 Closes: https://bugs.gentoo.org/933854 Co-authored-by: Jean-Baptiste "Jiboo" Lepesme <lepesme.jb@gmail.com> Signed-off-by: Aliaksei Urbanski <aliaksei.urbanski@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/zig')
-rw-r--r--dev-lang/zig/Manifest2
-rw-r--r--dev-lang/zig/files/zig-0.13.0-test-fmt-no-doc.patch17
-rw-r--r--dev-lang/zig/files/zig-0.13.0-test-std-kernel-version.patch28
-rw-r--r--dev-lang/zig/zig-0.13.0.ebuild213
4 files changed, 260 insertions, 0 deletions
diff --git a/dev-lang/zig/Manifest b/dev-lang/zig/Manifest
index 59c8c3e88aaa..538062fe0caf 100644
--- a/dev-lang/zig/Manifest
+++ b/dev-lang/zig/Manifest
@@ -2,3 +2,5 @@ DIST zig-0.11.0.tar.xz 15275316 BLAKE2B 603e4995a36d214ba71cf05b719a04732c892799
DIST zig-0.11.0.tar.xz.minisig 312 BLAKE2B 8df407f07dde36280c945300fd8b803e6e59c026eb7a3eb56e6d2f4fe1047672e17946a3bbe23ccfe9be07b65331e17690e95fd348353be22f7b6d9b73b3f9ca SHA512 565dd1eacb7dd697e6b1ff54517adc1e4775d2523afaeb4f9a3dd404df871b187862211ecbbcf90b42e3a03853677fc1603e7fc8fc5ba7126a054679faa601ca
DIST zig-0.12.0.tar.xz 17099152 BLAKE2B 2a1248302868156c4ddcb154d075af29886a95a4c29de02ff0981e76a85f5d4109dd5c38f95c2c16f5c942bab7d120ae068c1e122ab8ad421c0213b7e996956c SHA512 0c3d9396fea4905245c7e32ce6bd9b4ff140f061cd8a957929e4c84cf105f5bbcbf2e7c030013ac649edb569e909f65d928b3e8a86f35c9076fb62e996feea14
DIST zig-0.12.0.tar.xz.minisig 312 BLAKE2B 4b3d1ae45d3b6d81054a39255c0892d9376d05da9ff1076bcf740310c9650b0154ddc39f19caee9dae293719d58a63764e43b694b83fe7031c87ab434aa377f5 SHA512 6e14c1e1926beeb249cb88fb2247ff401f679b64785c3ec8a924e33c894174deb77b48286469a863761bce0ca57524f904995eacf544919dda387c140e6e829e
+DIST zig-0.13.0.tar.xz 17220728 BLAKE2B f4bbacc2012950c556bebc28fc322fc6424bf20fe118e8362373336b6460e514028978584087f6e7f25ed8b8e6991610edce625676a1dd80c1975c5f9ef48775 SHA512 6f5f31f4ba71a11d8b16c7a5a613e124095e503fa6b02d2b77e5b177674c739287e81d98d96dc261fed24bc836caf196f71c3fcc7a6518387df86ba9e03df4dd
+DIST zig-0.13.0.tar.xz.minisig 312 BLAKE2B 2d061257c9c75f9c36b01cfb08dcd2040538a125b9ea2cae8617ae5496e685b165933ce8981494419522b7e19b51fc69a651ecaa4a8930753acf2e4ae3d6e00f SHA512 21c6139c06cba6c5e23a3305fed0c0f1b9b32d9140bd686c26365ce0279d5f53cd081894eaba29f0c1ed51b2e831edf7bd4ae6a7eaee5018a252e312e9b65507
diff --git a/dev-lang/zig/files/zig-0.13.0-test-fmt-no-doc.patch b/dev-lang/zig/files/zig-0.13.0-test-fmt-no-doc.patch
new file mode 100644
index 000000000000..7bbda741dc6f
--- /dev/null
+++ b/dev-lang/zig/files/zig-0.13.0-test-fmt-no-doc.patch
@@ -0,0 +1,17 @@
+# Docs contain examples of badly formatted code,
+# so they should be excluded for test-fmt to pass.
+# In the upstream, the "doc" directory
+# was removed from fmt_include_paths in
+# https://github.com/ziglang/zig/commit/cb1d1bdf
+
+--- a/build.zig
++++ b/build.zig
+@@ -428,7 +428,7 @@
+ }
+ const optimization_modes = chosen_opt_modes_buf[0..chosen_mode_index];
+
+- const fmt_include_paths = &.{ "doc", "lib", "src", "test", "tools", "build.zig" };
++ const fmt_include_paths = &.{ "lib", "src", "test", "tools", "build.zig" };
+ const fmt_exclude_paths = &.{"test/cases"};
+ const do_fmt = b.addFmt(.{
+ .paths = fmt_include_paths,
diff --git a/dev-lang/zig/files/zig-0.13.0-test-std-kernel-version.patch b/dev-lang/zig/files/zig-0.13.0-test-std-kernel-version.patch
new file mode 100644
index 000000000000..2d2dc22a375a
--- /dev/null
+++ b/dev-lang/zig/files/zig-0.13.0-test-std-kernel-version.patch
@@ -0,0 +1,28 @@
+# https://github.com/ziglang/zig/pull/20001
+# https://github.com/Jiboo/zig/commit/856fe4af
+
+Author: Jean-Baptiste "Jiboo" Lepesme <lepesme.jb@gmail.com>
+Date: Sun, 19 May 2024 15:02:42 +0200
+
+IoUring: fix an issue in tests where InvalidVersion might get thrown by
+skipKernelLessThan, due to some kernel versions not being SemVer compliant.
+
+diff --git a/lib/std/os/linux/IoUring.zig b/lib/std/os/linux/IoUring.zig
+index 3bf3c077fc3b..b2a4da486907 100644
+--- a/lib/std/os/linux/IoUring.zig
++++ b/lib/std/os/linux/IoUring.zig
+@@ -3883,7 +3883,13 @@ inline fn skipKernelLessThan(required: std.SemanticVersion) !void {
+ }
+
+ const release = mem.sliceTo(&uts.release, 0);
+- var current = try std.SemanticVersion.parse(release);
++ // Strips potential extra, as kernel version might not be semver compliant, example "6.8.9-300.fc40.x86_64"
++ const extra_index = std.mem.indexOfAny(u8, release, "-+");
++ const stripped = release[0..(extra_index orelse release.len)];
++ // Make sure the input don't rely on the extra we just stripped
++ try testing.expect(required.pre == null and required.build == null);
++
++ var current = try std.SemanticVersion.parse(stripped);
+ current.pre = null; // don't check pre field
+ if (required.order(current) == .gt) return error.SkipZigTest;
+ }
diff --git a/dev-lang/zig/zig-0.13.0.ebuild b/dev-lang/zig/zig-0.13.0.ebuild
new file mode 100644
index 000000000000..e55bb8ee700e
--- /dev/null
+++ b/dev-lang/zig/zig-0.13.0.ebuild
@@ -0,0 +1,213 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LLVM_MAX_SLOT=18
+inherit edo check-reqs cmake llvm multiprocessing toolchain-funcs
+
+DESCRIPTION="A robust, optimal, and maintainable programming language"
+HOMEPAGE="https://ziglang.org https://github.com/ziglang/zig"
+
+BDEPEND="test? ( !!<sys-apps/sandbox-2.39 )"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/ziglang/zig.git"
+ inherit git-r3
+else
+ VERIFY_SIG_METHOD=minisig
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/minisig-keys/zig-software-foundation.pub
+ inherit verify-sig
+
+ SRC_URI="
+ https://ziglang.org/download/${PV}/${P}.tar.xz
+ verify-sig? ( https://ziglang.org/download/${PV}/${P}.tar.xz.minisig )
+ "
+ KEYWORDS="~amd64 ~arm ~arm64"
+
+ BDEPEND+=" verify-sig? ( sec-keys/minisig-keys-zig-software-foundation )"
+fi
+
+# project itself: MIT
+# There are bunch of projects under "lib/" folder that are needed for cross-compilation.
+# Files that are unnecessary for cross-compilation are removed by upstream
+# and therefore their licenses (if any special) are not included.
+# lib/libunwind: Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )
+# lib/libcxxabi: Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )
+# lib/libcxx: Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )
+# lib/libc/wasi: || ( Apache-2.0-with-LLVM-exceptions Apache-2.0 MIT BSD-2 ) public-domain
+# lib/libc/musl: MIT BSD-2
+# lib/libc/mingw: ZPL public-domain BSD-2 ISC HPND
+# lib/libc/glibc: BSD HPND ISC inner-net LGPL-2.1+
+LICENSE="MIT Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT ) || ( Apache-2.0-with-LLVM-exceptions Apache-2.0 MIT BSD-2 ) public-domain BSD-2 ZPL ISC HPND BSD inner-net LGPL-2.1+"
+SLOT="$(ver_cut 1-2)"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BUILD_DIR="${S}/build"
+
+# Zig requires zstd and zlib compression support in LLVM, if using LLVM backend.
+# (non-LLVM backends don't require these)
+# They are not required "on their own", so please don't add them here.
+# You can check https://github.com/ziglang/zig-bootstrap in future, to see
+# options that are passed to LLVM CMake building (excluding "static" ofc).
+DEPEND="
+ sys-devel/clang:${LLVM_MAX_SLOT}=
+ sys-devel/lld:${LLVM_MAX_SLOT}=
+ sys-devel/llvm:${LLVM_MAX_SLOT}=[zstd]
+"
+
+RDEPEND="
+ ${DEPEND}
+"
+
+IDEPEND="app-eselect/eselect-zig"
+
+# see https://github.com/ziglang/zig/issues/3382
+# For now, Zig Build System doesn't support enviromental CFLAGS/LDFLAGS/etc.
+QA_FLAGS_IGNORED="usr/.*/zig/${PV}/bin/zig"
+
+# Since commit https://github.com/ziglang/zig/commit/e7d28344fa3ee81d6ad7ca5ce1f83d50d8502118
+# Zig uses self-hosted compiler only
+CHECKREQS_MEMORY="4G"
+
+PATCHES=(
+ "${FILESDIR}/${P}-test-fmt-no-doc.patch"
+ "${FILESDIR}/${P}-test-std-kernel-version.patch"
+)
+
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}"
+}
+
+ctarget_to_zigtarget() {
+ # Zig's Target Format: arch-os-abi
+ local CTARGET="${CTARGET:-${CHOST}}"
+
+ local ZIG_ARCH
+ case "${CTARGET%%-*}" in
+ i?86) ZIG_ARCH=x86;;
+ sparcv9) ZIG_ARCH=sparc64;;
+ *) ZIG_ARCH="${CTARGET%%-*}";; # Same as in CHOST
+ esac
+
+ local ZIG_OS
+ case "${CTARGET}" in
+ *linux*) ZIG_OS=linux;;
+ *apple*) ZIG_OS=macos;;
+ esac
+
+ local ZIG_ABI
+ case "${CTARGET##*-}" in
+ gnu) ZIG_ABI=gnu;;
+ solaris*) ZIG_OS=solaris ZIG_ABI=none;;
+ darwin*) ZIG_ABI=none;;
+ *) ZIG_ABI="${CTARGET##*-}";; # Same as in CHOST
+ esac
+
+ echo "${ZIG_ARCH}-${ZIG_OS}-${ZIG_ABI}"
+}
+
+get_zig_mcpu() {
+ local ZIG_DEFAULT_MCPU=native
+ tc-is-cross-compiler && ZIG_DEFAULT_MCPU=baseline
+ echo "${ZIG_MCPU:-${ZIG_DEFAULT_MCPU}}"
+}
+
+get_zig_target() {
+ local ZIG_DEFAULT_TARGET=native
+ tc-is-cross-compiler && ZIG_DEFAULT_TARGET="$(ctarget_to_zigtarget)"
+ echo "${ZIG_TARGET:-${ZIG_DEFAULT_TARGET}}"
+}
+
+pkg_setup() {
+ llvm_pkg_setup
+ check-reqs_pkg_setup
+}
+
+src_configure() {
+ # Useful for debugging and a little bit more deterministic.
+ export ZIG_LOCAL_CACHE_DIR="${T}/zig-local-cache"
+ export ZIG_GLOBAL_CACHE_DIR="${T}/zig-global-cache"
+
+ local mycmakeargs=(
+ -DZIG_SHARED_LLVM=ON
+ -DZIG_TARGET_TRIPLE="$(get_zig_target)"
+ -DZIG_TARGET_MCPU="$(get_zig_mcpu)"
+ -DZIG_USE_LLVM_CONFIG=ON
+ -DCMAKE_PREFIX_PATH="$(get_llvm_prefix ${LLVM_MAX_SLOT})"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/$(get_libdir)/zig/${PV}"
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ "${BUILD_DIR}/stage3/bin/zig" env || die "Zig compilation failed"
+
+ if use doc; then
+ cd "${BUILD_DIR}" || die
+ edo ./stage3/bin/zig build std-docs --prefix "${S}/docgen/"
+ edo ./stage3/bin/zig build langref --prefix "${S}/docgen/"
+ fi
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ local ZIG_TEST_ARGS=(
+ -j$(makeopts_jobs)
+ --color on
+ --summary all
+ --verbose
+ -Dstatic-llvm=false
+ -Denable-llvm
+ -Dskip-non-native
+ -Doptimize=Debug
+ -Dtarget="$(get_zig_target)"
+ -Dcpu="$(get_zig_mcpu)"
+ )
+ local ZIG_TEST_STEPS=(
+ test-asm-link
+ test-behavior
+ test-c-abi
+ test-c-import
+ test-cases
+ test-cli
+ test-compare-output
+ test-compiler-rt
+ test-fmt
+ test-link
+ test-run-translated-c
+ test-stack-traces
+ test-standalone
+ test-std
+ test-translate-c
+ test-universal-libc
+ )
+
+ local step
+ for step in "${ZIG_TEST_STEPS[@]}" ; do
+ # to keep the verbosity, don't use edob here
+ ./stage3/bin/zig build ${step} ${ZIG_TEST_ARGS[@]} || die
+ done
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "docgen/doc/langref.html" "docgen/doc/std" )
+ cmake_src_install
+
+ cd "${ED}/usr/$(get_libdir)/zig/${PV}/" || die
+ mv lib/zig/ lib2/ || die
+ rm -rf lib/ || die
+ mv lib2/ lib/ || die
+ dosym -r "/usr/$(get_libdir)/zig/${PV}/bin/zig" "/usr/bin/zig-${PV}"
+}
+
+pkg_postinst() {
+ eselect zig update ifunset || die
+}
+
+pkg_postrm() {
+ eselect zig update ifunset || die
+}