summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-14 23:45:43 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-15 00:08:12 +0200
commit44f22e62efe5b3a0e48e5a783ab13088b2ea335b (patch)
tree1291581d4bd13ce8f09664f3c4f9663e1c22d02c /dev-lang
parentdev-lang/algol68g: drop old 3.5.4 (diff)
downloadgentoo-44f22e62efe5b3a0e48e5a783ab13088b2ea335b.tar.gz
gentoo-44f22e62efe5b3a0e48e5a783ab13088b2ea335b.tar.bz2
gentoo-44f22e62efe5b3a0e48e5a783ab13088b2ea335b.zip
dev-lang/algol68g: bump to 3.5.8
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/algol68g/Manifest1
-rw-r--r--dev-lang/algol68g/algol68g-3.5.8.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-lang/algol68g/Manifest b/dev-lang/algol68g/Manifest
index 67594fa62ec9..dff0439ff779 100644
--- a/dev-lang/algol68g/Manifest
+++ b/dev-lang/algol68g/Manifest
@@ -1,2 +1,3 @@
DIST algol68g-3.5.5.tar.gz 664205 BLAKE2B 1ac99c1723e45ff69a72592c0209716409c35ce208e79682ed77a972b08cab49b78b735f1b585640c9a8b5d59853cafb601d8a049bc33bfa42f6a37c93848285 SHA512 5c671e1b7f90a6a0197afd0efdae737d409d0db98b4f62e2a958ecbec5d731cb68896e8c14e975d4d569e399a79ee12be3269c6ab2e9c6a34f2cb6d9a1e5a273
DIST algol68g-3.5.7.tar.gz 664353 BLAKE2B 109a94c6e8996d71634187bafaf33ce6be40c054dcd62a5cb40a5197ad645a3f8769b3596504206aeccd4769aa80af263ad763b115171db73e3255b5e64347a8 SHA512 05a3d51cffb918d0e61d8692da83905190d3c52079acb3bcad2c49e8fa9dcc9ab433a830486db337ff28c540b128795d5af876d70ad778c72426549c1a6116d9
+DIST algol68g-3.5.8.tar.gz 664310 BLAKE2B f086b8d4930735e186761aea65f2599cb1a6234b43162ec2aad9e3292485a363f536c9226ecff460af5a99ed66bb1f6842d5f928e9d04e2149b7adcf08751101 SHA512 99fcd5719edda5726ef8c65a3d577ae02159f660a9d261d247553cd1ad7a0f323dc8f59739507e644306c03902e6a2327f617c82fc7052e3e9f59e98aca9fdbe
diff --git a/dev-lang/algol68g/algol68g-3.5.8.ebuild b/dev-lang/algol68g/algol68g-3.5.8.ebuild
new file mode 100644
index 000000000000..6689c5616025
--- /dev/null
+++ b/dev-lang/algol68g/algol68g-3.5.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Algol 68 Genie compiler-interpreter"
+HOMEPAGE="https://jmvdveer.home.xs4all.nl/en.algol-68-genie.html"
+SRC_URI="https://jmvdveer.home.xs4all.nl/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+curl +gsl +mpfr +ncurses plotutils postgres +readline"
+
+RDEPEND="
+ curl? ( net-misc/curl )
+ gsl? ( sci-libs/gsl:= )
+ mpfr? ( dev-libs/mpfr:= )
+ plotutils? ( media-libs/plotutils )
+ postgres? ( dev-db/postgresql:* )
+ readline? ( sys-libs/readline:= )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-3.3.21-configure-implicit.patch" )
+
+src_configure() {
+ local -a myconf=(
+ $(use_enable curl)
+ $(use_enable gsl)
+ $(use_enable mpfr)
+ $(use_enable ncurses curses)
+ $(use_enable plotutils)
+ $(use_enable postgres postgresql)
+ $(use_enable readline)
+ $(use_with ncurses)
+ )
+ econf "${myconf[@]}"
+}