summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-05 21:59:45 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-05 23:44:17 +0200
commita2f6faad8a0099b3054b05282aafa5f08835a0c9 (patch)
tree952027f7af542b4e314fe606bd0aa229b9bf9f26 /dev-lang
parentapp-editors/neovim: add 0.10.2 (diff)
downloadgentoo-a2f6faad8a0099b3054b05282aafa5f08835a0c9.tar.gz
gentoo-a2f6faad8a0099b3054b05282aafa5f08835a0c9.tar.bz2
gentoo-a2f6faad8a0099b3054b05282aafa5f08835a0c9.zip
dev-lang/nim: bump to 2.2.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nim/Manifest1
-rw-r--r--dev-lang/nim/nim-2.2.0.ebuild183
2 files changed, 184 insertions, 0 deletions
diff --git a/dev-lang/nim/Manifest b/dev-lang/nim/Manifest
index 8c27c6369f9d..0b895d6dee3c 100644
--- a/dev-lang/nim/Manifest
+++ b/dev-lang/nim/Manifest
@@ -1,2 +1,3 @@
DIST nim-2.0.8.tar.xz 7617556 BLAKE2B 96ab3e92c7c9d3dcb54de6528f2ae788f3ff4a927d693f2ca4917231441d85d12c8bda44c41c8f363979dbd0d8db54098648512caf7780bdc40e393c4f7803ec SHA512 e64abc379c046a9432515d1c8074a7e10ff72a1076663a5b7bdd39ae92852c98ba2cab96aa5e968fc31ca393e778e70b2392d6ab56bca7ac956d0176b4b69a83
+DIST nim-2.2.0.tar.xz 7896912 BLAKE2B 671b1f5551e093933519797bbfe2875c1726a0cdd1b33288a9ab189fb966fdb21583027345e58ab13d7e7e85479aafc52340e8ddecd062aca4b4b8de6466b88e SHA512 56374815770b1b92bef3521471a3b1a8b810646eb7f978ff329075d64d231a7d1591a928c28407aa507f1b59375d539fc81b678b84f6b8b4a88ed274048ebf21
DIST nim-atlas-0.8.0.tar.gz 59097 BLAKE2B 231b238ac3b15cc2c2d9ad927f80ae72d8ae4c649277515f32df6cc04275ccd38db5307d627572af547501e6522c06c86dc279dc3e13b5385f14e24032f6fe69 SHA512 747c13e2c5bd45a1dc6c1426f8c7637f638ada9dd4c9aa3edf4ef8367060e73226dc4bcde6380fac25ed47ebf4097fd223c72fadc3cceba8c71dd0f0571e47eb
diff --git a/dev-lang/nim/nim-2.2.0.ebuild b/dev-lang/nim/nim-2.2.0.ebuild
new file mode 100644
index 000000000000..e2962efd86a9
--- /dev/null
+++ b/dev-lang/nim/nim-2.2.0.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ATLAS_V="0.8.0"
+
+inherit bash-completion-r1 edo multiprocessing toolchain-funcs xdg-utils
+
+DESCRIPTION="Compiled, garbage-collected systems programming language"
+HOMEPAGE="https://nim-lang.org/
+ https://github.com/nim-lang/Nim/"
+
+SRC_URI="
+ https://nim-lang.org/download/${P}.tar.xz
+ https://github.com/nim-lang/atlas/archive/refs/tags/${ATLAS_V}.tar.gz
+ -> nim-atlas-${ATLAS_V}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test-js test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ sys-process/parallel
+ test? (
+ dev-db/sqlite:3
+ dev-libs/boehm-gc
+ dev-libs/libffi
+ dev-libs/libpcre:3
+ dev-libs/openssl
+ media-libs/libsdl
+ media-libs/libsfml
+ test-js? (
+ net-libs/nodejs
+ )
+ )
+"
+
+src_configure() {
+ xdg_environment_reset # bug #667182
+
+ unset NIMBLE_DIR
+ tc-export CC CXX LD
+
+ mkdir "${HOME}/.parallel" || die
+ touch "${HOME}/.parallel/will-cite" || die "parallel setup failed"
+
+ cat > nim.cfg <<- EOF || die "Failed to create Nim config"
+ cc:"gcc"
+ gcc.exe:"$(tc-getCC)"
+ gcc.linkerexe:"$(tc-getCC)"
+ gcc.cpp.exe:"$(tc-getCXX)"
+ gcc.cpp.linkerexe:"$(tc-getCXX)"
+ gcc.options.speed:"${CFLAGS}"
+ gcc.options.size:"${CFLAGS}"
+ gcc.options.debug:"${CFLAGS}"
+ gcc.options.always:"${CPPFLAGS}"
+ gcc.options.linker:"${LDFLAGS}"
+ gcc.cpp.options.speed:"${CXXFLAGS}"
+ gcc.cpp.options.size:"${CXXFLAGS}"
+ gcc.cpp.options.debug:"${CXXFLAGS}"
+ gcc.cpp.options.always:"${CPPFLAGS}"
+ gcc.cpp.options.linker:"${LDFLAGS}"
+
+ $([[ "${NOCOLOR}" == true || "${NOCOLOR}" == yes ]] && echo '--colors:"off"')
+ -d:"release"
+ --parallelBuild:"$(makeopts_jobs)"
+
+ # some tests don't work with processing hints
+ --processing:"off"
+ EOF
+
+ cp -r "${WORKDIR}/atlas-${ATLAS_V}" "${S}/dist/atlas" || die
+
+ mkdir -p "${S}/dist/atlas/dist" || die
+ cp -r "${S}/dist/nimble/dist/sat" "${S}/dist/atlas/dist/sat" || die
+}
+
+src_compile() {
+ local -x PATH="${S}/bin:${PATH}"
+
+ edo ./build.sh --parallel "$(makeopts_jobs)"
+
+ ebegin "Waiting for unfinished parallel jobs"
+ while [[ ! -f "bin/nim" ]] ; do
+ sleep 3
+ done
+ sleep 10
+ eend 0
+
+ edo chmod +x ./bin/nim
+ edo ./bin/nim compile -d:release koch
+ edo ./koch boot -d:nimUseLinenoise -d:release --skipParentCfg:off
+ edo ./koch tools -d:release
+ edo ./bin/nim compile -d:release ./tools/niminst/niminst.nim
+}
+
+src_test() {
+ local -x PATH="${S}/bin:${PATH}"
+ local -a nimflags=(
+ # Leave only the safe hints enabled.
+ --hint:all:off
+ --hint:User:on
+ --hint:UserRaw:on
+ )
+ local -a testament_args=(
+ --skipFrom:"${FILESDIR}/${PN}-2.0.6-testament-skipfile.txt"
+ --nim:"bin/nim"
+ --targets:"$(usex test-js 'c js' 'c')"
+ )
+
+ [[ "${NOCOLOR}" == true || "${NOCOLOR}" == yes ]] \
+ && testament_args+=( --colors:off )
+
+ local -a categories
+ readarray -t categories < <(find tests -mindepth 1 -maxdepth 1 -type d -printf "%P\n" | sort)
+
+ # AdditionalCategories from "testament/categories.nim".
+ categories+=( debugger examples lib )
+
+ local test_return=0
+
+ local tcat
+ local checkpoint
+ for tcat in "${categories[@]}"; do
+ # Use checkpoints for less painful testing.
+ checkpoint="${T}/.testament-${tcat}"
+
+ [[ -f "${checkpoint}" ]] && continue
+
+ case "${tcat}" in
+ testdata )
+ :
+ ;;
+ arc | gc | ic | js | msgs | stylecheck \
+ | testament | untestable | objects | valgrind )
+ einfo "Skipped nim test category: ${tcat}"
+ ;;
+ * )
+ einfo "Running tests in category '${tcat}'"
+ nonfatal edo ./bin/testament "${testament_args[@]}" \
+ category "${tcat}" "${nimflags[@]}" \
+ || test_return=1
+ ;;
+ esac
+
+ touch "${checkpoint}" || die
+ done
+
+ [[ "${test_return}" -eq 1 ]] \
+ && die "tests failed, please inspect the failed test categories above"
+}
+
+src_install() {
+ local -x PATH="${S}/bin:${PATH}"
+
+ edo ./koch install "${ED}/usr/lib"
+ dosym -r /usr/lib/nim/bin/nim /usr/bin/nim
+
+ # "./koch install" installs only "nim" binary but not the rest.
+ exeinto /usr/bin
+ local exe
+ while read -r exe ; do
+ einfo "Installing nim support tool: ${exe}"
+ doexe "${exe}"
+ done < <(find ./bin -type f -not -iname nim)
+
+ newbashcomp tools/nim.bash-completion nim
+ newbashcomp dist/nimble/nimble.bash-completion nimble
+
+ insinto /usr/share/zsh/site-functions
+ newins tools/nim.zsh-completion _nim
+ newins dist/nimble/nimble.zsh-completion _nimble
+
+ # Install the @nim-rebuild set for Portage.
+ insinto /usr/share/portage/config/sets
+ newins "${FILESDIR}/nim-sets.conf" nim.conf
+
+ einstalldocs
+}