summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-25 15:41:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-25 15:42:30 +0200
commit785f61adc7739286b7e58f7866c50e415fe6ceb1 (patch)
tree21eac9ed518751b89b218acc1a4e8128248c49cb /dev-libs/cereal
parentprofiles: Mask media-sound/rgain for removal (diff)
downloadgentoo-785f61adc7739286b7e58f7866c50e415fe6ceb1.tar.gz
gentoo-785f61adc7739286b7e58f7866c50e415fe6ceb1.tar.bz2
gentoo-785f61adc7739286b7e58f7866c50e415fe6ceb1.zip
dev-libs/cereal: EAPI-7, cmake.eclass, switch HOMEPAGE to https
Bug: https://bugs.gentoo.org/729584 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/cereal')
-rw-r--r--dev-libs/cereal/cereal-1.3.0.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-libs/cereal/cereal-1.3.0.ebuild b/dev-libs/cereal/cereal-1.3.0.ebuild
index 85993089e208..463e000b4b75 100644
--- a/dev-libs/cereal/cereal-1.3.0.ebuild
+++ b/dev-libs/cereal/cereal-1.3.0.ebuild
@@ -1,26 +1,27 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+inherit cmake
-DESCRIPTION="header-only C++11 serialization library"
-HOMEPAGE="http://uscilab.github.io/cereal/"
+DESCRIPTION="Header-only C++11 serialization library"
+HOMEPAGE="https://uscilab.github.io/cereal/"
SRC_URI="https://github.com/USCiLab/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+
RESTRICT="!test? ( test )"
DEPEND="test? ( dev-libs/boost )"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DJUST_INSTALL_CEREAL=$(usex !test)
-DWITH_WERROR=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}