summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2018-10-12 09:09:20 +0300
committerMichał Górny <mgorny@gentoo.org>2018-10-12 21:47:49 +0200
commit7de06dc659e12cd2cbb1269fcd44c2882e72354b (patch)
tree655196ef2a612f6da08d29aaf463d51b45401cae /dev-libs/efl
parentnet-misc/megatools: drop old (diff)
downloadgentoo-7de06dc659e12cd2cbb1269fcd44c2882e72354b.tar.gz
gentoo-7de06dc659e12cd2cbb1269fcd44c2882e72354b.tar.bz2
gentoo-7de06dc659e12cd2cbb1269fcd44c2882e72354b.zip
dev-libs/efl: fix build issue with 'xpresent' USE enabled for 1.21.1
Closes: https://bugs.gentoo.org/668354 Signed-off-by: Joonas Niilola <juippis@gmail.com> Package-Manager: Portage[mgorny]-2.3.49.1 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/efl')
-rw-r--r--dev-libs/efl/efl-1.21.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-libs/efl/efl-1.21.1.ebuild b/dev-libs/efl/efl-1.21.1.ebuild
index d020ef97f293..c627b1a33b84 100644
--- a/dev-libs/efl/efl-1.21.1.ebuild
+++ b/dev-libs/efl/efl-1.21.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,6 +30,7 @@ REQUIRED_USE="
vnc? ( X fbcon )
wayland? ( egl gles !opengl )
xim? ( X )
+ xpresent? ( X )
"
RDEPEND="
@@ -123,11 +124,11 @@ RDEPEND="
x11-libs/libX11
x11-libs/libXrender
virtual/opengl
- xpresent? ( x11-libs/libXpresent )
)
)
xine? ( media-libs/xine-lib )
xpm? ( x11-libs/libXpm )
+ xpresent? ( x11-libs/libXpresent )
"
DEPEND="
@@ -215,6 +216,7 @@ src_configure() {
$(use_enable xim)
$(use_enable xine)
$(use_enable xpm image-loader-xpm)
+ $(use_enable xpresent)
--with-crypto=$(usex gnutls gnutls $(usex ssl openssl none))
--with-glib=$(usex glib)
@@ -227,7 +229,6 @@ src_configure() {
)
use drm && use wayland && myconf+=( --enable-gl-drm )
- use X && use xpresent && myconf+=( --enable-xpresent )
if use opengl ; then
myconf+=( --with-opengl=full )