summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-01-24 00:51:51 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-01-24 01:11:45 +0100
commit01f3fc14d029f76c51e74390b8cfcf4acca7a2b0 (patch)
tree8f2bae712cb43fc430bc83377a9f27fdf8618bf8 /dev-libs/jemalloc/jemalloc-4.4.0.ebuild
parentsys-apps/man-pages-posix: mark ALLARCHES (diff)
downloadgentoo-01f3fc14d029f76c51e74390b8cfcf4acca7a2b0.tar.gz
gentoo-01f3fc14d029f76c51e74390b8cfcf4acca7a2b0.tar.bz2
gentoo-01f3fc14d029f76c51e74390b8cfcf4acca7a2b0.zip
dev-libs/jemalloc: drop old
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/19188 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/jemalloc/jemalloc-4.4.0.ebuild')
-rw-r--r--dev-libs/jemalloc/jemalloc-4.4.0.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-libs/jemalloc/jemalloc-4.4.0.ebuild b/dev-libs/jemalloc/jemalloc-4.4.0.ebuild
deleted file mode 100644
index 399d51c93202..000000000000
--- a/dev-libs/jemalloc/jemalloc-4.4.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs multilib-build multilib-minimal
-
-DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
-HOMEPAGE="http://jemalloc.net/ https://github.com/jemalloc/jemalloc"
-SRC_URI="https://github.com/jemalloc/jemalloc/releases/download/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0/2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="debug hardened static-libs stats"
-HTML_DOCS=( doc/jemalloc.html )
-PATCHES=( "${FILESDIR}/${PN}-3.5.1-strip-optimization.patch"
- "${FILESDIR}/${PN}-3.5.1_fix_html_install.patch"
-)
-MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
-# autotools-utils.eclass auto-adds configure options when static-libs is in IUSE
-# but jemalloc doesn't implement them in its configure; need this here to
-# supress the warnings until automagic is removed from the eclass
-QA_CONFIGURE_OPTIONS="--enable-static --disable-static --enable-shared --disable-shared"
-
-multilib_src_configure() {
- local myconf=()
-
- if use hardened ; then
- myconf+=( --disable-syscall )
- fi
-
- ECONF_SOURCE="${S}" \
- econf \
- $(use_enable debug) \
- $(use_enable stats) \
- "${myconf[@]}"
-}
-
-multilib_src_install() {
- # Copy man file which the Makefile looks for
- cp "${S}/doc/jemalloc.3" "${BUILD_DIR}/doc" || die
- emake DESTDIR="${D}" install
-}
-
-multilib_src_install_all() {
- if [[ ${CHOST} == *-darwin* ]] ; then
- # fixup install_name, #437362
- install_name_tool \
- -id "${EPREFIX}"/usr/$(get_libdir)/libjemalloc.1.dylib \
- "${ED}"/usr/$(get_libdir)/libjemalloc.2.dylib || die
- fi
- use static-libs || find "${ED}" -name '*.a' -delete
-}