summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-16 03:07:53 +0100
committerSam James <sam@gentoo.org>2022-04-16 03:09:24 +0100
commitc7d8da15ca9547f2a88df43fa995e335e7a0c7fd (patch)
tree2a0e742c8c9fa7a4d27fec1926510133c3fb633a /dev-libs/libnl
parentnet-misc/rsync: add 3.2.4 (diff)
downloadgentoo-c7d8da15ca9547f2a88df43fa995e335e7a0c7fd.tar.gz
gentoo-c7d8da15ca9547f2a88df43fa995e335e7a0c7fd.tar.bz2
gentoo-c7d8da15ca9547f2a88df43fa995e335e7a0c7fd.zip
dev-libs/libnl: add 3.6.0 (unkeyworded)
Unkeyworded for now until test failure investigated (reported upstream). Bug: https://github.com/thom311/libnl/issues/308 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libnl')
-rw-r--r--dev-libs/libnl/Manifest1
-rw-r--r--dev-libs/libnl/files/libnl-3.6.0-static-tests.patch37
-rw-r--r--dev-libs/libnl/libnl-3.6.0.ebuild107
3 files changed, 145 insertions, 0 deletions
diff --git a/dev-libs/libnl/Manifest b/dev-libs/libnl/Manifest
index a9a95c9c88d1..94fe71f27f45 100644
--- a/dev-libs/libnl/Manifest
+++ b/dev-libs/libnl/Manifest
@@ -1 +1,2 @@
DIST libnl-3.5.0.tar.gz 967835 BLAKE2B cf21c1ffa89799b91bf4bddb8833d5af5c62eb1c53a078ee55a2888bd8439e1ae6db8886c9c4f937297962faac6873b4cf5211ee3d1e5354d96b5dc545a6fc2d SHA512 9c94c09bac34297493b3ea482713d7c0865d2839b5042e5c7d1ed008e2402ab63df35a18e272f40b2cce27d0c31dc733fe7e4b2d376e7ca847a2b0d5e90de50c
+DIST libnl-3.6.0.tar.gz 981921 BLAKE2B 4fbc1f6284dfbf0aaa855dfc3bb9774327254718257cf162c14574ece6b0da20f03a587830b21a2481d1da6e9c90482d71d8f9308f1eeafa605c90d0847a838c SHA512 7d1190ce94f43f5b18b1f7909221ca034d4ea5c8ed5735dbd27224d03e7f95d3c4e8ccdb611e33b58007729a21bfc0e23adc8758b112c712355664d87a81ce1b
diff --git a/dev-libs/libnl/files/libnl-3.6.0-static-tests.patch b/dev-libs/libnl/files/libnl-3.6.0-static-tests.patch
new file mode 100644
index 000000000000..be406705e1d7
--- /dev/null
+++ b/dev-libs/libnl/files/libnl-3.6.0-static-tests.patch
@@ -0,0 +1,37 @@
+From: Thomas Haller <thaller@redhat.com>
+Date: Fri, 15 Apr 2022 13:29:49 +0200
+Subject: [PATCH] build: avoid building check-direct with --disable-static
+
+"check-direct" needs to statically link with the libraries, because
+it wants to test internal ABI, which is hidden in the share libraries.
+When configuring with "--disable-static", static libs are not build
+and the test tool cannot be build.
+
+Just skip the test in that case.
+
+https://github.com/thom311/libnl/issues/306
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -984,8 +984,10 @@ tests_check_all_LDADD = \
+ $(NULL)
+
+ if WITH_CHECK
++if ENABLE_STATIC
+ check_programs += tests/check-direct
+ endif
++endif
+
+ tests_check_direct_SOURCES = \
+ tests/check-direct.c \
+--- a/configure.ac
++++ b/configure.ac
+@@ -107,6 +107,8 @@ else
+ AC_CHECK_LIB([pthread], [pthread_mutex_lock], [], AC_MSG_ERROR([libpthread is required]))
+ fi
+
++AM_CONDITIONAL([ENABLE_STATIC], [test "$enable_static" != "no"])
++
+ AC_ARG_ENABLE([debug],
+ AS_HELP_STRING([--disable-debug], [Do not include debugging statements]),
+ [enable_debug="$enableval"], [enable_debug="yes"])
+
diff --git a/dev-libs/libnl/libnl-3.6.0.ebuild b/dev-libs/libnl/libnl-3.6.0.ebuild
new file mode 100644
index 000000000000..5c1aeb096def
--- /dev/null
+++ b/dev-libs/libnl/libnl-3.6.0.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_OPTIONAL=1
+inherit autotools distutils-r1 multilib-minimal
+
+LIBNL_P=${P/_/-}
+LIBNL_DIR=${PV/_/}
+LIBNL_DIR=${LIBNL_DIR//./_}
+
+DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
+HOMEPAGE="https://www.infradead.org/~tgr/libnl/ https://github.com/thom311/libnl"
+SRC_URI="https://github.com/thom311/${PN}/releases/download/${PN}${LIBNL_DIR}/${P/_rc/-rc}.tar.gz"
+S="${WORKDIR}/${LIBNL_P}"
+
+LICENSE="LGPL-2.1 utils? ( GPL-2 )"
+SLOT="3"
+# Test failure: https://github.com/thom311/libnl/issues/308
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+debug python test utils"
+RESTRICT="!test? ( test )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ python? ( dev-lang/swig )
+ test? ( dev-libs/check )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DOCS=( ChangeLog )
+
+MULTILIB_WRAPPED_HEADERS=(
+ # we do not install CLI stuff for non-native
+ /usr/include/libnl3/netlink/cli/addr.h
+ /usr/include/libnl3/netlink/cli/class.h
+ /usr/include/libnl3/netlink/cli/cls.h
+ /usr/include/libnl3/netlink/cli/ct.h
+ /usr/include/libnl3/netlink/cli/exp.h
+ /usr/include/libnl3/netlink/cli/link.h
+ /usr/include/libnl3/netlink/cli/neigh.h
+ /usr/include/libnl3/netlink/cli/qdisc.h
+ /usr/include/libnl3/netlink/cli/route.h
+ /usr/include/libnl3/netlink/cli/rule.h
+ /usr/include/libnl3/netlink/cli/tc.h
+ /usr/include/libnl3/netlink/cli/utils.h
+)
+
+PATCHES=(
+ "${FILESDIR}"/${P}-static-tests.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if use python; then
+ pushd "${S}"/python > /dev/null || die
+ distutils-r1_src_prepare
+ popd > /dev/null || die
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(multilib_native_use_enable utils cli) \
+ $(use_enable debug)
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use python ; then
+ pushd python > /dev/null || die
+ distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi && use python ; then
+ # Unset DOCS= since distutils-r1.eclass interferes
+ local DOCS=()
+
+ pushd python > /dev/null || die
+
+ distutils-r1_src_install
+
+ # For no obvious reason this is not done automatically
+ python_foreach_impl python_optimize
+
+ popd > /dev/null || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+}