summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRolf Eike Beer <eike@sf-mail.de>2017-10-22 20:54:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-30 00:19:19 +0100
commitff4926d32c2031a8b959d704fa7a7a0b8b02b843 (patch)
treee22172ffdea8ade50692ee488d45abff9d14584c /dev-libs/libowfat
parentmedia-sound/mp3blaster: remove old (diff)
downloadgentoo-ff4926d32c2031a8b959d704fa7a7a0b8b02b843.tar.gz
gentoo-ff4926d32c2031a8b959d704fa7a7a0b8b02b843.tar.bz2
gentoo-ff4926d32c2031a8b959d704fa7a7a0b8b02b843.zip
dev-libs/libowfat: use DESTDIR
Support was added in version 0.31. While at it do some other improvements as suggested by Jonas Stein. Closes: https://bugs.gentoo.org/598980 Closes: https://github.com/gentoo/gentoo/pull/6017
Diffstat (limited to 'dev-libs/libowfat')
-rw-r--r--dev-libs/libowfat/libowfat-0.31-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/libowfat/libowfat-0.31-r1.ebuild b/dev-libs/libowfat/libowfat-0.31-r1.ebuild
new file mode 100644
index 000000000000..8f007a7cef71
--- /dev/null
+++ b/dev-libs/libowfat/libowfat-0.31-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="reimplement libdjb - excellent libraries from Dan Bernstein"
+SRC_URI="https://www.fefe.de/${PN}/${P}.tar.xz"
+HOMEPAGE="https://www.fefe.de/libowfat/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="diet"
+
+RDEPEND="diet? ( >=dev-libs/dietlibc-0.33_pre20090721 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+pkg_setup() {
+ # Required for mult/umult64.c to be usable
+ append-flags -fomit-frame-pointer
+}
+
+src_compile() {
+ emake -j1 \
+ CC=$(tc-getCC) \
+ CFLAGS="-I. ${CFLAGS}" \
+ DIET="/usr/bin/diet -Os" \
+ prefix=/usr \
+ INCLUDEDIR=/usr/include/libowfat \
+ $( use diet || echo 'DIET=' )
+}
+
+src_install () {
+ emake -j1 \
+ DESTDIR="${D}" \
+ LIBDIR="/usr/lib" \
+ MAN3DIR="/usr/share/man/man3" \
+ INCLUDEDIR="/usr/include/libowfat" \
+ install
+
+ cd "${D}"/usr/share/man
+ mv man3/buffer.3 man3/owfat-buffer.3
+}