summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Andrejak <thomas.andrejak@gmail.com>2017-08-28 00:52:01 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-08 10:19:05 +0200
commitc355e564ed8b6efec432a566c30d04cdeb0221d7 (patch)
tree07ca0194903ca13fd72ac87d953cafd74b9dbfe1 /dev-libs/libpreludedb
parentdev-libs/libprelude: whitespace/style fixes (diff)
downloadgentoo-c355e564ed8b6efec432a566c30d04cdeb0221d7.tar.gz
gentoo-c355e564ed8b6efec432a566c30d04cdeb0221d7.tar.bz2
gentoo-c355e564ed8b6efec432a566c30d04cdeb0221d7.zip
dev-libs/libpreludedb: Bump version 4.0.0
Diffstat (limited to 'dev-libs/libpreludedb')
-rw-r--r--dev-libs/libpreludedb/Manifest1
-rw-r--r--dev-libs/libpreludedb/files/libpreludedb-4.0.0-fix-python-bindings.patch39
-rw-r--r--dev-libs/libpreludedb/libpreludedb-4.0.0.ebuild89
3 files changed, 129 insertions, 0 deletions
diff --git a/dev-libs/libpreludedb/Manifest b/dev-libs/libpreludedb/Manifest
index 2dd4bb3c6e7e..416585abaa5a 100644
--- a/dev-libs/libpreludedb/Manifest
+++ b/dev-libs/libpreludedb/Manifest
@@ -1,2 +1,3 @@
DIST libpreludedb-3.0.0.tar.gz 1269937 SHA256 608afa449388b2fcc25dc6aa2ad74ab2f22fd03ca3a0c0cdb2588d794f82d3ca SHA512 9d80e01be8cf028b8a843e68e45eeb84c561ff37e688fe5b8156e717f337b1db4d3de983f37a0544bf018238bec07580dce0c7208df005113efbba0aab34b981 WHIRLPOOL 1c700c34d05c5ba42fae40ff2597bf3f951bb49674eebfbb6ce80824bd59880f5a1402d786f00e4a5560da94c515968c11f9d84e67e88b1eedbfa02e364abd35
DIST libpreludedb-3.1.0.tar.gz 1291186 SHA256 3ac2adade778941249fc87adcaebf39ef3acf17844632f690c66fb50dd48d857 SHA512 dcb98eff2521979c2956bdd6f3b661c346c0f6748ef820a75d77c948e426a996de26c7fc6b6c2abddc93277db3820eb2f44b61c87feb86483e720cf9b0e0124c WHIRLPOOL 85d0a79be0cd0f638368317ebb0020a60670a6fb1093868accfe3755bcf04988d2263775959732a32ae5b33e0169e95d215dc4af547780fc3bc1c0ad5054c3f0
+DIST libpreludedb-4.0.0.tar.gz 1325812 SHA256 be7f86a37517df05c6aaa9b9e8d1dce1c1f6ea3f8c6a46333b1fe72858d1aaf2 SHA512 13f5dbcfa6af965f2075d60c645ebb19cbd6b18807b26f4f13a7a05f1cf552996f9846e856728a4e1dc621efda693016e82623d4a3cbf74849b3e7114f19faca WHIRLPOOL 973b2d63b9f12f93f81c5fdd2a8847610442e43fb65544c0a80f82650ede3880bb1fc9d98d1c7ac00da05d6607d6abf8cc7b970395ae607fd55cc0789bfd6234
diff --git a/dev-libs/libpreludedb/files/libpreludedb-4.0.0-fix-python-bindings.patch b/dev-libs/libpreludedb/files/libpreludedb-4.0.0-fix-python-bindings.patch
new file mode 100644
index 000000000000..7fb93c269ef2
--- /dev/null
+++ b/dev-libs/libpreludedb/files/libpreludedb-4.0.0-fix-python-bindings.patch
@@ -0,0 +1,39 @@
+--- a/bindings/python/Makefile.am 2017-07-18 12:27:27.278000000 +0200
++++ b/bindings/python/Makefile.am 2017-09-07 23:41:21.279920258 +0200
+@@ -6,36 +6,6 @@
+ all-am: python-build
+
+ python-build: _preludedb.cxx
+-if HAVE_PYTHON2
+- CC="$(CXX)" $(PYTHON2) setup.py build
+-endif
+-if HAVE_PYTHON3
+- CC="$(CXX)" $(PYTHON3) setup.py build
+-endif
+-install-exec-hook:
+-if HAVE_PYTHON2
+- $(PYTHON2) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
+-endif
+-if HAVE_PYTHON3
+- $(PYTHON3) setup.py install `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
+-endif
+-
+-uninstall-hook:
+-if HAVE_PYTHON2
+- $(PYTHON2) setup.py uninstall `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
+-endif
+-if HAVE_PYTHON3
+- $(PYTHON3) setup.py uninstall `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
+-endif
+-
+-clean-local:
+-if HAVE_PYTHON2
+- $(PYTHON2) setup.py clean -a
+-endif
+-if HAVE_PYTHON3
+- $(PYTHON3) setup.py clean -a
+-endif
+-
+
+ _preludedb.cxx preludedb.py: $(top_srcdir)/bindings/c++/include/*.hxx $(top_srcdir)/bindings/libpreludedbcpp.i libpreludedbcpp-python.i
+ if HAVE_SWIG
diff --git a/dev-libs/libpreludedb/libpreludedb-4.0.0.ebuild b/dev-libs/libpreludedb/libpreludedb-4.0.0.ebuild
new file mode 100644
index 000000000000..2fb7ad0e091e
--- /dev/null
+++ b/dev-libs/libpreludedb/libpreludedb-4.0.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+DISTUTILS_OPTIONAL=1
+
+inherit autotools distutils-r1 ruby-single
+
+DESCRIPTION="Framework to easy access to the Prelude database"
+HOMEPAGE="https://www.prelude-siem.org"
+SRC_URI="https://www.prelude-siem.org/pkg/src/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql postgres python sqlite"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="~dev-libs/libprelude-${PV}
+ net-libs/gnutls:=
+ mysql? ( virtual/libmysqlclient )
+ postgres? ( dev-db/postgresql:* )
+ python? ( ${PYTHON_DEPS} )
+ sqlite? ( dev-db/sqlite:3 )"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-3.0.7
+ dev-util/gtk-doc-am
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-python-bindings.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if use python; then
+ cd bindings/python || die
+ distutils-r1_src_prepare
+ fi
+}
+
+src_configure() {
+ local myconf=(
+ --enable-easy-bindings
+ --with-swig
+ $(use_with mysql)
+ $(use_with postgres postgresql)
+ $(use_with sqlite sqlite3)
+ )
+
+ if use python; then
+ python_setup
+ if python_is_python3; then
+ myconf+=(--without-python2 --with-python3="${EPYTHON}")
+ else
+ myconf+=(--without-python3 --with-python2="${EPYTHON}")
+ fi
+ else
+ myconf+=(--without-python2 --without-python3)
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+ if use python; then
+ cd bindings/python || die
+ distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ if use python; then
+ cd bindings/python || die
+ distutils-r1_src_install
+ fi
+}