summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libsodium
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libsodium')
-rw-r--r--dev-libs/libsodium/Manifest2
-rw-r--r--dev-libs/libsodium/libsodium-1.0.2.ebuild35
-rw-r--r--dev-libs/libsodium/libsodium-1.0.3.ebuild35
-rw-r--r--dev-libs/libsodium/metadata.xml23
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-libs/libsodium/Manifest b/dev-libs/libsodium/Manifest
new file mode 100644
index 000000000000..cd80fa084b61
--- /dev/null
+++ b/dev-libs/libsodium/Manifest
@@ -0,0 +1,2 @@
+DIST libsodium-1.0.2.tar.gz 1673394 SHA256 961d8f10047f545ae658bcc73b8ab0bf2c312ac945968dd579d87c768e5baa19 SHA512 15fc47516f0e35906c1c304205fa991e74a273e4e6fc2186b6c16f0e41523de24493e149262b97ef03e4adc221232372ef1f283c4c23f96e4c5d99023d361e14 WHIRLPOOL 18509d9911c1d0ec6e8b9a8735abfeb2c1623669d31045abc6d9dd1289571fbe3a055f960f42a86779e7c03967532d71d7b9d0597ecfe457672e69b27b577e48
+DIST libsodium-1.0.3.tar.gz 1679664 SHA256 cbcfc63cc90c05d18a20f229a62c7e7054a73731d0aa858c0517152c549b1288 SHA512 7d58ddf973bfc456c2d196129d2c3a9ddec6e40b977797251385cd42bdd1234987779566903b7c2251cae02aab7e1c5246967af4c887be8a3451ae3f745c1ae5 WHIRLPOOL 1722d2c9f8bb18fe5d74b1ffe3600fe0a17779569315558324fd3262d63c0db5c9368d3bf9a6bb421802882dd1fd2c701ad062938a5f414190670f8c7f244231
diff --git a/dev-libs/libsodium/libsodium-1.0.2.ebuild b/dev-libs/libsodium/libsodium-1.0.2.ebuild
new file mode 100644
index 000000000000..ca4a68e8b2ae
--- /dev/null
+++ b/dev-libs/libsodium/libsodium-1.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A portable fork of NaCl, a higher-level cryptographic library"
+HOMEPAGE="https://github.com/jedisct1/libsodium"
+SRC_URI="http://download.libsodium.org/${PN}/releases/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/13"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="+asm minimal static-libs +urandom"
+
+src_configure() {
+ local myconf
+
+ # --disable-pie needed on x86, bug #512734
+ use x86 && myconf="${myconf} --disable-pie"
+
+ econf \
+ $(use_enable asm) \
+ $(use_enable minimal) \
+ $(use_enable !urandom blocking-random) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/libsodium/libsodium-1.0.3.ebuild b/dev-libs/libsodium/libsodium-1.0.3.ebuild
new file mode 100644
index 000000000000..a87bde865f6b
--- /dev/null
+++ b/dev-libs/libsodium/libsodium-1.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A portable fork of NaCl, a higher-level cryptographic library"
+HOMEPAGE="https://github.com/jedisct1/libsodium"
+SRC_URI="http://download.libsodium.org/${PN}/releases/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/13"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+asm minimal static-libs +urandom"
+
+src_configure() {
+ local myconf
+
+ # --disable-pie needed on x86, bug #512734
+ use x86 && myconf="${myconf} --disable-pie"
+
+ econf \
+ $(use_enable asm) \
+ $(use_enable minimal) \
+ $(use_enable !urandom blocking-random) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/libsodium/metadata.xml b/dev-libs/libsodium/metadata.xml
new file mode 100644
index 000000000000..42278004388b
--- /dev/null
+++ b/dev-libs/libsodium/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <longdescription>
+ NaCl (pronounced "salt") is a new easy-to-use high-speed software
+ library for network communication, encryption, decryption,
+ signatures, etc. NaCl's goal is to provide all of the core
+ operations needed to build higher-level cryptographic tools.
+ Sodium is a portable, cross-compilable, installable,
+ packageable fork of NaCl, with a compatible API.
+ </longdescription>
+ <use>
+ <flag name="asm">Enables assembly implementations</flag>
+ <flag name="urandom">Use /dev/urandom instead of /dev/random</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">jedisct1/libsodium</remote-id>
+ </upstream>
+</pkgmetadata>