summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2022-05-12 09:11:34 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-13 10:05:53 +0200
commit7bb0c333335b9d7c155a4a114ea0a1a0af33b054 (patch)
tree150ed5107c3aca9de3da7fe9032ac17468beeaa8 /dev-libs/libstrophe
parentapp-emacs/nim-mode: new package; add version 0.4.2_p20211102 (diff)
downloadgentoo-7bb0c333335b9d7c155a4a114ea0a1a0af33b054.tar.gz
gentoo-7bb0c333335b9d7c155a4a114ea0a1a0af33b054.tar.bz2
gentoo-7bb0c333335b9d7c155a4a114ea0a1a0af33b054.zip
dev-libs/libstrophe: add 0.12.0
Also introduces subslot 0.1, representing upstream's decision to add SONAME versioning, starting with SONAME version 0. `.1` was appended to the subslot to force a different subslot from the default one and can be removed with the next subslot. Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-libs/libstrophe')
-rw-r--r--dev-libs/libstrophe/Manifest1
-rw-r--r--dev-libs/libstrophe/libstrophe-0.12.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libstrophe/Manifest b/dev-libs/libstrophe/Manifest
index 943d1adc3738..463ae672fee4 100644
--- a/dev-libs/libstrophe/Manifest
+++ b/dev-libs/libstrophe/Manifest
@@ -1,2 +1,3 @@
DIST libstrophe-0.10.0.tar.xz 357896 BLAKE2B b457c1556b7bd8012fd0b0badb962c0002ca38884e246911b25c8e01fa785a08c316a18c84e8f9e124ebeed636c586097a2dacf56c7c94062ac262e44f9473d0 SHA512 cffd71f3c83f53a4f0681916249842cc17e11fc28afa940e29a786ee02c5294a11115c115b12d200e185a62520623c68e1d4514ab374423e13e26b9438d80ea8
DIST libstrophe-0.11.0.tar.xz 370740 BLAKE2B 19f240383e81ea2733505b8361ba061ba69b09227eddfb958aa3027d7c3aca2f1739977e003b980ecf5501fde5ffa2bdb0a0618aff70637b11f94dbd70fce3a4 SHA512 3fd3fc395d1c86787cccf9dfb54805a56d650687db17ee28107f4fd610aa250c40cd6052d5c8c48110d69a8bceddb913570efca24874733d3e9a016dd90df65c
+DIST libstrophe-0.12.0.tar.xz 397120 BLAKE2B 6ac32e317e14a8641b1d092026772264682b7b0980158757a82036f3db2643a6429e5553d9173b578111d5b8b503e9a98a4e140f98f8ac03866758624a1cec67 SHA512 dd0fc54840bb5626859f91c7bbe5204ea89332856392a5a33c50cf7f66c8aaa7b0d7c24bd737e8473d63f2c9d7683a75dcb9465a19634d14e54c9f8f20580884
diff --git a/dev-libs/libstrophe/libstrophe-0.12.0.ebuild b/dev-libs/libstrophe/libstrophe-0.12.0.ebuild
new file mode 100644
index 000000000000..31bb9d386052
--- /dev/null
+++ b/dev-libs/libstrophe/libstrophe-0.12.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
+HOMEPAGE="http://strophe.im/libstrophe/"
+SRC_URI="https://github.com/strophe/${PN}/releases/download/${PV}/${P}.tar.xz"
+LICENSE="|| ( MIT GPL-3 )"
+# Subslot: ${SONAME}.1 to differentiate from previous versions without SONAME
+SLOT="0/0.1"
+KEYWORDS="~amd64"
+IUSE="doc expat gnutls"
+
+RDEPEND="
+ expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2:2 )
+ gnutls? ( net-libs/gnutls:0= )
+ !gnutls? ( dev-libs/openssl:0= )
+ dev-libs/openssl:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=( ChangeLog )
+
+src_configure() {
+ # shellcheck disable=SC2207
+ local myeconf=(
+ --enable-tls
+ $(use_with !expat libxml2)
+ $(use_with gnutls)
+ )
+ econf "${myeconf[@]}"
+}
+src_compile() {
+ default
+ if use doc; then
+ doxygen || die
+ HTML_DOCS=( docs/html/* )
+ fi
+}
+
+src_install() {
+ default
+ use doc && dodoc -r examples
+ find "${D}" -type f \( -name '*.la' -o -name '*.a' \) -delete || die
+}
+
+# Explicit src_test is there to document that the test suite is integrated and
+# is expected to pass. Please do not remove.
+src_test() {
+ emake check
+}