summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-06-03 09:50:58 +0200
committerDavid Seifert <soap@gentoo.org>2024-06-03 09:50:58 +0200
commitdeb74f8ef889a482fb8f061977636bedd45d615c (patch)
tree13b5062c47dd6b23b33506e1a2e63d8b99ec2f07 /dev-libs/link-grammar
parentdev-libs/link-grammar: force LEX="sys-devel/flex" (diff)
downloadgentoo-deb74f8ef889a482fb8f061977636bedd45d615c.tar.gz
gentoo-deb74f8ef889a482fb8f061977636bedd45d615c.tar.bz2
gentoo-deb74f8ef889a482fb8f061977636bedd45d615c.zip
dev-libs/link-grammar: drop 5.12.3
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/link-grammar')
-rw-r--r--dev-libs/link-grammar/Manifest1
-rw-r--r--dev-libs/link-grammar/files/link-grammar-5.12.3-Wimplicit-function-declaration.patch35
-rw-r--r--dev-libs/link-grammar/link-grammar-5.12.3.ebuild118
3 files changed, 0 insertions, 154 deletions
diff --git a/dev-libs/link-grammar/Manifest b/dev-libs/link-grammar/Manifest
index eff4c9094f3c..75d64829e040 100644
--- a/dev-libs/link-grammar/Manifest
+++ b/dev-libs/link-grammar/Manifest
@@ -1,2 +1 @@
-DIST link-grammar-5.12.3.tar.gz 4704751 BLAKE2B a7f0fe39c51ed26ea764d583b38b21cfce6e596c6cd94db6ba47b3606a2b6cd9e56bd6fedeb104dbb345baedae3e144af96999739dda9daa9a9e5886bd98d2f4 SHA512 e0fdb78ec03042119011afea005a62829317fd0bc20afcd94e3f234c9c5252ed9c57d717b75368ac4a63dd8493bd86f551870299925f3b9b95b11915f48d8abe
DIST link-grammar-5.12.4.tar.gz 4720724 BLAKE2B 6573895298128165d7f840a13aad124418dbd1b9c70436dbe2bd65b3fd1883777e72da13f5196031696edb7cdc6c9d86acd5fdd4d1aa8fb295a136b2ba0568cf SHA512 fd5318c21202c17902de996882fd8630c7e95622b8ebe6877a334df22ff678a6040e0519bdabfa1138aaefdf3a7c20cbfe9e65bdce4dfe568729c9ba5a2d6fe5
diff --git a/dev-libs/link-grammar/files/link-grammar-5.12.3-Wimplicit-function-declaration.patch b/dev-libs/link-grammar/files/link-grammar-5.12.3-Wimplicit-function-declaration.patch
deleted file mode 100644
index 55ca89c09b94..000000000000
--- a/dev-libs/link-grammar/files/link-grammar-5.12.3-Wimplicit-function-declaration.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 3cbc9ddfd4c3a3e407338619fa383d24da05b23d Mon Sep 17 00:00:00 2001
-From: David Seifert <soap@gentoo.org>
-Date: Sun, 7 May 2023 16:02:23 +0200
-Subject: [PATCH] Use correct guard macro for glibc heap functions
-
-* `__GNUC__` == Compiling with `-std=gnu*`
-* `__GLIBC__` == Compiling against glibc
-
-Bug: https://bugs.gentoo.org/903749
----
- link-grammar/parse/extract-links.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/link-grammar/parse/extract-links.c b/link-grammar/parse/extract-links.c
-index a6129ac7a..e2ce266bc 100644
---- a/link-grammar/parse/extract-links.c
-+++ b/link-grammar/parse/extract-links.c
-@@ -278,7 +278,7 @@ void free_extractor(extractor_t * pex)
- pex->x_table_size = 0;
- pex->x_table = NULL;
-
--#if defined __GNUC__
-+#if defined __GLIBC__
- // MST parsing can result in pathological cases, with almost a
- // billion elts in the Parse_choice_pool. This blows up the
- // resident-set size (RSS) over time. Avoid this issue by trimming.
-@@ -294,7 +294,7 @@ void free_extractor(extractor_t * pex)
-
- xfree((void *) pex, sizeof(extractor_t));
-
--#if defined __GNUC__
-+#if defined __GLIBC__
- // malloc_trim() is a gnu extension. An alternative would be
- // to call madvise(MADV_DONTNEED) but this is more complicated.
- if (trim) malloc_trim(0);
diff --git a/dev-libs/link-grammar/link-grammar-5.12.3.ebuild b/dev-libs/link-grammar/link-grammar-5.12.3.ebuild
deleted file mode 100644
index 9b58401971bf..000000000000
--- a/dev-libs/link-grammar/link-grammar-5.12.3.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit autotools python-r1 out-of-source
-
-DESCRIPTION="A Syntactic English parser"
-HOMEPAGE="https://www.abisource.com/projects/link-grammar/ https://www.link.cs.cmu.edu/link/"
-SRC_URI="https://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/5"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc ~x86"
-IUSE="aspell +hunspell python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-# XXX: sqlite is automagic
-# Does not build with >=sci-mathematics/minisat-2, bug #593662
-RDEPEND="
- dev-db/sqlite:3
- dev-libs/libpcre2:=
- aspell? ( app-text/aspell )
- hunspell? ( app-text/hunspell )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-lang/swig:0
- dev-build/autoconf-archive
- virtual/pkgconfig"
-
-PATCHES=(
- # upstreamed (https://github.com/opencog/link-grammar/pull/1471)
- "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
-)
-
-QA_CONFIG_IMPL_DECL_SKIP=(
- # _AC_UNDECLARED_BUILTIN false positive
- strchr
-)
-
-pkg_setup() {
- if use aspell && use hunspell; then
- ewarn "You have enabled 'aspell' and 'hunspell' support, but both cannot coexist,"
- ewarn "only hunspell will be built. Press Ctrl+C and set only 'aspell' USE flag if"
- ewarn "you want aspell support."
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-my_src_configure() {
- local myconf=(
- --disable-maintainer-mode
- --disable-editline
- # java is hopelessly broken, invokes maven at build time (bug #806157)
- --disable-java-bindings
- --disable-perl-bindings
- --disable-sat-solver
- --with-regexlib=pcre2
- $(use_enable aspell)
- $(use_enable hunspell)
- $(usev hunspell --with-hunspell-dictdir="${EPREFIX}"/usr/share/myspell)
- )
-
- econf \
- --disable-python-bindings \
- "${myconf[@]}"
-
- if use python; then
- python_configure() {
- econf \
- --enable-python-bindings \
- "${myconf[@]}"
- }
- python_foreach_impl run_in_build_dir python_configure
- fi
-}
-
-my_src_compile() {
- local -x MAIN_BUILD_DIR="${BUILD_DIR}"
- default
-
- if use python; then
- python_compile() {
- emake -C bindings/python \
- VPATH="${S}:${MAIN_BUILD_DIR}" \
- _clinkgrammar_la_DEPENDENCIES="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la \
- _clinkgrammar_la_LIBADD="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la
- }
- python_foreach_impl run_in_build_dir python_compile
- fi
-}
-
-my_src_install() {
- local -x MAIN_BUILD_DIR="${BUILD_DIR}"
- default
-
- if use python; then
- python_install() {
- emake -C bindings/python \
- VPATH="${S}:${MAIN_BUILD_DIR}" \
- _clinkgrammar_la_DEPENDENCIES="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la \
- _clinkgrammar_la_LIBADD="${MAIN_BUILD_DIR}"/link-grammar/liblink-grammar.la \
- DESTDIR="${D}" \
- install
- }
- python_foreach_impl run_in_build_dir python_install
- fi
-
- # no static archives
- find "${ED}" -name '*.la' -delete || die
-}