summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-09-13 19:38:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-10-02 14:58:37 +0200
commitbe89122e2ed5287573e763e29036f42eeee59985 (patch)
tree043ae99e66fcefd25380946271753bc84358c43c /dev-libs/qtkeychain
parentsci-libs/gdal: Fix build with app-text/poppler-21.10.0 (diff)
downloadgentoo-be89122e2ed5287573e763e29036f42eeee59985.tar.gz
gentoo-be89122e2ed5287573e763e29036f42eeee59985.tar.bz2
gentoo-be89122e2ed5287573e763e29036f42eeee59985.zip
dev-libs/qtkeychain: Version bump 0.12.0
Closes: https://bugs.gentoo.org/782382 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Closes: https://github.com/gentoo/gentoo/pull/22286 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/qtkeychain')
-rw-r--r--dev-libs/qtkeychain/Manifest1
-rw-r--r--dev-libs/qtkeychain/qtkeychain-0.12.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/qtkeychain/Manifest b/dev-libs/qtkeychain/Manifest
index 2f780f01c857..1ad4dda38e52 100644
--- a/dev-libs/qtkeychain/Manifest
+++ b/dev-libs/qtkeychain/Manifest
@@ -1 +1,2 @@
DIST qtkeychain-0.11.1.tar.gz 41001 BLAKE2B 155ca333d403e6ad91c2f733dec06e7957d3998c8124156cf33ea9b79521a6838e9c5a317b591897543b820d436d89ce3eada6425318d801834c133b6c55c982 SHA512 45551003000b8ed76d44767c54d18dcbb956d5aeb63d8bf2f0fc06c61eab4d7d2e70b894e9c0729722dfcb5004f818f4f4c9a413444fc2aebe0271f104b500e6
+DIST qtkeychain-0.12.0.tar.gz 46070 BLAKE2B 42ae7b1e86cdfd26c7603c7bf3dfda9e0b856e44e531b92436ba260e32d51be9884602afff996c9cf5837c3cf6453fec70a9d06ac2e51c7e028305706e0ceeeb SHA512 ad8f7b3e8f59894a09892aeb78118f5ed93aa4593eece782c1879a4f3c37d9d63e8d40ad4b2e6a2e286e0da39f45cd4ed46181a1a05c078a59134114b2456a03
diff --git a/dev-libs/qtkeychain/qtkeychain-0.12.0.ebuild b/dev-libs/qtkeychain/qtkeychain-0.12.0.ebuild
new file mode 100644
index 000000000000..b2a7c0bb00b7
--- /dev/null
+++ b/dev-libs/qtkeychain/qtkeychain-0.12.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+HOMEPAGE="https://github.com/frankosterfeld/qtkeychain"
+DESCRIPTION="Qt API for storing passwords securely"
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/frankosterfeld/qtkeychain/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="${HOMEPAGE}.git"
+fi
+
+LICENSE="BSD-2"
+SLOT="0/1"
+IUSE="gnome-keyring"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ gnome-keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog ReadMe.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_QT6=OFF
+ -DQTKEYCHAIN_STATIC=OFF
+ -DBUILD_TEST_APPLICATION=OFF
+ -DBUILD_TRANSLATIONS=ON
+ -DLIBSECRET_SUPPORT=$(usex gnome-keyring)
+ )
+
+ cmake_src_configure
+}