summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2024-02-03 10:17:35 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-02-03 10:17:52 +0200
commit3cd78d6b8a4ea47beda2ee5ba90d919587459f11 (patch)
tree72c673e370c253010c9836f72c88413c77b069dc /dev-libs/raft
parentapp-containers/lxd: add 5.0.3 (diff)
downloadgentoo-3cd78d6b8a4ea47beda2ee5ba90d919587459f11.tar.gz
gentoo-3cd78d6b8a4ea47beda2ee5ba90d919587459f11.tar.bz2
gentoo-3cd78d6b8a4ea47beda2ee5ba90d919587459f11.zip
dev-libs/raft: add 0.21.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/raft')
-rw-r--r--dev-libs/raft/Manifest1
-rw-r--r--dev-libs/raft/raft-0.21.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/raft/Manifest b/dev-libs/raft/Manifest
index d5b288185dab..8ae1fad6294d 100644
--- a/dev-libs/raft/Manifest
+++ b/dev-libs/raft/Manifest
@@ -1,3 +1,4 @@
DIST raft-0.18.3.tar.gz 335916 BLAKE2B f8dbf5f5ae89645a2d99e8b4b8c80560f64226deb2ac10e683f337c98f458fc5db7898b1e0fd9754f14ded07aa058daf88e03003a037729bdafdab3539b8ca46 SHA512 0ba0ea71b70d2769da22482cfeac5c59a17f4fa75d582075108411d633db75c7d6f6e817ce14768c15bd5c977987650e813019808932bafcac5753478c672916
DIST raft-0.19.1.tar.gz 354736 BLAKE2B cfdb9a1948311debe99b56e0f9c1f19fb858248ab1138648e26a21d965cc488aea504711415ff569d2e80a15414a1f15ca9b34ff9b3de62b03580755cefe30b3 SHA512 4990dca1f61dcda82acaf043a5b81dd9a3b92a0f3e0be9b2c339d764be338220f2fab31ed8bae535153b1d81c86364d447774b52da2c8b90c5daa7b8718d7ae2
DIST raft-0.20.0.tar.gz 360152 BLAKE2B 7eb109b483a298a60c5ea46b1df55a611cb5c40b7b7d14c29d615384ac0b8dd582a521e8da1a616cfe312f675980be55669c77a7d070dabbf1f20a99970097a6 SHA512 d29fd1e610c7e668a0ca25f60a5644b807a24c642993a3e0b54593f9f640a719bb38a6b45f72ded7fbd332817a1137e2d08bdcc74d2afd675e4d0e3dda27358c
+DIST raft-0.21.0.tar.gz 362922 BLAKE2B c1594ca3aa111882ff5b0442cb4deb7ceec9978429e4e8a8c97251716cb876a9c9444527c90ef70acad2bf6d53378d27fb14a44e1497364c1a1270f01fe712ce SHA512 08e3dfe262ac39f50e990eb0fa65462255a3d6b5e87484fd5a6223d9b54f508e3aa0cd134286b99272b181fcef138bf8035d3c6e3be0aee22d25f2d42295904d
diff --git a/dev-libs/raft/raft-0.21.0.ebuild b/dev-libs/raft/raft-0.21.0.ebuild
new file mode 100644
index 000000000000..4b51fe639271
--- /dev/null
+++ b/dev-libs/raft/raft-0.21.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C implementation of the Raft consensus protocol"
+HOMEPAGE="https://github.com/cowsql/raft"
+SRC_URI="https://github.com/cowsql/raft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+
+# Upstream change from canonical to cowsql resetted SONAME, 3 -> 0. bgo#915960
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="lz4 test zfs"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/libuv:=
+ lz4? ( app-arch/lz4:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/raft-0.10.0-toggle-zfs.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # --disable-hardening: most of these are covered on non-hardened Gentoo already.
+ local myeconfargs=(
+ --enable-uv
+ --enable-v0
+
+ --disable-backtrace
+ --disable-benchmark
+ --disable-debug
+ --disable-example
+ --disable-hardening
+ --disable-sanitize
+ --disable-static
+
+ $(use_enable test fixture)
+
+ $(use_with lz4)
+ $(use_with zfs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}