summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyang Wu <xgreenlandforwyy@gmail.com>2022-06-25 18:55:21 +0800
committerBenda Xu <heroxbd@gentoo.org>2022-08-06 22:20:23 +0800
commit2d98f165c76cf3da395a8acfb22442bf5c848d21 (patch)
tree1662319824972a1fdc6f4cb5b88bde5700bf4db1 /dev-libs/roct-thunk-interface
parentdev-libs/rocm-device-libs: add 5.1.3 (diff)
downloadgentoo-2d98f165c76cf3da395a8acfb22442bf5c848d21.tar.gz
gentoo-2d98f165c76cf3da395a8acfb22442bf5c848d21.tar.bz2
gentoo-2d98f165c76cf3da395a8acfb22442bf5c848d21.zip
dev-libs/roct-thunk-interface: add 5.1.3
Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-libs/roct-thunk-interface')
-rw-r--r--dev-libs/roct-thunk-interface/Manifest1
-rw-r--r--dev-libs/roct-thunk-interface/roct-thunk-interface-5.1.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/roct-thunk-interface/Manifest b/dev-libs/roct-thunk-interface/Manifest
index 8eb3d57d96b4..4e38d834ffb1 100644
--- a/dev-libs/roct-thunk-interface/Manifest
+++ b/dev-libs/roct-thunk-interface/Manifest
@@ -4,3 +4,4 @@ DIST roct-thunk-interface-4.2.0.tar.gz 3162877 BLAKE2B 48196c2334a5514c17a5b6ca1
DIST roct-thunk-interface-4.3.0.tar.gz 3177655 BLAKE2B e3746bb361731484acb5da8c48246fa9ce6cce46919bc771e2670bc4694e09147b51b65274cc58d690e06ce6781aca54d67508625d9ffc1e30f42dbd69adabd5 SHA512 c0515784696464feef906d6ef4446c9bddb77b5abe62e982a7d75331a8b7fb84e94f12ebeaf2e128be28ab8f903bf6894cbf2302aa5ddee23eaf9b2cc807c872
DIST roct-thunk-interface-4.5.2.tar.gz 3178434 BLAKE2B 3333b3416d1f7f26401a543ff5ef1b728a6efc38c5c9306d98cb03f034f8b0e10f961f9863192c23a6b7a70ff543e2d8abb60169a4a9a0c5992f2483e6f69db2 SHA512 6f51956df14532a3428f56a80479357c703c26589c68b054a340d751e34435211500c441fc90d7edbbb7c6c327a8ba71afafc8355c8c0e7a1cd45a9c9d0d99e6
DIST roct-thunk-interface-5.0.2.tar.gz 3178727 BLAKE2B 9b8926ec18340a686f0499070dd4846fb9ba3eae2fed2d02615fbbee977c3417cb5815b54a19aed7623484e175702cb757e8f3ac30b8b9f04ce4cf0ce81b2cc5 SHA512 c78a4d22d6e09decfec8c710707bc89ca30d3deba9ee3123af83d530f1bf58cb3681206a8c2ad8a523ff45621b87701020cfce23bba4fd87b81791ee8f04619e
+DIST roct-thunk-interface-5.1.3.tar.gz 3178689 BLAKE2B c46af7bc60772beaa9a214a86a634290cfd7952589f70736c0c2544c0459eb4fdcc65030d897dbb67bfbaae545f529ac647397df3fcfeddeb5d5e05a283cfd6b SHA512 746a04e667ce242160d6e2519594fc93b205520dae28678859fbd40c3c641082aa6219c04c8e2b58289763a5244dd6336b56c2e2016ba671c5e5a6fb9ca5caea
diff --git a/dev-libs/roct-thunk-interface/roct-thunk-interface-5.1.3.ebuild b/dev-libs/roct-thunk-interface/roct-thunk-interface-5.1.3.ebuild
new file mode 100644
index 000000000000..d0cf376f0b8d
--- /dev/null
+++ b/dev-libs/roct-thunk-interface/roct-thunk-interface-5.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake linux-info
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCT-Thunk-Interface-rocm-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Thunk Interface"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface"
+CONFIG_CHECK="~HSA_AMD ~HMM_MIRROR ~ZONE_DEVICE ~DRM_AMDGPU ~DRM_AMDGPU_USERPTR"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="sys-process/numactl"
+DEPEND="${RDEPEND}"
+BDEPEND="x11-libs/libdrm[video_cards_amdgpu]"
+
+CMAKE_BUILD_TYPE=Release
+
+src_prepare() {
+ sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
+ sed -e "s:ubuntu:gentoo:" -i CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCPACK_PACKAGING_INSTALL_PREFIX="${EPREFIX}/usr"
+ )
+ cmake_src_configure
+}