summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-03-14 01:51:07 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-03-14 01:51:25 +0100
commita58e9d9e453c2181fb076de2113cf14b2c7e2e5c (patch)
tree7626a3a7a1c5327d30a7eb153b43f292ae887797 /dev-lua
parentgames-simulation/openrct2: bump to version 0.3.3 (diff)
downloadgentoo-a58e9d9e453c2181fb076de2113cf14b2c7e2e5c.tar.gz
gentoo-a58e9d9e453c2181fb076de2113cf14b2c7e2e5c.tar.bz2
gentoo-a58e9d9e453c2181fb076de2113cf14b2c7e2e5c.zip
dev-lua/lua-argparse: bump to version 0.7.1
Upstream changed to luarocks now, but unfortunately, docs and tests have been removed. Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lua-argparse/Manifest1
-rw-r--r--dev-lua/lua-argparse/lua-argparse-0.7.1.ebuild31
-rw-r--r--dev-lua/lua-argparse/metadata.xml1
3 files changed, 33 insertions, 0 deletions
diff --git a/dev-lua/lua-argparse/Manifest b/dev-lua/lua-argparse/Manifest
index 2adc19a51a1b..2d0fc3a81478 100644
--- a/dev-lua/lua-argparse/Manifest
+++ b/dev-lua/lua-argparse/Manifest
@@ -1 +1,2 @@
DIST lua-argparse-0.6.0.tar.gz 36712 BLAKE2B 88882738453a894db68ef93557d870393eaec1fb2bf39b110bd2691678d26be64734d07c7f01f760d9c1d031e530707449ff2ca54a5cdd428cb8da3b1897a7e1 SHA512 7efdfab8ec563a9e7eddc7aff760fd4d3605df2896939af3f2c80e5ed4d4e5ba45a7815057e15446d242351a6fd139d6b8da802fe318d4a4bcd69918fece53d1
+DIST lua-argparse-0.7.1.tar.gz 43778 BLAKE2B 6bc6a3dee3fd98cb8c00fa3ccb3ae9ffdb9f2707d80dd7f5717e1265430731957b756672ed4acd9222c686108f8a8b8c71c71285c2540e818396faf302c1d287 SHA512 f192d0c591516a74408a19c0bbf34233be180f63794211a951d19fc8d981749bc71eace16a4680c8f2bb302ab48958c6a9ffc84022a1754275fc1f9113ae32b0
diff --git a/dev-lua/lua-argparse/lua-argparse-0.7.1.ebuild b/dev-lua/lua-argparse/lua-argparse-0.7.1.ebuild
new file mode 100644
index 000000000000..669314b5265b
--- /dev/null
+++ b/dev-lua/lua-argparse/lua-argparse-0.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Feature-rich command line parser for Lua"
+HOMEPAGE="https://github.com/luarocks/argparse"
+SRC_URI="https://github.com/luarocks/${PN/lua-/}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN//lua-/}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+lua_src_install() {
+ insinto "$(lua_get_lmod_dir)"
+ doins src/argparse.lua
+}
+
+src_install() {
+ default
+ lua_foreach_impl lua_src_install
+}
diff --git a/dev-lua/lua-argparse/metadata.xml b/dev-lua/lua-argparse/metadata.xml
index d44082c8ccab..00545cf23bff 100644
--- a/dev-lua/lua-argparse/metadata.xml
+++ b/dev-lua/lua-argparse/metadata.xml
@@ -20,6 +20,7 @@
and more. Argparse automatically generates usage, help and error messages.
</longdescription>
<upstream>
+ <remote-id type="github">luarocks/argparse</remote-id>
<remote-id type="github">mpeterv/argparse</remote-id>
</upstream>
</pkgmetadata>