summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-15 09:08:58 +0100
committerSam James <sam@gentoo.org>2021-04-16 12:16:15 +0100
commit22bf78e429a3df76f73ddc49adf21b6c63ab0ab6 (patch)
tree87053abb6c0d2a424985841058f2f63823df785c /dev-ml/camlidl
parentdev-lisp/sbcl: eutils-- (diff)
downloadgentoo-22bf78e429a3df76f73ddc49adf21b6c63ab0ab6.tar.gz
gentoo-22bf78e429a3df76f73ddc49adf21b6c63ab0ab6.tar.bz2
gentoo-22bf78e429a3df76f73ddc49adf21b6c63ab0ab6.zip
dev-ml/camlidl: eutils->epatch
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/camlidl')
-rw-r--r--dev-ml/camlidl/camlidl-1.05-r1.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/dev-ml/camlidl/camlidl-1.05-r1.ebuild b/dev-ml/camlidl/camlidl-1.05-r1.ebuild
index 6dd3e9f5d3d3..667d456641f4 100644
--- a/dev-ml/camlidl/camlidl-1.05-r1.ebuild
+++ b/dev-ml/camlidl/camlidl-1.05-r1.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils toolchain-funcs
+inherit epatch toolchain-funcs
DESCRIPTION="CamlIDL is a stub code generator for using C/C++ libraries from O'Caml"
HOMEPAGE="http://caml.inria.fr/camlidl/"
SRC_URI="http://caml.inria.fr/distrib/bazar-ocaml/${P}.tar.gz"
+
LICENSE="QPL-1.0 LGPL-2"
SLOT="0/${PV}"
KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE=""
+
DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt]"
RDEPEND="${DEPEND}"
@@ -23,10 +24,11 @@ src_prepare() {
src_compile() {
# Use the UNIX makefile
- libdir=`ocamlc -where`
- sed -i -e "s|OCAMLLIB=.*|OCAMLLIB=${libdir}|" config/Makefile.unix
- sed -i -e "s|BINDIR=.*|BINDIR=${EPREFIX}/usr/bin|" config/Makefile.unix
- ln -s Makefile.unix config/Makefile
+ libdir=$(ocamlc -where)
+
+ sed -i -e "s|OCAMLLIB=.*|OCAMLLIB=${libdir}|" config/Makefile.unix || die
+ sed -i -e "s|BINDIR=.*|BINDIR=${EPREFIX}/usr/bin|" config/Makefile.unix || die
+ ln -s Makefile.unix config/Makefile || die
# Make
emake -j1
@@ -34,12 +36,12 @@ src_compile() {
src_test() {
einfo "Running tests..."
- cd tests
+ cd tests || die
emake CCPP="$(tc-getCXX)"
}
src_install() {
- libdir=`ocamlc -where`
+ libdir=$(ocamlc -where)
dodir ${libdir#${EPREFIX}}/caml
dodir /usr/bin
# Install