summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-07-08 18:03:20 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-07-08 18:34:45 +0200
commit5ca12e07cbcd48960ea266e47df1c2702d6f038a (patch)
tree8c9f192e9e6936868c67bf4e636a119d5506c6e8 /dev-ml/core_unix
parentdev-ml/timezone: add 0.16.0 (diff)
downloadgentoo-5ca12e07cbcd48960ea266e47df1c2702d6f038a.tar.gz
gentoo-5ca12e07cbcd48960ea266e47df1c2702d6f038a.tar.bz2
gentoo-5ca12e07cbcd48960ea266e47df1c2702d6f038a.zip
dev-ml/core_unix: add 0.16.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/core_unix')
-rw-r--r--dev-ml/core_unix/Manifest1
-rw-r--r--dev-ml/core_unix/core_unix-0.16.0.ebuild38
-rw-r--r--dev-ml/core_unix/files/core_unix-0.16.0-musl.patch11
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-ml/core_unix/Manifest b/dev-ml/core_unix/Manifest
index c4f58231086c..a6a26540f675 100644
--- a/dev-ml/core_unix/Manifest
+++ b/dev-ml/core_unix/Manifest
@@ -1,2 +1,3 @@
DIST core_unix-0.15.0.tar.gz 377928 BLAKE2B 49b58471a28c356bdf39f15e22bd21ec4363182cf744c0455847ffc15015fdad2928a428986c2a9edff647ebef9f2ad2059b184b393e979119c8f007f67ec140 SHA512 eeb53bd0c06a7d1facfb133f0a45a232d57941eff644d4ed6c2d5002acd4e6b323376ec9c05838f760ebd9da3fbc39332989ed50b3921191c175811c947fcbfe
DIST core_unix-0.15.2.tar.gz 377836 BLAKE2B 56551ab1509bfecc59ae4b45aaaa4d336415cffe9339932239c884bc86207bdb4066aace35144618509b78b461164bdfaaaa04030ecb1b3619de6f8fe5c3a7b9 SHA512 6d59c52111235f952f3052fb86af1d7380ff3d8d89b5c8d59a66d530a14d462fa4b06cdf29f2ee2b4356a574dbefef33b82f60f9fba512942bc0e6aad07f2b6f
+DIST core_unix-0.16.0.tar.gz 391719 BLAKE2B 29105ee1b8342241dbea136207d221af04d9412a74412fb4fd532f08b22b842125a72e69a47d36129a99c04cd3a83e605bc42b970d79a52420b3e273bd9915d5 SHA512 e38a126af832360f0e0079919b930f3fa99b02935c35372b1ed8c7e174af335de2f4dcb8da90be8f9f524542752dd5c62ec6192eb327d7cc6313b7402b0f7f65
diff --git a/dev-ml/core_unix/core_unix-0.16.0.ebuild b/dev-ml/core_unix/core_unix-0.16.0.ebuild
new file mode 100644
index 000000000000..3abd67fa944c
--- /dev/null
+++ b/dev-ml/core_unix/core_unix-0.16.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit dune toolchain-funcs
+
+DESCRIPTION="Unix-specific portions of Core"
+HOMEPAGE="https://github.com/janestreet/core_unix"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/core:=
+ dev-ml/core_kernel:${SLOT}
+ dev-ml/expect_test_helpers_core:${SLOT}
+ dev-ml/ocaml_intrinsics:${SLOT}
+ >=dev-ml/spawn-0.15:=
+ dev-ml/timezone:${SLOT}
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-musl.patch )
+
+src_prepare() {
+ sed -i \
+ -e "s:gcc:$(tc-getCC):" \
+ unix_pseudo_terminal/src/discover.sh \
+ || die
+
+ default
+}
diff --git a/dev-ml/core_unix/files/core_unix-0.16.0-musl.patch b/dev-ml/core_unix/files/core_unix-0.16.0-musl.patch
new file mode 100644
index 000000000000..e37ad2f8454a
--- /dev/null
+++ b/dev-ml/core_unix/files/core_unix-0.16.0-musl.patch
@@ -0,0 +1,11 @@
+--- a/bigstring_unix/src/bigstring_unix_stubs.c 2023-07-08 18:01:05.614573701 +0200
++++ b/bigstring_unix/src/bigstring_unix_stubs.c 2023-07-08 18:01:20.505598860 +0200
+@@ -743,7 +743,7 @@
+ int count = Int_val(v_count);
+ size_t total_len = 0;
+ struct iovec *iovecs = copy_iovecs(&total_len, v_iovecs, count);
+- struct msghdr msghdr = {NULL, 0, NULL, 0, NULL, 0, 0};
++ struct msghdr msghdr = {NULL};
+ ssize_t ret;
+ if (total_len > THREAD_IO_CUTOFF || contains_mmapped(v_iovecs, count)) {
+ Begin_roots1(v_iovecs);