summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-21 17:16:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-21 18:33:55 +0200
commitc2bfc996adb8a7df1b0ba4eb5b33e8979b943c4d (patch)
tree2494108236a9bde536095367c3d3b75bc8755dc9 /dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild
parentdev-python/pycobertura: Add missing dependency (diff)
downloadgentoo-c2bfc996adb8a7df1b0ba4eb5b33e8979b943c4d.tar.gz
gentoo-c2bfc996adb8a7df1b0ba4eb5b33e8979b943c4d.tar.bz2
gentoo-c2bfc996adb8a7df1b0ba4eb5b33e8979b943c4d.zip
dev-ml/ocaml-magic-mime: bump to 1.1.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild')
-rw-r--r--dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild b/dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild
new file mode 100644
index 000000000000..17c16d0e2fa3
--- /dev/null
+++ b/dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Convert file extensions to MIME types"
+HOMEPAGE="https://github.com/mirage/ocaml-magic-mime"
+SRC_URI="https://github.com/mirage/ocaml-magic-mime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/ocaml:="
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ magic-mime.install || die
+}