summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 18:54:16 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commita3298280679f5b7f9574c75851cf0666b284bb7d (patch)
tree58d38c3485b0783dbb26b37d674412bace6a71e6 /dev-ml/ppx_compare
parentdev-ml/ppx_here: use proper install method (diff)
downloadgentoo-a3298280679f5b7f9574c75851cf0666b284bb7d.tar.gz
gentoo-a3298280679f5b7f9574c75851cf0666b284bb7d.tar.bz2
gentoo-a3298280679f5b7f9574c75851cf0666b284bb7d.zip
dev-ml/ppx_compare: use proper install method.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_compare')
-rw-r--r--dev-ml/ppx_compare/ppx_compare-113.24.00.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/dev-ml/ppx_compare/ppx_compare-113.24.00.ebuild b/dev-ml/ppx_compare/ppx_compare-113.24.00.ebuild
index 7a7398fc88cb..7b95ef5ae2dc 100644
--- a/dev-ml/ppx_compare/ppx_compare-113.24.00.ebuild
+++ b/dev-ml/ppx_compare/ppx_compare-113.24.00.ebuild
@@ -6,10 +6,9 @@ EAPI="5"
inherit oasis
-MY_P=${PN/-/_}-${PV}
DESCRIPTION="Generation of comparison functions from types"
HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0/${PV}"
@@ -23,7 +22,22 @@ DEPEND="
dev-ml/ppx_core:="
RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( CHANGES.md )
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}