summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-11-09 20:58:25 +0100
committerAlfredo Tupone <tupone@gentoo.org>2021-11-09 20:58:25 +0100
commit04b95b7e89870d1fdd69bc5c5e33c6363898be05 (patch)
treebb38216aed926d853c2efa91768d6b5ac6f58f10 /dev-ml/uunf/uunf-14.0.0.ebuild
parentdev-perl/Feed-Find: Keyword 0.120.0 x86, #820551 (diff)
downloadgentoo-04b95b7e89870d1fdd69bc5c5e33c6363898be05.tar.gz
gentoo-04b95b7e89870d1fdd69bc5c5e33c6363898be05.tar.bz2
gentoo-04b95b7e89870d1fdd69bc5c5e33c6363898be05.zip
dev-ml/uunf: 14.0.0 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/uunf/uunf-14.0.0.ebuild')
-rw-r--r--dev-ml/uunf/uunf-14.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/uunf/uunf-14.0.0.ebuild b/dev-ml/uunf/uunf-14.0.0.ebuild
new file mode 100644
index 000000000000..8d806d41586d
--- /dev/null
+++ b/dev-ml/uunf/uunf-14.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Unicode text normalization"
+HOMEPAGE="https://erratique.ch/software/uunf https://github.com/dbuenzli/uunf"
+SRC_URI="https://erratique.ch/software/uunf/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-ml/topkg:=
+ dev-ml/uutf:=
+ dev-ml/cmdliner:="
+RDEPEND="${DEPEND}"
+BDEPEND="dev-ml/findlib"
+OPAM_FILE=opam
+
+src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ # bug #798270
+ ulimit -s 11530000
+
+ ocaml pkg/pkg.ml build \
+ || die
+}