summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-29 00:49:07 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-29 00:55:50 +0200
commitfb796e82e12a5c13d8c8b1093e4e0d460ca5d302 (patch)
treeefda4d7e203d046ea37d50687b73e24ff4f4657a /dev-perl/Alien-HDF4/files
parentmedia-libs/gst-plugins-bad: block media-plugins/gst-transcoder (diff)
downloadgentoo-fb796e82e12a5c13d8c8b1093e4e0d460ca5d302.tar.gz
gentoo-fb796e82e12a5c13d8c8b1093e4e0d460ca5d302.tar.bz2
gentoo-fb796e82e12a5c13d8c8b1093e4e0d460ca5d302.zip
dev-perl/Alien-HDF4: New package, needed by dev-perl/PDL
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Alien-HDF4/files')
-rw-r--r--dev-perl/Alien-HDF4/files/Alien-HDF4-0.50.0-shared.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Alien-HDF4/files/Alien-HDF4-0.50.0-shared.patch b/dev-perl/Alien-HDF4/files/Alien-HDF4-0.50.0-shared.patch
new file mode 100644
index 000000000000..ffeabcf5b29e
--- /dev/null
+++ b/dev-perl/Alien-HDF4/files/Alien-HDF4-0.50.0-shared.patch
@@ -0,0 +1,32 @@
+diff -ruN Alien-HDF4-0.05.orig/common.pl Alien-HDF4-0.05/common.pl
+--- Alien-HDF4-0.05.orig/common.pl 2019-04-27 03:01:25.000000000 +0200
++++ Alien-HDF4-0.05/common.pl 2021-07-29 00:47:09.923447920 +0200
+@@ -36,13 +36,13 @@
+ foreach my $libdir ( @HDF_lib_locations ) {
+ return (
+ $libdir, '-lmfhdfalt -ldfalt',
+- ) if -e "$libdir/libdfalt.a";
++ ) if -e "$libdir/libdfalt.$Config{so}";
+ return (
+ $libdir, '-lmfhdf -ldf',
+- ) if -e "$libdir/libdf.a";
++ ) if -e "$libdir/libdf.$Config{so}";
+ return (
+ $libdir, '-lmfhdf -lhdf -lxdr',
+- ) if -e "$libdir/libhdf.a";
++ ) if -e "$libdir/libhdf.$Config{so}";
+ }
+ return;
+ }
+diff -ruN Alien-HDF4-0.05.orig/Makefile.PL Alien-HDF4-0.05/Makefile.PL
+--- Alien-HDF4-0.05.orig/Makefile.PL 2019-04-27 02:53:52.000000000 +0200
++++ Alien-HDF4-0.05/Makefile.PL 2021-07-29 00:46:34.395073467 +0200
+@@ -7,7 +7,7 @@
+
+ my ($libpath, $libs) = findlibs();
+ die <<EOF unless defined $libpath;
+-Cannot find hdf library, libdf.a.
++Cannot find hdf library, libdf.$Config{so}.
+ Please add the correct library path to Makefile.PL or install HDF
+ EOF
+