summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-06 03:45:09 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-06 03:45:09 +1200
commit6baccc5ec7e9224178e40e80777c97b1abe81549 (patch)
tree9f448b707a8abdb3aa16a2c198fa6a3ba2a49835 /dev-perl/BSON/BSON-1.12.1.ebuild
parentdev-perl/BSD-Resource: -r bump for EAPI7 and LICENSE fixes (diff)
downloadgentoo-6baccc5ec7e9224178e40e80777c97b1abe81549.tar.gz
gentoo-6baccc5ec7e9224178e40e80777c97b1abe81549.tar.bz2
gentoo-6baccc5ec7e9224178e40e80777c97b1abe81549.zip
dev-perl/BSON: Bump to 1.12.1
- EAPI7 Upstream: - Add BSON::Array wrapper to avoid ambiguity between top level document containers and data array references. - Add End-Of-Life notice. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/BSON/BSON-1.12.1.ebuild')
-rw-r--r--dev-perl/BSON/BSON-1.12.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-perl/BSON/BSON-1.12.1.ebuild b/dev-perl/BSON/BSON-1.12.1.ebuild
new file mode 100644
index 000000000000..230ba913879e
--- /dev/null
+++ b/dev-perl/BSON/BSON-1.12.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MONGODB
+DIST_VERSION=v1.12.1
+inherit perl-module
+
+DESCRIPTION="BSON serialization and deserialization"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Crypt-URandom
+ virtual/perl-Exporter
+ virtual/perl-MIME-Base64
+ virtual/perl-Math-BigInt
+ >=dev-perl/Moo-2.2.4
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Tie-IxHash
+ virtual/perl-Time-HiRes
+ virtual/perl-Time-Local
+ >=dev-perl/boolean-0.450.0
+ virtual/perl-if
+ dev-perl/namespace-clean
+ virtual/perl-threads-shared
+ virtual/perl-version
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ dev-perl/JSON-MaybeXS
+ >=virtual/perl-JSON-PP-2.970.10
+ >=dev-perl/Path-Tiny-0.54.0
+ dev-perl/Test-Deep
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"