summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-09 12:18:21 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-09 12:19:01 +1200
commite087fd0c10780edb2c9abc15bd1a2b11b60bdd7d (patch)
tree0b94612b1349602124a3a47cfbf800637cfeebab /dev-perl/DBD-Pg
parentwww-client/opera: Old (diff)
downloadgentoo-e087fd0c10780edb2c9abc15bd1a2b11b60bdd7d.tar.gz
gentoo-e087fd0c10780edb2c9abc15bd1a2b11b60bdd7d.tar.bz2
gentoo-e087fd0c10780edb2c9abc15bd1a2b11b60bdd7d.zip
dev-perl/DBD-Pg: Bump to version 3.13.0
- EAPI7 - Unconditionally remove t/00_signature.t - Ensure CFLAGS passed to make/compiler - Resurrect compie-testing for Bundle::DBD::Pg - Disable t/03*.t and t/04*.t due to https://rt.cpan.org/Ticket/Display.html?id=132965 Upstream: - Prevent double-free memory errors https://rt.cpan.org/Ticket/Display.html?id=130681 - Fix crash when pg_error_field is called https://rt.cpan.org/Ticket/Display.html?id=130721 - Update list of Postgres reserved words in quote.c - Fix tests for 32-bit machines - Eagerly NULL-ify PQclear-ed things to remove race conditions https://rt.cpan.org/Ticket/Display.html?id=131522 - Allow localtime from Time::Piece, and other magical arrays, to be used directly as a bind value again. - Fix tests for EnterpriseDB server - Add small warning regarding ShowErrorStatement - Indicate non-key index columns in statistics_info - Return empty result set instead of undef from statistics_info when table NOTEXIST and not $unique_only - Fix Segfault during st destroy https://github.com/bucardo/dbdpg/issues/57 https://github.com/bucardo/dbdpg/pull/66 - Improve testing for table_info() - Fix failing 'fulltest' target on BSD - Return table info row last in statistics_info for compat with pre-8.3 servers - Fix ASC_OR_DESC field in statistics_info - Indicate NULL ordering in statistics_info - Remove test that assumed '(12,34)' to be invalid for type 'circle' as Postgres now handles it better. - Prevent DBI turning AutoCommit 'on' after a failed commit - Fix memory leak in dbdimp.c by redoing the "last_result" internals https://rt.cpan.org/Ticket/Display.html?id=132812 - Fix regression in Perl length() for returned query results - Make $sth->finish() do less, so that among other things, pg_error_field still works on the last action performed. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/DBD-Pg')
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.13.0.ebuild114
-rw-r--r--dev-perl/DBD-Pg/Manifest1
2 files changed, 115 insertions, 0 deletions
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.13.0.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.13.0.ebuild
new file mode 100644
index 000000000000..252be08d1029
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-3.13.0.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TURNSTEP
+inherit perl-module
+
+DESCRIPTION="PostgreSQL database driver for the DBI module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-version
+ >=dev-perl/DBI-1.614.0
+ dev-db/postgresql:*
+"
+DEPEND="
+ dev-db/postgresql:*
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ virtual/perl-Time-HiRes
+ )
+"
+PERL_RM_FILES=(
+ "t/00_signature.t"
+)
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
+
+src_test() {
+ local MODULES=(
+ "Bundle::DBD::Pg v${PV}"
+ "DBD::Pg v${PV}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1 #||
+ #die "Could not load ${dep}"
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+
+ local LIVEDB_TESTS=(
+ "t/01connect.t"
+ "t/02attribs.t"
+ "t/03dbmethod.t"
+ "t/03smethod.t"
+ "t/04misc.t"
+ "t/06bytea.t"
+ "t/07copy.t"
+ "t/08async.t"
+ "t/09arrays.t"
+ "t/12placeholders.t"
+ "t/20savepoints.t"
+ "t/30unicode.t"
+ )
+ if [[ ! -v DBI_DSN ]]; then
+ ewarn "Functional database tests disabled due to lack of configuration."
+ ewarn "Please set the following environment variables values pertaining to a"
+ ewarn "pre-configured Postgres installation in order for tests to work:"
+ ewarn " DBI_DSN - A DBI-compatible connection string for a Postgres Database"
+ ewarn " ( eg: dbi:Pg:dbname=testdb )"
+ ewarn " DBI_USER - A Postgres Database Username"
+ ewarn " DBI_PASS - A Postgres Database Password"
+ ewarn ""
+ ewarn "For details, visit:"
+ ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/DBD-Pg"
+ perl_rm_files "${LIVEDB_TESTS[@]}"
+ else
+ # Super user required
+ # https://rt.cpan.org/Ticket/Display.html?id=132965
+ perl_rm_files "t/03dbmethod.t" "t/04misc.t"
+ fi
+ # Parallel testing breaks database access
+ DBDPG_TEST_ALWAYS_ENV=1 DIST_TEST="do" perl-module_src_test
+
+}
diff --git a/dev-perl/DBD-Pg/Manifest b/dev-perl/DBD-Pg/Manifest
index d9c4b65f6f81..935042debacb 100644
--- a/dev-perl/DBD-Pg/Manifest
+++ b/dev-perl/DBD-Pg/Manifest
@@ -1,4 +1,5 @@
DIST DBD-Pg-3.10.0.tar.gz 268414 BLAKE2B da6ac65519632aa95ee2554607d5e26820527042873ab78a9e40e671902b1b8e2fe39f37e44b15cf3db8eda243e57c7fab9077d4a08ec7f3c312825609fbc805 SHA512 46c985bbdeeed4ef60d6fe06034fa0959df288f2b9bbd434e2716676a3cb7a1ded168a3cf87a6a82eb397eb8edcc023c0b85483e948ce31abcac64a1919580ba
+DIST DBD-Pg-3.13.0.tar.gz 278332 BLAKE2B cf405cd2afd5095fb7bc824b9fc4ca3c9aa86c3bf0bfe0a651ea21ec48921e97d20b8a4fffc3847d1ebe4c737d29671564b48fafea2f71f7fa0128733f47d0a9 SHA512 70fcf250f143d974fcb96fe597464bd5c91453fe00b36521afbf13e98c60f38ece4e79fa7e0076b273c4e30d67748c0c3be0879ba569a278fb1b1f2124da8913
DIST DBD-Pg-3.5.3.tar.gz 256570 BLAKE2B f589fc4ed978d2215d66b4cfd72b00e166f15dbe2caf004fa52c09fc6fc9f9b81ed84bc04ec0c4d3fe15f4eabb5a8a3b24b08acabb66b993c3ce67576a4c1721 SHA512 7a564e5c86fa41719289f6e391f0cd39f01df7d088892fca11175c60fec8a3af884f9204ae834caac2024ff0d45dcc013e314ec0c09a07fe7ee76170ec3a634f
DIST DBD-Pg-3.6.2.tar.gz 258640 BLAKE2B 76e25905b0336eae4ead14c28cf8338412fec023ea0540fc80f5c8d02b1c46de1b42ee8be2230fb3276aa3c8fa2bda9a97ddbd41fc81617a557359907c02d600 SHA512 1f55bd463d90cd0d9933acde0a79462a57f11e7ed9519943cc2cb4487b4b69edd7d16ffa3d666c50aca797f9756ff4e6a0d67b58bc100f4920da36169d73b7b4
DIST DBD-Pg-3.7.0.tar.gz 260083 BLAKE2B 73ae253e8033dab58075f6dc3c639e5d21f2df09880f59cb00fcdc201c17db1573e4902c4bfd535916775c0ef61a020a70e8f542ce28e257a903d4aabb9f6730 SHA512 edd4d3448dac1b563899c5fd4a1bad6cb810afdbbbf57b558bbe6710aa3e58530a6cf0932e35c3316c7f4f59763764d75ce1049f13c8c13deeb2e8a7c60ff73e