summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-13 13:16:31 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-13 14:18:25 -0500
commit5b63c143676ed5d0201f703b41421e2ec6930957 (patch)
treefc6d53c9b76c506bbd122ad24cfa51377e028d53 /dev-php/PEAR-Crypt_CHAP
parentdev-lang/rakudo: Bump (diff)
downloadgentoo-5b63c143676ed5d0201f703b41421e2ec6930957.tar.gz
gentoo-5b63c143676ed5d0201f703b41421e2ec6930957.tar.bz2
gentoo-5b63c143676ed5d0201f703b41421e2ec6930957.zip
dev-php/PEAR-Crypt_CHAP: Revbump to include a fixed constructor patch
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/PEAR-Crypt_CHAP')
-rw-r--r--dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r2.ebuild26
-rw-r--r--dev-php/PEAR-Crypt_CHAP/files/CHAP-1.5.0-constructor.patch65
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r2.ebuild b/dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r2.ebuild
new file mode 100644
index 000000000000..b07a5c6270e9
--- /dev/null
+++ b/dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Generating CHAP packets"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RDEPEND="dev-lang/php:*[crypt,hash]"
+DEPEND="test? ( ${RDEPEND} dev-php/PEAR-PEAR )"
+PATCHES=( "${FILESDIR}/CHAP-1.5.0-constructor.patch" )
+
+src_install() {
+ php-pear-r2_src_install
+ insinto /usr/share/php/Crypt
+ doins CHAP.php
+}
+
+src_test() {
+ pear run-tests tests/Crypt_CHAP.phpt || die
+}
diff --git a/dev-php/PEAR-Crypt_CHAP/files/CHAP-1.5.0-constructor.patch b/dev-php/PEAR-Crypt_CHAP/files/CHAP-1.5.0-constructor.patch
new file mode 100644
index 000000000000..6fa92898e106
--- /dev/null
+++ b/dev-php/PEAR-Crypt_CHAP/files/CHAP-1.5.0-constructor.patch
@@ -0,0 +1,65 @@
+diff -aurN a/CHAP.php b/CHAP.php
+--- a/CHAP.php 1970-01-01 04:13:08.000000000 -0500
++++ b/CHAP.php 2018-02-13 13:04:49.812389739 -0500
+@@ -78,7 +78,19 @@
+ * @var integer
+ */
+ var $chapid = 1;
+-
++
++ /**
++ * Constructor
++ *
++ * Generates a random challenge
++ * @return void
++ */
++ function __construct()
++ {
++ parent::__construct();
++ $this->generateChallenge();
++ }
++
+ /**
+ * Constructor
+ *
+@@ -160,7 +172,19 @@
+ * @var bool
+ */
+ var $flags = 1;
+-
++
++ /**
++ * Constructor
++ *
++ * Loads the hash extension
++ * @return void
++ */
++ function __construct()
++ {
++ parent::__construct();
++ $this->loadExtension('hash');
++ }
++
+ /**
+ * Constructor
+ *
+@@ -412,6 +436,19 @@
+ /**
+ * Constructor
+ *
++ * Generates the 16 Bytes peer and authentication challenge
++ * @return void
++ */
++ function __construct()
++ {
++ parent::__construct();
++ $this->generateChallenge('peerChallenge', 16);
++ $this->generateChallenge('authChallenge', 16);
++ }
++
++ /**
++ * Constructor
++ *
+ * Generates the 16 Bytes peer and authentication challenge
+ * @return void
+ */