summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2022-06-14 18:07:31 +0200
committerSam James <sam@gentoo.org>2022-06-15 23:05:29 +0100
commit918319a820d9e146559489b733345297a1ded29b (patch)
tree60d1576286028a8db11131bbc52ec4be409bde54 /dev-php/libvirt-php
parentsys-devel/gdb: fix cross build issues with configuring gmp libs (diff)
downloadgentoo-918319a820d9e146559489b733345297a1ded29b.tar.gz
gentoo-918319a820d9e146559489b733345297a1ded29b.tar.bz2
gentoo-918319a820d9e146559489b733345297a1ded29b.zip
dev-php/libvirt-php: bump to v0.5.6
Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25903 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-php/libvirt-php')
-rw-r--r--dev-php/libvirt-php/Manifest1
-rw-r--r--dev-php/libvirt-php/libvirt-php-0.5.6.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-php/libvirt-php/Manifest b/dev-php/libvirt-php/Manifest
index 560eb6a12413..162d8f03c3ea 100644
--- a/dev-php/libvirt-php/Manifest
+++ b/dev-php/libvirt-php/Manifest
@@ -1,2 +1,3 @@
DIST libvirt-php-0.5.5.tar.gz 761250 BLAKE2B 9899d2f0e5ea387333decce5071afc81d4160d54ef570dcbe04422dc3e93479ee57520f9bf33a0275ee86cd4b1c87e5a3f7d5118e0cd87658faed44d2ccd4807 SHA512 2ea263561a0bf5d155314e06dcf3c3b5c278640bc5edfa674cdd777cb6d0810bda0492c6cf77a02bc88fb6aa99b0ff1f0cbaeea87ff2e45bff9b5774a2507684
DIST libvirt-php-0.5.5_p20211020.tar.bz2 359477 BLAKE2B f4be3cf138364997911b58b07e128e4b5c9e6f1520d876b51466a30cd2ade4035a06488e07b8be4cce65b1bc6585b768997214c9d0ba72cc51855b4fc0827ff4 SHA512 b935c910e8754000de45e88f5d5e61e2e95fbb1b007f0d747bf4cd3531ee9cb0ff5bc2ec6f561c79711df9b70e1c4cdaf2e046774341d29d3f2382d27ab8c494
+DIST libvirt-php-0.5.6.tar.xz 386372 BLAKE2B 30d6a1c8dd18a4bd9d46e9c20551978fa0c20f2d671a359fdbf86def5166df7f882e65c509087efe0acef7d0dc468b3eb520689f9e7ba552e966809c8f647390 SHA512 5d1b3a2afc697051a5a0d4750ce4d02b31f482b1c17ef2cf4a593b705de438d8ccb4b1543ce6b2520b450734b3634e64ccf9200227f5681cbd2daad5a9f5ee9c
diff --git a/dev-php/libvirt-php/libvirt-php-0.5.6.ebuild b/dev-php/libvirt-php/libvirt-php-0.5.6.ebuild
new file mode 100644
index 000000000000..9c565addf6bb
--- /dev/null
+++ b/dev-php/libvirt-php/libvirt-php-0.5.6.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PHP_EXT_NAME="libvirt-php"
+PHP_EXT_SKIP_PHPIZE="yes"
+USE_PHP="php7-4 php8-0 php8-1"
+PHP_EXT_ECONF_ARGS=()
+
+inherit php-ext-source-r3 autotools
+
+DESCRIPTION="PHP bindings for libvirt"
+HOMEPAGE="http://libvirt.org/php/"
+SRC_URI="http://libvirt.org/sources/php/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="app-emulation/libvirt
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ virtual/pkgconfig
+ doc? ( app-text/xhtml1 )"
+
+DOCS=( ChangeLog NEWS README )
+# Remove the insane check for pecl-imagick which is only used in examples
+# and is not called upon in any build
+PATCHES=( "${FILESDIR}/remove-imagick-check.patch" )
+
+src_unpack() {
+ default
+
+ # create the default modules directory to be able
+ # to use the php-ext-source-r3 eclass to configure/build
+ ln -s src "${S}/modules" || die
+}
+
+src_prepare() {
+ php-ext-source-r3_src_prepare
+
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ eautoreconf
+ done
+}
+
+src_install() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ insinto "${EXT_DIR}"
+ doins "src/.libs/${PHP_EXT_NAME}.so"
+ done
+
+ php-ext-source-r3_createinifiles
+ einstalldocs
+
+ if use doc ; then
+ docinto html
+ dodoc -r docs/*
+ fi
+}
+
+src_test() {
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ default
+ done
+}