summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-02 13:26:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-02 13:26:26 +0200
commitc3fe4d4105e7093336a2f2012f9737eb1ae7f3d8 (patch)
treea9382b5127b08887f58f70e2acb36676a726e8cc /dev-python/DBUtils
parentdev-python/ConfigArgParse: Clean MY_P up (diff)
downloadgentoo-c3fe4d4105e7093336a2f2012f9737eb1ae7f3d8.tar.gz
gentoo-c3fe4d4105e7093336a2f2012f9737eb1ae7f3d8.tar.bz2
gentoo-c3fe4d4105e7093336a2f2012f9737eb1ae7f3d8.zip
Rename dev-python/{dbutils → DBUtils}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/DBUtils')
-rw-r--r--dev-python/DBUtils/DBUtils-3.0.2.ebuild32
-rw-r--r--dev-python/DBUtils/Manifest1
-rw-r--r--dev-python/DBUtils/metadata.xml26
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/DBUtils/DBUtils-3.0.2.ebuild b/dev-python/DBUtils/DBUtils-3.0.2.ebuild
new file mode 100644
index 000000000000..56f1b8438672
--- /dev/null
+++ b/dev-python/DBUtils/DBUtils-3.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="DBUtils"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Database connections for multi-threaded environments"
+HOMEPAGE="
+ https://webwareforpython.github.io/DBUtils/
+ https://github.com/WebwareForPython/DBUtils/
+ https://pypi.org/project/DBUtils/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ dodoc docs/*.rst
+ rm docs/*.rst || die
+ local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/DBUtils/Manifest b/dev-python/DBUtils/Manifest
new file mode 100644
index 000000000000..999ddb65d850
--- /dev/null
+++ b/dev-python/DBUtils/Manifest
@@ -0,0 +1 @@
+DIST DBUtils-3.0.2.tar.gz 92566 BLAKE2B ee63b252eedeba18ab1db68c10ebe7b2204bef4d2f7d07fc09a095d632dca97304280ed7f14994644e42835fd61717b88de6902feb97df04533979b2b82625ed SHA512 3e4631b8c30466e0f8be438b980fe98071535ea63e06c69161ffda89ed2716fd84c406ace1b3b78e7811bebbc7d0383f080a43b58ed073c37280a7282cb9ccb6
diff --git a/dev-python/DBUtils/metadata.xml b/dev-python/DBUtils/metadata.xml
new file mode 100644
index 000000000000..5890a14a76bf
--- /dev/null
+++ b/dev-python/DBUtils/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ DBUtils is a suite of tools providing solid, persistent and pooled connections
+ to a database that can be used in all kinds of multi-threaded environments
+ like Webware for Python or other web application servers. The suite supports
+ DB-API 2 compliant database interfaces and the classic PyGreSQL interface.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">WebwareForPython/DBUtils</remote-id>
+ <remote-id type="pypi">DBUtils</remote-id>
+ </upstream>
+</pkgmetadata>