summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-20 11:13:26 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-20 11:13:38 -0500
commitdaa027ef1e0fad380a290c5bcae6c864e50ccda3 (patch)
treeed900e3e9d993a38b1dd866af5184019c0d9f589 /dev-python/alembic/alembic-1.4.2.ebuild
parentdev-libs/kuserfeedback: amd64 stable wrt bug #721452 (diff)
downloadgentoo-daa027ef1e0fad380a290c5bcae6c864e50ccda3.tar.gz
gentoo-daa027ef1e0fad380a290c5bcae6c864e50ccda3.tar.bz2
gentoo-daa027ef1e0fad380a290c5bcae6c864e50ccda3.zip
dev-python/alembic: 1.4.2 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/alembic/alembic-1.4.2.ebuild')
-rw-r--r--dev-python/alembic/alembic-1.4.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/alembic/alembic-1.4.2.ebuild b/dev-python/alembic/alembic-1.4.2.ebuild
new file mode 100644
index 000000000000..500a91574ec7
--- /dev/null
+++ b/dev-python/alembic/alembic-1.4.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://bitbucket.org/zzzeek/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test doc"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+# For test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # suite passes all if run from source. The residual fail & error are quite erroneous
+ rm tests/test_script_consumption.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${EPYTHON} run_tests.py || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}