summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-23 07:52:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-23 07:52:25 +0200
commitb182892d671289d08526ae331757522d6112845f (patch)
tree0777dbac5a1960e27f22a65b4b61e71a06ad817d /dev-python/argparse-manpage
parentdev-python/versioningit: Bump to 2.2.1 (diff)
downloadgentoo-b182892d671289d08526ae331757522d6112845f.tar.gz
gentoo-b182892d671289d08526ae331757522d6112845f.tar.bz2
gentoo-b182892d671289d08526ae331757522d6112845f.zip
dev-python/argparse-manpage: Bump to 4.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argparse-manpage')
-rw-r--r--dev-python/argparse-manpage/Manifest1
-rw-r--r--dev-python/argparse-manpage/argparse-manpage-4.5.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/argparse-manpage/Manifest b/dev-python/argparse-manpage/Manifest
index c4c4627c897b..13ed6c96deff 100644
--- a/dev-python/argparse-manpage/Manifest
+++ b/dev-python/argparse-manpage/Manifest
@@ -1,2 +1,3 @@
DIST argparse-manpage-4.3.gh.tar.gz 54479 BLAKE2B de6b6a5c449eebbd4aae207cfeadc6b16baf33e4ed0b6cc886921ee2e2dcdb48ae25f160dd6679da26fc6566fa483a864bc6dd4a0af800b853452405007f58c0 SHA512 9541ddcbddbd12c2fd0d72cc229d453d5d1d25eb915123c26b9040c6a97db6a72bb4002ada5a86620e9caff7c9bc588f1ee7d0c8241b6369cfb28b0271afdbc3
DIST argparse-manpage-4.4.gh.tar.gz 54603 BLAKE2B 2068e5eb8cf6eecdc4128e0cbb47927577f636178a38ae9ed18cb6aa42baa1dc814b95cb67b3299bd62fc1a63bc25db53cf844b24261b1e2bef9b3dd649cad11 SHA512 d2e1978fec14b6e13d1004a1ae779829c4a584f6fc4e10bd3f5651f72095a1fe010856fec26f6a504c8ce47c95b0124a427f2853c4936987c347ecfb42d28ac1
+DIST argparse-manpage-4.5.gh.tar.gz 54783 BLAKE2B a348ad06990126965b48c64db209f13c91d68329fba57e4287b1a2ac7c246a25aedc25b70bfc01fd19b72c5700a67193da4ef47106a5b8ea863edf859ea07ecd SHA512 b9b166d2469d0fc6c9f6d1112bef553c1de32d1f558be4ef4f9b739b94d83acba2712eb9d324d9f3437bf421b833336c0eab34061ccd7b3cf810591705078bf2
diff --git a/dev-python/argparse-manpage/argparse-manpage-4.5.ebuild b/dev-python/argparse-manpage/argparse-manpage-4.5.ebuild
new file mode 100644
index 000000000000..0c9b3e3aa2cd
--- /dev/null
+++ b/dev-python/argparse-manpage/argparse-manpage-4.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically build man-pages for your Python project"
+HOMEPAGE="
+ https://github.com/praiskup/argparse-manpage/
+ https://pypi.org/project/argparse-manpage/
+"
+SRC_URI="
+ https://github.com/praiskup/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ epytest
+}