summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/attrdict
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/attrdict')
-rw-r--r--dev-python/attrdict/Manifest1
-rw-r--r--dev-python/attrdict/attrdict-2.0.0.ebuild30
-rw-r--r--dev-python/attrdict/metadata.xml14
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/attrdict/Manifest b/dev-python/attrdict/Manifest
new file mode 100644
index 000000000000..ef3f28613a05
--- /dev/null
+++ b/dev-python/attrdict/Manifest
@@ -0,0 +1 @@
+DIST attrdict-2.0.0.tar.gz 8994 SHA256 86aeb6d3809e0344409f8148d7cac9eabce5f0b577c160b5e90d10df3f8d2ad3 SHA512 6dd363eb3bca83c84dcbcdd04fb2a7f5360ff5c97b7e52159c4efe61856a37bb6a9427da00da07cb9222f3cef6de18b94bf2da5d0192372f9252a130fa476b7d WHIRLPOOL 35a9a2ec820756d640990e6cbcd1bbed1145dbcd14a4e099bde618fab3a4a74d5d419a01bb43e7d55a59c295f9a8ae77e5f091c4263f2282d50dcc1a0002c90d
diff --git a/dev-python/attrdict/attrdict-2.0.0.ebuild b/dev-python/attrdict/attrdict-2.0.0.ebuild
new file mode 100644
index 000000000000..bc776d9514f5
--- /dev/null
+++ b/dev-python/attrdict/attrdict-2.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A dict with attribute-style access"
+HOMEPAGE="https://github.com/bcj/AttrDict"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py nosetests || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/attrdict/metadata.xml b/dev-python/attrdict/metadata.xml
new file mode 100644
index 000000000000..db49812b88b6
--- /dev/null
+++ b/dev-python/attrdict/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">attrdict</remote-id>
+ <remote-id type="github">bcj/AttrDict</remote-id>
+ </upstream>
+</pkgmetadata>