summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-16 04:02:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-16 05:03:07 +0200
commita0da3ca699452fbf0ba3132e470e820688d50b33 (patch)
tree15dd9a3016621b245c916f0f4e1e39673aa04f76 /dev-python/botocore
parentapp-misc/jf: new package, add 0.6.2 (diff)
downloadgentoo-a0da3ca699452fbf0ba3132e470e820688d50b33.tar.gz
gentoo-a0da3ca699452fbf0ba3132e470e820688d50b33.tar.bz2
gentoo-a0da3ca699452fbf0ba3132e470e820688d50b33.zip
dev-python/botocore: Bump to 1.31.49
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.31.49.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 1fcbb99f2d8a..68d61bb7385a 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -11,3 +11,4 @@ DIST botocore-1.31.45.gh.tar.gz 11938951 BLAKE2B 842d76cfea05de7515d6dfe8c977c89
DIST botocore-1.31.46.gh.tar.gz 11938173 BLAKE2B 99c9b49b8403d005f0153f1bf89f6da8708b9c39c7ac4d8b00bae181ae1663cda95470ff804e38b582f4a07047a21167475aa75247b4003e8bbca887dadde944 SHA512 51a7d1df2c7c2e7098dbca05e602af0975988fe8ee4c608235608b27a338e016b16b1cf6605a74ebe52e77b335333d06a3c9b4338c2843dca19dec1c64c1407e
DIST botocore-1.31.47.gh.tar.gz 11942023 BLAKE2B 94bdc5b5ca5e5749d40996c7396f1bd4236eeeefeee98b3fef6b452cb0d4c5886b0028f165175a70d7794328113f13ab7449c71b8c375a995f0d1d4b629c807a SHA512 788af17274fca19028eaa61ebc72f17cb40b95d1b354ee88fe063ece5eeff3b3f6f3aacea462c4dd065bcd8f3ddd577d6180c8d3f5d0c8c589dd8d31d60aba94
DIST botocore-1.31.48.gh.tar.gz 11946450 BLAKE2B 5393125dcc346182ea81ebebeb181cc7aad8e64e4ca5d93e23e9fe98d12dd2d175b8ff659864574d6dea15e5248dbbaf7a247f8261e74a9cea48a73e3e6b87f4 SHA512 51e13e1bd2962e4ed1c2dff97e9ead583e78bc3cb43cecc92b79299b3da9f449d244d0218e94506ae2c59ba4be49db21c03af6f6fc1451340f4d7fb2d6c082f3
+DIST botocore-1.31.49.gh.tar.gz 11946203 BLAKE2B 3b3026f0861705cc3467391c673d2e2f8e63af1a2e52b63cad21e5f75bf31f5970a2a5f5a959dc8dcd1be6c3ad67ed10642c79a7d41a24e15e983096818e8197 SHA512 8e1cb12ff7455bbf62c5cf54c2bc1b8f48484ebc6e95b4e061d5bc6388a4ecd3ff4152a1d9aab5cbee84d872d59417cfb1cecb6fd281f1f8dd9e3e7e04cc782d
diff --git a/dev-python/botocore/botocore-1.31.49.ebuild b/dev-python/botocore/botocore-1.31.49.ebuild
new file mode 100644
index 000000000000..7cacb5c3f634
--- /dev/null
+++ b/dev-python/botocore/botocore-1.31.49.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit} -p xdist -n "$(makeopts_jobs)"
+}