summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-28 04:02:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-28 05:18:12 +0200
commitb1bfc1293253931df64790e0b6566ef5b716db4c (patch)
tree7c3da255546fdc6bd9ab8d5c2e8f6d3f77c0843b /dev-python/botocore
parentgames-roguelike/stone-soup: add 0.31.0_pre20231027 (diff)
downloadgentoo-b1bfc1293253931df64790e0b6566ef5b716db4c.tar.gz
gentoo-b1bfc1293253931df64790e0b6566ef5b716db4c.tar.bz2
gentoo-b1bfc1293253931df64790e0b6566ef5b716db4c.zip
dev-python/botocore: Bump to 1.31.73
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.31.73.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index f62d631e9f4f..4a0f5b37f717 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.31.69.gh.tar.gz 11993410 BLAKE2B 3bb478c0d0bb8add09f3659739000ca
DIST botocore-1.31.70.gh.tar.gz 11998773 BLAKE2B 1843caf6976d066b1898a3721303c05a1075acd4cb59393adfa31542647d85d6b9fb3dc06e7710ff0249126bc464eea3bf47e3e484a242100facce7c545ef2d3 SHA512 4b2f0548cd3b223e30537b2ec6d3de2f417b2df0e5c9af00e9cee295483a50f66abcc2ca1d449aa4e85917f0157b249e594f8be7fb919069b97e49b174d53960
DIST botocore-1.31.71.gh.tar.gz 12000913 BLAKE2B 1cb78a9da73deacb302023f785d70645d3e5ecb8f828ebffb32f05f4d4f3343b5a9edf1fb0dd1c353c5bb38e094500ec2e1578c342312dca94ca64928c4d8b28 SHA512 6aa3a66c90cde16decf8b4dd678496d82d69388533105c3c785dca54d73736d2c3bb017ca57a39ea2dd59925ddc09dcd0ef600e8efd85c057356c29d2ce4013a
DIST botocore-1.31.72.gh.tar.gz 12007238 BLAKE2B 3eca25ae134849aebd4d51d6f9c06c5606b9612ef55f46eaa545f1d7e978bb9d8d6a260615500c57d7efec8bc744a01ec4fc290fceaa48d6186847732b3b4a2b SHA512 8a31ab6ac3ba2d5fd565449ea424a482c31a586fec7601c84e64b5cc209d30d16279ccec64e7c2971bbce141b9011103b87b034a807f7d5a875eb0d9f6254050
+DIST botocore-1.31.73.gh.tar.gz 12009409 BLAKE2B 949ecb6e85141ca8e3c01e05f996e47f63e0967ec85dde5772f27d564abca001c642ca1991f45b8fec05f7c105f22f713c5e3a8b5e8a8ea3a1a2026abc92fdac SHA512 cd9f77aad6f17d06a04206abc2ae34285423581f6ae5d1c70635d43dc22d73d46842048f0a0f955147c8fb5e5a071e8d4d597a3f9c28146c74957f4b18c8cd22
diff --git a/dev-python/botocore/botocore-1.31.73.ebuild b/dev-python/botocore/botocore-1.31.73.ebuild
new file mode 100644
index 000000000000..7cacb5c3f634
--- /dev/null
+++ b/dev-python/botocore/botocore-1.31.73.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit} -p xdist -n "$(makeopts_jobs)"
+}