summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-13 17:03:19 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-13 17:47:07 +0200
commitd8a712456ba5502e96bcf35d70ef61a594bc92b9 (patch)
tree4a53cfcd210b22603eb9c1446b8e3f0ae63640db /dev-python/botocore
parentdev-python/findpython: Add GH remote-id (diff)
downloadgentoo-d8a712456ba5502e96bcf35d70ef61a594bc92b9.tar.gz
gentoo-d8a712456ba5502e96bcf35d70ef61a594bc92b9.tar.bz2
gentoo-d8a712456ba5502e96bcf35d70ef61a594bc92b9.zip
dev-python/botocore: Bump to 1.31.46
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.31.46.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 6c3bd2a3005c..aa408e035a05 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -8,3 +8,4 @@ DIST botocore-1.31.42.gh.tar.gz 11936544 BLAKE2B a1da9ec08885f84c458f62142056042
DIST botocore-1.31.43.gh.tar.gz 11936649 BLAKE2B ad663783c71255afac612f96f06b2a64f73bd41f32c02386d613d2c6b9f492943c7194f4e58aa62ece2df748d3812728ebdb0636acb3beb53278448829bad50c SHA512 71a718000c46102bcac50f34b1a477c5f788a2feea74629e4db8ad0b482711dbe8f5799424a304ff04d3bbff4acc68407a960008a1c9fe376972ca05b0c01ac0
DIST botocore-1.31.44.gh.tar.gz 11937780 BLAKE2B 38660a6025cef328a4df7e3f0170a79d86f3febd68056993a0aeb8b30a2729abaa914cd6def8c38c3b61a905eb4736cb6232daa4f2e6d7e7140a3a1e23193206 SHA512 29fa176a6b753fc9005f79a19eed4f1a065e1e34d71cc462647c2260b45cc3c10ee720b06a5c8d4471f6d4e6a7b24ee2ae2d70d7973792c64985edb1e0578d99
DIST botocore-1.31.45.gh.tar.gz 11938951 BLAKE2B 842d76cfea05de7515d6dfe8c977c8981924e400ebf518d5ed139c2c12b517b7136811a50e4bf768fb45d2d18e782e82d9482566d9e90a06cf0e76485fa931a3 SHA512 8ad8de83dbe5aa1b90da0627b25022e80df9b4d759050c5baf72b1cc8f29a8df260017e943c7f4b9b9b5b4b112c4acb15a8998531a48777de926dee54af82424
+DIST botocore-1.31.46.gh.tar.gz 11938173 BLAKE2B 99c9b49b8403d005f0153f1bf89f6da8708b9c39c7ac4d8b00bae181ae1663cda95470ff804e38b582f4a07047a21167475aa75247b4003e8bbca887dadde944 SHA512 51a7d1df2c7c2e7098dbca05e602af0975988fe8ee4c608235608b27a338e016b16b1cf6605a74ebe52e77b335333d06a3c9b4338c2843dca19dec1c64c1407e
diff --git a/dev-python/botocore/botocore-1.31.46.ebuild b/dev-python/botocore/botocore-1.31.46.ebuild
new file mode 100644
index 000000000000..7cacb5c3f634
--- /dev/null
+++ b/dev-python/botocore/botocore-1.31.46.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit} -p xdist -n "$(makeopts_jobs)"
+}