summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-12-01 15:59:28 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-12-01 15:59:28 +0700
commitbd799942be66f21ed99e842a2cfcfc214af3efec (patch)
tree368b8b0f927bbd5df043b90f17052afbb2d15c6d /dev-python/bpython
parentdev-python/curtsies: bump to 0.3.4 (diff)
downloadgentoo-bd799942be66f21ed99e842a2cfcfc214af3efec.tar.gz
gentoo-bd799942be66f21ed99e842a2cfcfc214af3efec.tar.bz2
gentoo-bd799942be66f21ed99e842a2cfcfc214af3efec.zip
dev-python/bpython: bump to 0.20.1
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/bpython')
-rw-r--r--dev-python/bpython/Manifest1
-rw-r--r--dev-python/bpython/bpython-0.20.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/bpython/Manifest b/dev-python/bpython/Manifest
index 34828df66cd2..d1518f5cbe4d 100644
--- a/dev-python/bpython/Manifest
+++ b/dev-python/bpython/Manifest
@@ -1 +1,2 @@
+DIST bpython-0.20.1.tar.gz 223953 BLAKE2B b26ee6e4d41609e9a04a013d90f4ae7f598ba28028d9982a77aa7f11887a60c39855e875ae004b416e375b0c906e066a22a18f0251d2e7192d690fe03afe51c7 SHA512 ff69b175afbb1f050f1aa481966bbc32580b3d113a886f49a97fa8f01e3c8c0edf2c0075785fc61ac616168c97d61ee7daeed85d0b08f1317fb774f7ad6bf439
DIST bpython-0.20.tar.gz 224127 BLAKE2B 6b7334f6657e27eff3f48468ee4eed64b69f9ba9ce92881a28ff57a5d5e60948b30fca689adc7a3aac088d2aa1316bfd43509f4f8d80b4822e8990f2753a2059 SHA512 13c04bd9b9ce0bd1b3775295e249e0505abe3be6c601dc9d90455863fd8bc178abb3fe98b05586c6298ea9308a6b062907abf2979b37b08e4341439b0311a565
diff --git a/dev-python/bpython/bpython-0.20.1.ebuild b/dev-python/bpython/bpython-0.20.1.ebuild
new file mode 100644
index 000000000000..ecf0abab267b
--- /dev/null
+++ b/dev-python/bpython/bpython-0.20.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="https://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.org/project/bpython/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/curtsies-0.2.11[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/jedi[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ "
+# sphinx is used implicitly to build manpages
+BDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+DOCS=( AUTHORS CHANGELOG sample.theme light.theme )
+
+distutils_enable_sphinx doc/sphinx/source --no-autodoc
+distutils_enable_tests unittest
+
+src_prepare() {
+ sed -e 's:test_exec_dunder_file:_&:' \
+ -e 's:test_exec_nonascii_file_linenums:_&:' \
+ -i bpython/test/test_args.py || die
+ distutils-r1_src_prepare
+}