summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-24 10:09:16 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-24 10:23:59 +0100
commitf4a1cc48df80eb2a640f6f7de31747dbad5cb98e (patch)
treeb44d4fdb6678f498bac9eebcee9724bce8d0c5db /dev-python/cffi
parentdev-python/sqlalchemy: Version Bump (diff)
downloadgentoo-f4a1cc48df80eb2a640f6f7de31747dbad5cb98e.tar.gz
gentoo-f4a1cc48df80eb2a640f6f7de31747dbad5cb98e.tar.bz2
gentoo-f4a1cc48df80eb2a640f6f7de31747dbad5cb98e.zip
dev-python/cffi: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/Manifest1
-rw-r--r--dev-python/cffi/cffi-1.4.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/cffi/Manifest b/dev-python/cffi/Manifest
index 938d5514e802..df285655fb34 100644
--- a/dev-python/cffi/Manifest
+++ b/dev-python/cffi/Manifest
@@ -4,3 +4,4 @@ DIST cffi-1.3.0.tar.gz 347342 SHA256 9daa53aff0b5cf64c85c10eab7ce6776880d0ee71b7
DIST cffi-1.3.1.tar.gz 351300 SHA256 d45dd39a770b4afb591c82555f6a8bbc1ac7eb019eda9b621eee1a0a72201220 SHA512 b89fe1b98a2e1492e05a9e69407104a5d5057dbe2730852fb91fae1db66751d35db53186d2f03dc950eb10dd9cecc83e44eb3e6954381dfd80d79519c7938288 WHIRLPOOL 37ea487ae7e5474a903cd259bac3428d04dc8f0ab0623edf8e12979e666d0779a04135e150073deb608a46b63084e51f66023e618637d3f71cc54f2eac84fdb9
DIST cffi-1.4.0.tar.gz 365067 SHA256 afeb3ce1c1e200aeb70313bc0bd94ebba4f2f37b2ae7ce00cabb648f548359eb SHA512 56b446a7635afff3cf33fea97451c98eb102589e19c5c2e249e3f751a38972152c4bcde901fa2a06703d5e01f10d994c5d9bc98af48f8278a8981de2522e45cc WHIRLPOOL 8b41807d02f203132b930247d9f4755e8c5e8c0e2594105cad8f46a902be013947d45420f7389ef34483673516e7ee58bce31f615ae582d4f445d344115fe4dc
DIST cffi-1.4.1.tar.gz 365194 SHA256 61fa9e32cc91744b92b3ec96f74c5910aa6c2f0a9fbba939fbad71dab558b974 SHA512 d58012af471aff5b8d8de84f837bf7f683928dcd4efb11e1b3d54e276e0eb0db143675e42c34ae757710817b9c0795ba97626734bf2e0930c93af055b1009ea6 WHIRLPOOL 74ca6952e3833441dd662b4a9f51c66a5746c74fa98cac5283492ddcfe17bf9314a79c5f4c0acf1592787d29f686e6e78d2a5f20334ca572d64e13d13875e272
+DIST cffi-1.4.2.tar.gz 365490 SHA256 8f1d177d364ea35900415ae24ca3e471be3d5334ed0419294068c49f45913998 SHA512 cdb265c4ae390b6498fab34a2f0920ee6eca65e6b543dfb92a0e64825bcef26e8bd4c9f1f43a15e7696128f38026e467fcdda057e00e939311a465b2b585fc34 WHIRLPOOL c3bad7b0bf27f6994bc21472f4ebadae2453e91a2e714b4801d3fb642bfdfbe838a84bc5c74a446a988629811857a28d49f3e08859c9914a385eebcf39e62f7f
diff --git a/dev-python/cffi/cffi-1.4.2.ebuild b/dev-python/cffi/cffi-1.4.2.ebuild
new file mode 100644
index 000000000000..ce2896f65967
--- /dev/null
+++ b/dev-python/cffi/cffi-1.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# DO NOT ADD pypy to PYTHON_COMPAT
+# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code"
+HOMEPAGE="http://cffi.readthedocs.org/ https://pypi.python.org/pypi/cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc test"
+
+RDEPEND="
+ virtual/libffi
+ dev-python/pycparser[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test -x -v --ignore testing/test_zintegration.py c/ testing/ || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}