summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-18 20:24:13 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-01-16 10:33:29 +0200
commit92035d56d0de01616a77436eca039c4a85bafc13 (patch)
tree5f3f6c7ad557f50e8695a1307faa4abec1bda49f /dev-python/clikit/clikit-0.6.2.ebuild
parentdev-python/crashtest: Python library for managing errors (diff)
downloadgentoo-92035d56d0de01616a77436eca039c4a85bafc13.tar.gz
gentoo-92035d56d0de01616a77436eca039c4a85bafc13.tar.bz2
gentoo-92035d56d0de01616a77436eca039c4a85bafc13.zip
dev-python/clikit: Python utilities for building CLIs
* Dependency of dev-python/cleo Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/clikit/clikit-0.6.2.ebuild')
-rw-r--r--dev-python/clikit/clikit-0.6.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/clikit/clikit-0.6.2.ebuild b/dev-python/clikit/clikit-0.6.2.ebuild
new file mode 100644
index 000000000000..19305d3a66c6
--- /dev/null
+++ b/dev-python/clikit/clikit-0.6.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Group of utilities to build beautiful and testable command line interfaces."
+HOMEPAGE="https://github.com/sdispater/clikit"
+SRC_URI="https://github.com/sdispater/clikit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pastel[${PYTHON_USEDEP}]
+ dev-python/pylev[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/crashtest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # skip failing test
+ rm tests/utils/test_terminal.py || die
+
+ distutils-r1_python_prepare_all
+}