summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 19:20:45 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 19:54:38 +0200
commite3b94b580710615d8fdfa85508c7e52112a7c382 (patch)
treeb8fef7c59d76a846823a9e8df1f5989627cbf775 /dev-python/commonmark
parentdev-python/pygments: Enable py3.11 (diff)
downloadgentoo-e3b94b580710615d8fdfa85508c7e52112a7c382.tar.gz
gentoo-e3b94b580710615d8fdfa85508c7e52112a7c382.tar.bz2
gentoo-e3b94b580710615d8fdfa85508c7e52112a7c382.zip
dev-python/commonmark: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/commonmark')
-rw-r--r--dev-python/commonmark/commonmark-0.9.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/commonmark/commonmark-0.9.1-r1.ebuild b/dev-python/commonmark/commonmark-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..40240b1e76ac
--- /dev/null
+++ b/dev-python/commonmark/commonmark-0.9.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python parser for the CommonMark Markdown spec"
+HOMEPAGE="
+ https://pypi.org/project/commonmark/
+ https://github.com/readthedocs/commonmark.py/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.7.1[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ local -x PYTHONIOENCODING='utf8'
+ "${EPYTHON}" commonmark/tests/run_spec_tests.py || die
+}
+
+src_prepare() {
+ default
+ # Fix file collision with app-text/cmark, see bug #627034
+ sed -i -e "s:'cmark\( = commonmark.cmark\:main'\):'cmark.py\1:" \
+ setup.py || die
+}
+
+pkg_postinst() {
+ ewarn "/usr/bin/cmark has been renamed to /usr/bin/cmark.py due file"
+ ewarn "collision with app-text/cmark (see bug #627034)"
+}