summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-03 08:44:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-03 08:48:24 +0200
commitb106e390031679b9e46201ab063a96400b69d378 (patch)
tree3fa62be70ff143512a1e396d24ed168717975983 /dev-python/dbus-python
parentdev-python/tappy: Enable py3.12 (diff)
downloadgentoo-b106e390031679b9e46201ab063a96400b69d378.tar.gz
gentoo-b106e390031679b9e46201ab063a96400b69d378.tar.bz2
gentoo-b106e390031679b9e46201ab063a96400b69d378.zip
dev-python/dbus-python: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/dbus-python-1.3.2.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/dev-python/dbus-python/dbus-python-1.3.2.ebuild b/dev-python/dbus-python/dbus-python-1.3.2.ebuild
index 5065a91958cf..1a653ddb7cd5 100644
--- a/dev-python/dbus-python/dbus-python-1.3.2.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.3.2.ebuild
@@ -3,22 +3,23 @@
EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
inherit autotools python-r1
DESCRIPTION="Python bindings for the D-Bus messagebus"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings/ https://dbus.freedesktop.org/doc/dbus-python/"
+HOMEPAGE="
+ https://www.freedesktop.org/wiki/Software/DBusBindings/
+ https://dbus.freedesktop.org/doc/dbus-python/
+"
SRC_URI="https://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
IUSE="doc examples test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
RESTRICT="!test? ( test )"
RDEPEND="${PYTHON_DEPS}
@@ -28,12 +29,16 @@ RDEPEND="${PYTHON_DEPS}
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- doc? ( $(python_gen_any_dep '
+ doc? (
+ $(python_gen_any_dep '
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
- ') )
- test? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/tappy[${PYTHON_USEDEP}] )
+ ')
+ )
+ test? (
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/tappy[${PYTHON_USEDEP}]
+ )
"
python_check_deps() {