summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-14 08:08:24 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-14 08:26:38 +0100
commitdf0756a3a68de415ebe1edd64ec5597c89765a20 (patch)
treeb17d859518851a36427d749c9f534f4007baabe3 /dev-python/dict2xml
parentdev-python/pytest-httpserver: Bump to 1.0.9 (diff)
downloadgentoo-df0756a3a68de415ebe1edd64ec5597c89765a20.tar.gz
gentoo-df0756a3a68de415ebe1edd64ec5597c89765a20.tar.bz2
gentoo-df0756a3a68de415ebe1edd64ec5597c89765a20.zip
dev-python/dict2xml: Bump to 1.7.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dict2xml')
-rw-r--r--dev-python/dict2xml/Manifest1
-rw-r--r--dev-python/dict2xml/dict2xml-1.7.5.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/dict2xml/Manifest b/dev-python/dict2xml/Manifest
index e2abaa6075c2..bf9105c02a4c 100644
--- a/dev-python/dict2xml/Manifest
+++ b/dev-python/dict2xml/Manifest
@@ -1 +1,2 @@
DIST dict2xml-1.7.4.tar.gz 14333 BLAKE2B 9d1a5180d6cffed171aa973902d6e88190b8bd90cd9e4d86744b5c074d82e45c7571763aa9cca67d190cf7af1b1fdd155cbff906a44a638dcb3a7033f1be86ba SHA512 13a2b34783e5f6414c173059ba16a2061ecaef41355b7b0099546d704c9c28b1e0f9ea3186d4b0db99083e66a2f22e69e57a4a415b72c00fd1e17bcb435e7462
+DIST dict2xml-1.7.5.tar.gz 14958 BLAKE2B 1907003e3a27a8e1c1a0e7ab1d5c72b310c46e7af7d51f6a1743ca018fb6a070b0b54b4b24afd8c78dd18f83f9f6950031c0076eae83ccc309a341a0df153708 SHA512 88a77fcdc2ec320ba1668b27da4aacfcfc817090aebabc01fce76bff51b316166a0cc1f053884e8012a28e7118449f901465703869245dc662f29cee9665157e
diff --git a/dev-python/dict2xml/dict2xml-1.7.5.ebuild b/dev-python/dict2xml/dict2xml-1.7.5.ebuild
new file mode 100644
index 000000000000..b23f9330ef96
--- /dev/null
+++ b/dev-python/dict2xml/dict2xml-1.7.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Small utility to convert a python dictionary into an XML string"
+HOMEPAGE="
+ https://github.com/delfick/python-dict2xml/
+ https://pypi.org/project/dict2xml/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# dict2xml uses noseOfYeti for its test, which is not yet available.
+RESTRICT="test"
+
+distutils_enable_tests pytest