summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/diff-match-patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/diff-match-patch')
-rw-r--r--dev-python/diff-match-patch/Manifest1
-rw-r--r--dev-python/diff-match-patch/diff-match-patch-20121119.ebuild25
-rw-r--r--dev-python/diff-match-patch/metadata.xml25
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/diff-match-patch/Manifest b/dev-python/diff-match-patch/Manifest
new file mode 100644
index 000000000000..a8d49cad2628
--- /dev/null
+++ b/dev-python/diff-match-patch/Manifest
@@ -0,0 +1 @@
+DIST diff-match-patch-20121119.tar.gz 54113 SHA256 9dba5611fbf27893347349fd51cc1911cb403682a7163373adacc565d11e2e4c SHA512 3daff80a6043a0413c515125a21839d9fa1d71f7e2441f4870ebefed35f1accea711814ad231c65de0e3468bbd01402c977fc063ab120b7d9f0e04ef555a8207 WHIRLPOOL ebd50cd7b86cb6c5b003f09d3c8efccda14cb1b2d158123b424f0c2bd40b37338ac8f13dcf464feb408d661db0ed6134fa9fc5c9954ebf35a3ebce206552b3aa
diff --git a/dev-python/diff-match-patch/diff-match-patch-20121119.ebuild b/dev-python/diff-match-patch/diff-match-patch-20121119.ebuild
new file mode 100644
index 000000000000..35d9c513165f
--- /dev/null
+++ b/dev-python/diff-match-patch/diff-match-patch-20121119.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff, match and patch algorithms for plain text"
+HOMEPAGE="http://code.google.com/p/google-diff-match-patch/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/diff-match-patch/metadata.xml b/dev-python/diff-match-patch/metadata.xml
new file mode 100644
index 000000000000..e01e20080e11
--- /dev/null
+++ b/dev-python/diff-match-patch/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <longdescription lang="en">The Diff Match and Patch libraries offer robust algorithms to perform
+ the operations required for synchronizing plain text.
+ Diff: Compare two blocks of plain text and efficiently return a list of
+ differences.
+ Match: Given a search string, find its best fuzzy match in a block of
+ plain text. Weighted for both accuracy and location.
+ Patch: Apply a list of patches onto plain text. Use best-effort to apply
+ patch even when the underlying text doesn't match.
+ Diff Match and Patch libraries are currently available in Java,
+ JavaScript, C++, C#, Objective C, Lua and Python, although this package
+ contains only Python implementation. Regardless of language, each
+ library features the same API and the same functionality. All versions
+ also have comprehensive test harnesses.</longdescription>
+ <upstream>
+ <remote-id type="pypi">diff-match-patch</remote-id>
+ </upstream>
+</pkgmetadata>