summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-picklefield
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-picklefield')
-rw-r--r--dev-python/django-picklefield/Manifest2
-rw-r--r--dev-python/django-picklefield/django-picklefield-0.3.0.ebuild23
-rw-r--r--dev-python/django-picklefield/django-picklefield-0.3.1.ebuild23
-rw-r--r--dev-python/django-picklefield/metadata.xml9
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/django-picklefield/Manifest b/dev-python/django-picklefield/Manifest
new file mode 100644
index 000000000000..9717f0ede7f4
--- /dev/null
+++ b/dev-python/django-picklefield/Manifest
@@ -0,0 +1,2 @@
+DIST django-picklefield-0.3.0.tar.gz 10334 SHA256 d1db231b9bec426a7f0b1c37ebbf4e5448658a4714820d74f847e2f769baa2f0 SHA512 01ba2f5227c3a4613212b9049cf69dfdcccba3aa79309a71fb107cbb0dd3976b9fe0e481ba79180c0a5d1b6e8039dbc367df35a3250ce57008d7fd572b1020ba WHIRLPOOL c696006ee777049058cc04fc6457f1931b855d6f74424a3e73ad87f5d25901a1ee6122b366c481351433b13cb6f20b9e61f417fc59808b30f31749293e86c074
+DIST django-picklefield-0.3.1.tar.gz 10410 SHA256 d99426be46fd92fe6b64b9f5c5926ea9859394e44ec3ef9e1f7c647d3a26657f SHA512 47e9aa8fda2374672c29dcb1068c9bddb0630bfc95cab401aa611123d1eeb3380f42efeee833542e187e052622d60aec1affb1c43cd96e9e69aadc187feba098 WHIRLPOOL eba9dc88dc688007568e5141e427eb9d49c80890d4da6df9487092471d52ab93556a919fda64e64d05e628f1715b03cba15b1cea7d225aba9f9546b35cf68ab1
diff --git a/dev-python/django-picklefield/django-picklefield-0.3.0.ebuild b/dev-python/django-picklefield/django-picklefield-0.3.0.ebuild
new file mode 100644
index 000000000000..5cf232e1ef76
--- /dev/null
+++ b/dev-python/django-picklefield/django-picklefield-0.3.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implementation of a pickled object field for django"
+HOMEPAGE="http://github.com/shrubberysoft/django-picklefield"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/django-1.1.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/django-picklefield/django-picklefield-0.3.1.ebuild b/dev-python/django-picklefield/django-picklefield-0.3.1.ebuild
new file mode 100644
index 000000000000..fe29ccd8e215
--- /dev/null
+++ b/dev-python/django-picklefield/django-picklefield-0.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implementation of a pickled object field for django"
+HOMEPAGE="http://github.com/shrubberysoft/django-picklefield"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-python/django-1.1.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/django-picklefield/metadata.xml b/dev-python/django-picklefield/metadata.xml
new file mode 100644
index 000000000000..2443d3ac9a4f
--- /dev/null
+++ b/dev-python/django-picklefield/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">django-picklefield</remote-id>
+ <remote-id type="github">shrubberysoft/django-picklefield</remote-id>
+ </upstream>
+</pkgmetadata>